Loss of File and Printer Sharing


H

Harko

Hi everyone,

Sometime in the past few days, I lost and then partially recovered file and
printer sharing capability on one computer of my home network.

The network consists of two MacBooks, an HP Compaq 6510b laptop issued to me
by my employer, and my home workstation, a Dell Dimension 4700. All of these
systems are wireless and connect to an AirPort Extreme, set up for NAT, which
assigns IP addresses to all with DHCP. File sharing was enabled and
functional among all of the computers, and there were two shared printers,
also functional: one connected to the USB port on the AirPort Extreme, the
other connected to my Dell.

The Dell came with XP Home, which I upgraded to XP Professional. The laptop
came with XP Professional. The laptop also came with Windows Firewall
disabled and Symantec Client Firewall (SFC) installed and operating. I set up
an allowed IP address range, covering all of the computers on the network, in
SCF for file and printer sharing. I had also disabled Windows Firewall on the
Dell, installed Zone Alarm, and also configured it for file and printer
sharing. I used Bonjour to configure the shared printers for the PCs with no
problem.

To save desktop space, I often used Remote Desktop to run the laptop from my
Dell without any problems. I'd share files between the two and also print
from the laptop to the Dell's printer, no problem.

Like many others, I lost Internet connectivity when Windows Update
automatically installed SP3 and KB 951748 recently on the Dell. After
researching the problem and reading through discussions here and at other
formums like AumHa, I decided to uninstall Zone Alarm and enable Windows
Firewall on the Dell. I made sure that the File and Printer Sharing exception
was enabled when I did so. I also installed SP3 and KB951748 on the laptop.

In addition to switching to Windows Firewall, I also recently purchased and
installed BitDefender Antivirus 2008 (just the antivirus, not the full
security suite), and I downloaded and ran Seconfig XP on the HOME setting
(which, admittedly now in hindsight, I should probably have understood a bit
better before doing...).

I believe the Seconfig XP caused the initial loss of file and print sharing,
as it closed a lot of ports and disabled things like NetBIOS, etc. My
symptoms at this time were:

* Loss of file and printer sharing over the network for the Dell. It was no
longer able to connect to the shares on the MacBooks or the laptop, nor could
I print to the network printer connected to the router anymore.

* The MacBooks and the laptop were unable to even detect the Dell as a
network computer.

Fortunately, Seconfig XP saved the original configuration, and I was able to
restore it.

After the Seconfig XP restore, my symptoms now are:

*The Dell can now connect to the shares on the MacBooks and the laptop.

*The MacBooks and the laptop can now detect the Dell as a network computer.

*The MacBooks and the laptop are still unable to access the shared folder on
the Dell.

*Trying to use the Add Network Place wizard on the laptop to navigate to
the shares on the Dell, I get the error message "The folder you entered does
not to appear to be valid. Please choose another."

I've ensured that

*the shared folder on the Dell is set to Share this folder
*the share name is correct
*the Everyone object has full access in Permissions
*the File and Printer Sharing exception is still enabled in Windows Firewall

I've also followed the procedure in the Troubleshooting File and Printer
Sharing in Windows XP document located at
http://www.microsoft.com/downloads/...8d-6b4a-448e-a632-076f98a351a2&displayLang=en. Still no luck.

I saw on another thread in this forum that some antivirus software can
interfere with file and printer sharing. Could the BitDefender AV be
interfering? It does have a feature called real-time scan, which does scan
network traffic on its default setting.

Any help is appreciated; I'm happy to supply more information as required.
 
Ad

Advertisements

H

Harko

Since my first post, I've made a bit of progress after some more research.

The fellow posting here:

http://forums.practicallynetworked.com/showthread.php?s=&threadid=833

has a useful file-sharing checklist; working through it, I found out that
the Security policies in the checklist:

- Access this computer from the network: add guest
- Deny logon locally: remove guest
- Network access:Sharing and security model... -> Guest only
- Deny access to this computer from the network-> check Guest is not here.

had been changed on the Dell; I pretty much had to set all four of those
listed above back to the settings recommended. The only problem I had was not
being able to (or knowing how to) add just "Guest" to the Access this
computer from the network policy; it forced me to choose a location, which is
the computer name, so now what's added is ComputerName\Guest.

After a restart, the MacBooks can now access the Dell's shares as they used
to, connected as "Guest".

However, I still cannot access the Dell from the laptop; the symptoms are
the same as in the first post.

Below are the result of trying to run "net view \\dellipaddress" from the
laptop's command line:



c:\Documents and Settings\harko> net view \\10.0.1.197
System error 5 has occurred.

Access is denied.

c:\Documents and Settings\harko> net view \\10.0.1.197



I hope this helps further.

--Harko
 
Ad

Advertisements

H

Harko

Solved. Full file and print sharing restored between all computers on the
network.

Apparently at some point during my ill-advised fiddlings, the Dell had left
the workgroup that all the other computers are in and joined its own domain,
which totally jacked up the sharings. Once I switched the Dell back to the
workgroup, everything was fine again.

My thanks to a very patient and pleasant Microsoft technical support person
named Avinash over in India, with whom I spent four hours in a chat session
this morning, to help figure that out.

--Harko
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top