L'objet ne contient pas d'objet d'automatisation


C

Christian82

Bonjour à toutes et à tous,

ACCESS 2002
J'ai construit un formulaire basé sur table1 qui contient un sous formulaire
basé sur une requête liant table2 à table3 dans une relation 1 à plusieurs.
Le formulaire et le sous formulaire sont liés par deux champs : Id_table1
(numèro auto, père) et Id_table1 (EntierLong situé dans table2 , fils). Dans
le sous formulaire une procédure évènementielle sur perte focus d'un
contrôle, met à jour 3 autres contrôles, par une instruction

Private Sub FraisVente_LostFocus()
Me.Date3 = Me. Date2
Me.PrixTotal = Me.PU * Me.Q + tva
Ref_tbl3 = Ref_tbl2
End Sub

Les numéros liés aux noms des contrôles correspondent aux numéros des
tables.
Tout se passe bien si l'on entre des données dans le sous formulaire ouvert
seul. Mais si l'on ouvre le formulaire, lors de la saisie, on obtient le
message suivant:
"L'objet ne contient pas d'objet d'automatisation "table2". Vous avez essayé
d'exécuter une procédure VisualBasic pour définir une propriété ou une
méthode pour un objet. Cependant, le composant ne rend pas la propriété ou
la méthode disponible pour les opérations d'automatisation."

Merci de votre aide

Christian
 
Ad

Advertisements

C

Christian82

Bonsoir,
Je crois que je me suis trompé de groupe, je vais sur le groupe francais
:))
Cordialement
Christian
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top