ImgBurn Waiting for hard disk activity to reach threshold level...


M

Mark Cook

What does this WinXP ImgBurn 2.3.2.0 error mean?
W 16:22:28 Waiting for buffers to recover...
W 16:22:43 Waiting for hard disk activity to reach threshold level...

Does it mean I have a slow hard disk?
 
Ad

Advertisements

K

Krazee Brenda

What does this WinXP ImgBurn 2.3.2.0 error mean?
W 16:22:28 Waiting for buffers to recover...
Cialis

W 16:22:43 Waiting for hard disk activity to reach threshold level...
See Alice.
Does it mean I have a slow hard disk?
Hoping so.
 
T

TERRI HOJABOOM

What does this WinXP ImgBurn 2.3.2.0 error mean?
W 16:22:28 Waiting for buffers to recover...
W 16:22:43 Waiting for hard disk activity to reach threshold level...

Does it mean I have a slow hard disk?
The biggest problem with DVD drives running extremely slowly on Windows XP
has been solved very many times on the ImgBurn forums.

Essentially your Windows XP computer has automatically lowered the
performance of your DVD burner by switching from DMA to PIO automatically.
The solution is to switch back to DMA. It's a bug in Windows that the
Microsoft engineers never got around to fixing over the years.

To test whether you are in the slow POI mode or the fast DMA mode, simply
go to:
My Computer > Properties > Hardware > Device Manager

You should see something like:
IDE ATA/ATAPI controllers
- Intel® 82801FB/FBM Ultra ATA Storage Controllers - 266F
- Primary IDE Channel

Look at the "Advanced Settings" tab for the "Primary IDE Channel":
- Device 0
- Device Type = Auto Detection
- Transfer Mode = DMA if available
- Current Transfer Mode = PIO Mode

Device 1
- Device Type = Auto Detection
- Transfer Mode = DMA if available
- Current Transfer Mode = PIO Mode

But you don't want to ever be in PIO mode. You have to fight Windows XP
tooth and nail to win this battle. But it can be won. In the end, you
should see your drivers in PIO mode:

Device 0
- Device Type = Auto Detection
- Transfer Mode = DMA if available
- Current Transfer Mode = Ultra DMA Mode 5

Device 1
- Device Type = Auto Detection
- Transfer Mode = DMA if available
- Current Transfer Mode = Ultra DMA Mode 2

Basically, you must monthly delete the existing drivers and reboot the
Windows XP computer. Windows XP will then reinstall the drivers in DMA mode
and your slow DVD burn will be resolved! Until Windows switches you back to
POI mode again!

Do this every month and you will be just fine!
For more information, see the Microsoft KB article:

IDE ATA and ATAPI disks use PIO mode after multiple time-out or CRC errors
occur http://support.microsoft.com/?kbid=817472
 
T

TERRI HOJABOOM

Hoping so.
Ignore the KB troll.

The answer to this very common Windows hard disk problem is in the ImgBurn
forums. Just search for "Waiting for buffers to recover..." or
:Waiting for hard disk activity to reach threshold level...".

I found this entry just now:
http://forum.imgburn.com/index.php?showtopic=59&st=0&p=967&#entry967

Note this is actually a Windows XP bug and not an ImgBurn problem at all.

But people who burn DVDs run into this Windows XP bug all the time so they
are the best ones who have characterized the slow DVD burning problem more
fully.
 
T

TERRI HOJABOOM

The answer to this very common Windows hard disk problem is in the ImgBurn
forums. Just search for "Waiting for buffers to recover..." or
:Waiting for hard disk activity to reach threshold level...".

I found this entry just now:
http://forum.imgburn.com/index.php?showtopic=59&st=0&p=967&#entry967

Note this is actually a Windows XP bug and not an ImgBurn problem at all.

But people who burn DVDs run into this Windows XP bug all the time so they
are the best ones who have characterized the slow DVD burning problem more
fully.
Slow DVD burns are a very common Windows XP bug.

In addition to the Microsoft Knowledge Base article "IDE ATA and ATAPI
disks use PIO mode after multiple time-out or CRC errors occur" at
http://support.microsoft.com/?kbid=817472, there's more about this common
Windows XP DVD burner DMA to PIO bug at
http://forum.imgburn.com/index.php?showtopic=3713&hl=threshold+level and at
http://forum.imgburn.com/index.php?showtopic=3826&hl=threshold+level and at
http://forum.imgburn.com/index.php?showtopic=59&st=0&p=967&#entry967
 
T

TERRI HOJABOOM

How To Enable DMA For Windows XP

For Windows XP, Direct Memory Access is not set for individual Hard Drives
and CD Rom Drives as depicted above. Instead, DMA is set for the Primary
IDE Channel and the Secondary IDE Channel. In short, each Channel allows us
to have two devices connected for a total of four devices. These devices
can be a combination of Hard Disk Drives, CD Rom Drives, CDRW Drives, DVD
Drives and Tape Backup Drives etc. Therefore, if both channels are set for
DMA access, then all the devices in your system will be set to use DMA.
For Windows XP

1. Go into your Control Panel by first clicking on the Start Button.
2. Then click on the Control Panel icon located in the right column of the
Start Menu.
3. If your Start Menu is set to the Classic View, then begin by clicking on
the Start Button.
4. Then click on Settings, then click on the Control Panel icon to open up
the Control Panel.
5. Now, Double click on the System icon to open up the System Properties
window.
6. Now click on the Hardware tab located at the top of the screen.
7. Then click on the Device Manager button in the center area of the
screen.
8. Now click on the plus sign [+] next to the IDE ATA/ATAPI controllers to
expand that section.
9. Then double click on the Primary IDE Channel to display the Primary IDE
Properties window.
10. Then click on the Advanced Settings Tab at the top of the screen.
11. Now for Device 0, ensure that the Transfer Mode: selection is set to
DMA if available.
12. Then for Device 1, ensure that the Transfer Mode: selection is also set
to DMA if available.
13. Then click on the OK button at the bottom of the screen to save your
settings.
14. Then double click on the Secondary IDE Channel to display the Secondary
IDE Properties window.
15. Then click on the Advanced Settings Tab at the top of the screen.
16. Now for Device 0, ensure that the Transfer Mode: selection is set to
DMA if available.
17. Then for Device 1, ensure that the Transfer Mode: selection is also set
to DMA if available.
18. Then click on the OK button at the bottom of the screen to save your
settings.
19. Then close Device Manager and the Control Panel to return back to your
Windows session.

http://www.real-knowledge.com/dma.htm
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top