IME Problems with MS ACCESS 2003.



Hi, I currently have the Korean IME installed and am developing an Access DB.

I have set all fields to IME Mode = Off.

While I tab through the table or the form bound to the table, my IME mode
changes ONLY if the field has an input mask set.

To reiterate, tabbing into any field that has an input mask will change my
IME Mode (changing the Icon from EN to KO) even if the IME Mode is set to Off
for that field.

Any help would be much appreciated,

Matt Moore



To make matters more confusing, it seems that some input masks do not cause
this behavior while others do.

Also, one input mask in one table causes the IME Mode to change, but the
exact same input mask in another table does not cause the IME mode to change.

I'm so confused. I cannot see any link between the errant fields to track
down this problem.


Ok I solved it.

What was happening was that everytime the cursor (caret) highlighted an
input mask placeholder (#,*,@......) it would switch IME modes no matter what
IME Mode I set it too in the table design.

I changed my Windows Setting --> Language for Non-Unicode Programs from
Korean to English.

This has solved the problem. It seems that the input mask placeholders are
Non-Unicode, thus switching the input modes.

If this is a bug then it should be addressed. If this is working as
intended then it should be added to the documentation.

Take care,

Matt Moore

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question