ICS b/w 2 win2k pros, while one is part of a domain?


T

Taariqq

Hi all, a newbie here.

I have a computer (win 2000 pro), where I have an internet access via
ethernet cable, that is made part of a domain in order to provide the
internet access. It is actually a strange scinario, and this is how it
works locally in Pakistaan. The local broadband internet provider has a
DSL connection, which he redistributes to end user, using DHCP. But, in
order to get this connection, the computer has to become part of the
ISP's domain. No modem or router involved locally. When starting the
computer, I log into the domain 'cable.xyz', with the given username
and password, and I am on the net, as well as able to share the network
folders at the ISP's machines. ... Let's call this computer A.

I am trying to share the internet access of computer A with another win
2000 pro machine (computer B).

I can ping both A & B from each other, and I can even ping the cable
provider domain from B, but I can't surf the net from machine B!

Machine A has 2 NICs as follows;
1st NIC 'Cable' (connecting to ISP) has Client for microsoft network,
NetBEUI protocol and TCP/IP, and I have the ICS enabled, with the
option of Obtain IP and DNS automatically ... otherwise the internet
connection won't work.
ipconfig at command prompt reveals the following;

Connection-specific DNS suffix: cable.xyz
IP address
: 10.10.71.239
Subnet Mask
: 255.255.0.0
Default Gateway
: (blank)

2nd NIC 'Local' (connecting to hub) has Client for microsoft network
NetBEUI
protocol
and TCP/IP
ICS is 'not'
enabled on this NIC.
have 'static' IP
of 192.168.0.1 & subnet 255.255.255.0
and there is no default gateway or
DNS address provided.

Machine B has only one NIC as follows;
Local has Client for microsoft
network
and TCP/IP
'no' NetBEUI
with obtain IP and DNS
automatically.

ipconfig reveals the following; Connection-specific DNS
suffix: cable.xyz
IP address
: 192.168.0.2
Subnet Mask
: 255.255.255.0
Default Gateway
: 192.168.0.1

Now ...
from either machine I can ping either 192.168.0.1/2
I am also able to ping cable.xyz, as well as other servers on the ISP,
.... BUT ... I can't surf the net from machine B.

I have Zone Alarm shut down on both machines, but machine A does have
the 'windows firewall client' running, connecting to ISA server at the
ISP

I just need to be able to surf the net form machine B.

Sorry for the long post, any help would be greatly appreciated, and TIA

Sincerely.
 
Ad

Advertisements

D

Doug Sherman [MVP]

Try:

1. On computer A run ipconfig /all and note the DNS server IP.

2. Manually configure computer B:

IP address 192.168.0.2
Subnet mask 255.255.255.0
Default Gateway 192.168.0.1
Primary DNS <The address you noted in #1>.

3. Unless you are using a proxy server, the 10.10.71.239 adapter cannot
have a blank default gateway. If computer A uses a proxy server, try
configuring this on computer B as well.

4. There is no obvious need for NetBEUI.

Doug Sherman
MCSE, MCSA, MCP+I, MVP
 
T

Taariqq

Doug, thanks for replying.

I configured computer B manually, with the 10.10.71.239 adapter's DNS,
which was 10.10.1.1 ... still no go.

Two points come to my mind ...
First about the proxy server, as you asked. Yes, after making machine A
part of the cable provider domain, I had to download something called
'windows firewall client', and configure it to use 'ISA server4', and
on connection settings of the browser, I had to chose 'manual proxy
configuration' (firefox) with 10.10.1.4 (server4 address) with port:
8080.

I have also configured computer B directly to cable provider (while
computer A was off-line) ... and the browsing works fine, but when when
I try to download 'windows firewall client' to configure the computer B
to use ISA server4, it does not install, with a message that says
'autoexec.nt not suitable for running windows application'.
Besides the point is that I want to be able to surf B thru A.

Second point is that computer A has been forced to be a part of a
domain on the cable connection provider, while computer B is part of
workgroup ... could that be the problem? For ICS to work, don't they
have to be part of the same network?

I also have a cable/dsl router with switching capabilities, and a dhcp
server.
I tried connecting the cable connection to WAN port, and use the router
dhcp to configure both computers (the way I was sharing Verizon DSL in
Boston) ... no go .... most prolly because one computer has to be a
part of the cable provider domain!?

If there is a way to use the Gigafast EE400-RP router that I have, to
connect to the provider ... I'D BE THRILLED ..... but the big problem
is that the physical computer name on computer A had to be changed, so
that it could be registered with the cable provider, in order to make
it a part of the domain.

If I can figure out either one of the two .. a) keep A part of
cable.xyz domain, and B part of workgroup, and share internet
connection, or ... b) use my router to connect to cable provider,
making them believe that I am logging in with computer A .... Username,
pwd and domain might work from the router, but I think the netbios
computer name might still be a problem?!

There has to be a way.

TIA
Tariq
 
D

Doug Sherman [MVP]

Yuck - you may be out of luck, ie. the ISP's ISA server may be configured to
block machines such as computer B. However, try:

1. Copy autoexec.nt from computer A to computer B - file should be in
WINDOWS\System32. If you still cannot complete the install, delete all
proxy server info on computer B and try:

2. Configure the 10.10.71.239 adapter on computer A with 10.10.1.1 as a
default gateway. If this turns out to be a correct guess, computer B may be
able to bypass the proxy server and access the Internet.

Doug Sherman
MCSE, MCSA, MCP+I, MVP
 
T

Taariqq

Tried both, still no go. Looks like my ISP really does not want me to
be sharing the connection ... oh well.
Copying the autoexec.nt at least let me install the firewall client on
B.
Thanks for the tips.

Tariq
 
Ad

Advertisements

D

Doug Sherman [MVP]

I think you are correct - your ISP has employed this unusual configuration
precisely for the purpose of preventing what you want to do.

Doug Sherman
MCSE, MCSA, MCP+I, MVP
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top