=HVIS


G

Guest

Hej er der nogen son kan hjælpe mig med at rette det her...

Den Her kan jeg få til at virke
=HVIS(B11=1000000;"T B";HVIS(B11=2600280;"N K";HVIS(B11=2900210;"A
L";HVIS(B11=0900700;"Kalle B";HVIS(B11=1400530;"Kaj
B";HVIS(B11=2811050;"Chris L";HVIS(B11=1600390;"K
Jensen";HVIS(B11=2512000;"Bjarne F";" "))))))))

MEN DEN HER KAN JEG IKKE ???????
=HVIS(B11=1000000;"T B";HVIS(B11=2600280;"N K";HVIS(B11=2900210;"A
L";HVIS(B11=0900700;"Kalle B";HVIS(B11=1400530;"Kaj
B";HVIS(B11=2811050;"Chris L";HVIS(B11=1600390;"K
Jensen";HVIS(B11=2512000;"Bjarne F"HVIS(B11=1000001;"K B";HVIS(B11=2600281;"K
K";HVIS(B11=2900200;"M L";HVIS(B11=0900701;"K C";HVIS(B11=1400500;"J
B";HVIS(B11=2811000;"C L";HVIS(B11=1600300;"K J";HVIS(B11=2510000;"B F";"
"))))))))))))))))

Er der nogen der kan fortælle mig hvad jeg gør forkert !!!!!
 
Ad

Advertisements

G

Guest

prøv med:

=INDEKS({"T B";"N K";"A L";"Kalle B";"Kaj B";"Chris L";"K Jensen";"Bjarne
F";"K B";"K K";"M L";"K C";"J B";"C L";"K J";"B
F"};SAMMENLIGN(B11;{1000000;2600280;2900210;900700;1400530;2811050;1600390;2512000;1000001;2600281;2900200;900701;1400500;2811000;1600300;2510000};0))
 
G

Guest

Excel har en begrænsning på 7 indlejrede HVIS'er, dette kan man dog
komme udenom ved at indsætte et & efter hver 7 HVIS sådan:

=HVIS(B11=1000000;"T B";HVIS(B11=2600280;"N K";HVIS(B11=2900210;"A
L";HVIS(B11=900700;"Kalle B";HVIS(B11=1400530;"Kaj B";HVIS(B11=2811050;"Chris
L";HVIS(B11=1600390;"K Jensen";)))))))&HVIS(B11=2512000;"Bjarne
F";HVIS(B11=1000001;"K B";HVIS(B11=2600281;"K K";HVIS(B11=2900200;"M
L";HVIS(B11=900701;"K C";HVIS(B11=1400500;"J B";HVIS(B11=2811000;"C
L";)))))))&HVIS(B11=1600300;"K J";HVIS(B11=2510000;"B F";" "))
 
G

Guest

Ja det virker men kun op til 26 så skriver den den er for lang ved nr 27 skal
bruge 35
 
Ad

Advertisements

G

Guest

ok,- hvad så ?

kan du så udvide indeks formlen så det passer ?

eller har den også begænsninger ?
 
H

Harald Staff

Glem det der HVISeri. En LOPSLAG-funksjon er vel så godt egnet til denslags,
og langt nemmere å lese/vedlikeholde.

(Poster wants a zillion nested danish IFs. This is a VLOOKUP suggestion)

HTH. Best wishes Harald
 
Ad

Advertisements

G

Guest

Jo det er der men det hjælper ikke ret meget når man ikke kan fatte det der
står !!!!
 
G

Guest

her er 37 betingelser,- virker fint her !!!!!!

hvis formlen ikke hænger sammen når du paster den til arket, gøres følgende:

i en tom celle tast = flyt markør til første linie, tast & flyt til anden
linie, tast & flyt til 3 linie tast & (eller hvis sidste tat enter)

højreklik på denne celle, vælg kopier, højreklik igen, vælg indsæt speciel,
vælg værdier.

=INDEKS({"T B";"N K";"A L";"Kalle B";"Kaj B";"Chris L";"K Jensen";"Bjarne
F";"K B";"K K";"M L";"K C";"J B";"C L";"K J";"B
F";"a";"b";"c";"d";"e";"f";"g";"h";"i";"j";"k";"l";"m";"n";"o";"p";"q";"r";"s";"t";"u"};SAMMENLIGN(B11;{1000000;2600280;2900210;900700;1400530;2811050;1600390;2512000;1000001;2600281;2900200;900701;1400500;2811000;1600300;2510000;1;2;3;4;5;6;7;8;9;10;11;12;13;14;15;16;17;18;19;20;21};0))
 
Ad

Advertisements

Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

Scan in Word 2007 1
discodragt 1
Navigering med piletaster 1
Share and download your ebooks and journal 0

Top