How to specify program to open file with?


J

joeu2004

I have an ASCII file that was extracted from a Unix
tarball using WinZip, with "smart CR/LF" enabled. So
it is, in effect, a text file. But because the file
does not have a ".txt" extension, MSWin does not open
the file with Notepad. Instead, it opens it with
QuickViewPlus, which apparently is associated with
that file type ("file").

How can I open the file with Notepad without changing
the system-wide program associated with the "file" type?

(That is, without going to Start -> Settings -> Control
Panel -> Folder Options -> File Types, for example.)

I know that I can start Notepad, then use File -> Open
and changing the File Name field to "*".

But I would prefer an operation that I can use by
simply clicking on the file icon in the folder, more
or less.

I know that I can append ".txt" to the file name.
That changes the file type to "text document", which
Notepad is associated with.

But I would prefer not to have to rename the file.

I thought I could right-click on the file icon and
select "Open With...". But I do not see that choice
when the file does not have the ".txt" extension.

Is there some other way to do "Open With..."?

(Ironically, the "Open With..." choice __does__ exist
when the file name has the extension ".txt". Go
figure!)
 
Ad

Advertisements

G

Guest

You should be able to press shift key, then right click on the file you want,
then choose open with on the little menu. I don't think this will change it
accross the board, I believe it is only in effect for that one time. I hope
this helps.

Lonnie
 
J

joeu2004

Lonnie said:
You should be able to press shift key, then right click on the file you want,
then choose open with on the little menu. I don't think this will change it
accross the board, I believe it is only in effect for that one time. I hope
this helps.

Thanks for the response, but I'm afraid I see not difference
between shift-right click and right click. In both cases,
there is no "Open With..." option if there is not (standard)
file extension like ".txt". I neglected to mention that I am
using MSWin XP SP2.
 
A

AnonPoster

I have an ASCII file that was extracted from a Unix
tarball using WinZip, with "smart CR/LF" enabled. So
it is, in effect, a text file. But because the file
does not have a ".txt" extension, MSWin does not open
the file with Notepad. Instead, it opens it with
QuickViewPlus, which apparently is associated with
that file type ("file").

How can I open the file with Notepad without changing
the system-wide program associated with the "file" type?

(That is, without going to Start -> Settings -> Control
Panel -> Folder Options -> File Types, for example.)

I know that I can start Notepad, then use File -> Open
and changing the File Name field to "*".

But I would prefer an operation that I can use by
simply clicking on the file icon in the folder, more
or less.

I know that I can append ".txt" to the file name.
That changes the file type to "text document", which
Notepad is associated with.

But I would prefer not to have to rename the file.

I thought I could right-click on the file icon and
select "Open With...". But I do not see that choice
when the file does not have the ".txt" extension.

Is there some other way to do "Open With..."?

(Ironically, the "Open With..." choice __does__ exist
when the file name has the extension ".txt". Go
figure!)
There's a powerful program called X-Setup that will, among other things,
add "Open with" to the context menu when you right-click on a file.
It's free at this url:

http://www.x-setup.net/

After you install it, use the search function to search for "open with."
Be very careful with this program and heed its warnings about changing
certain settings. It has very powerful voodoo magic ;-) On the other
hand, I've been using it for years to do things like control my startup
and add open with to context menus and I love it!!
 
Ad

Advertisements

G

Guest

I'm also using windows xp pro sp2. Are you holding the shift key down while
you right click on the file? If not then that is the problem. If you
already are, then I don't know of anything else I can suggest except to chage
it through the file type method.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top