How to set NOTEPAD to save to UNICODE as default


R

*rain*drops*

I guess the title says it: In XP, how do I set NOTEPAD to save to UNICODE
as default. I posted a similar query and recieved just one response,
recommending me to get a different program. I want to just tweak NOTEPAD,
through registry edits or whatever.

How do I do that?
 
Ad

Advertisements

R

RobertVA

*rain*drops* said:
I guess the title says it: In XP, how do I set NOTEPAD to save to UNICODE
as default. I posted a similar query and recieved just one response,
recommending me to get a different program. I want to just tweak NOTEPAD,
through registry edits or whatever.

How do I do that?
Have you tried saving a blank file in UNICODE format and double clicking
a shortcut leading to that file instead of starting Notepad with the
normal Notepad application shortcut?

There is a "IfCharset" key with the value of 0 in the
\HKEY_CURRENT_USER\Software\Microsoft\Notepad section of the registry. I
don't know what effect changing that key would have. That key is
duplicated in another part of the registry too (do a search). CAUTION:
experimenting with registry entries could have serious and unwanted
effects on your applications and operating system.
 
Ad

Advertisements

D

denzees

I guess the title says it: In XP, how do I set NOTEPAD to save to UNICODE
as default. I posted a similar query and recieved just one response,
recommending me to get a different program. I want to just tweak NOTEPAD,
through registry edits or whatever.

How do I do that?
SET NOTEPAD TO SAVE IN UNICODE BY DEFAULT
=========================================

1. Right click -> New -> Text Document
2. Open "New Text Document.txt". Do NOT type anything!
3. Go to "File -> Save As... " and choose UniCode under "Encoding:", press "Save" and overwrite existing file. Close the file.
4. Rename "New Text Document.txt" to "UniCode.txt"
5. Copy "UniCode.txt" to "C:\WINDOWS\SHELLNEW"
6. Open Regedit and Navigate to HKEY_CLASSES_ROOT\.txt\ShellNew
7. Right click in the right window -> New -> "String Value" and rename it to "FileName".
8. Double click on "FileName" and put "UniCode.txt" into "Value Data".
9. press OK It's finished.

Test it: Create new .txt document (Right click -> New -> Text Document). Open it and go to "File -> Save As... " and see that encoding is set by

default to UniCode . :)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

a UNICODE notepad by default? 2
default folder for notepad? 12
Changing default font in Notepad : 6
Change Notepad defaults to Metapad 2
Non Unicode language settings 0
Notepad 1
notepad 7
non-Unicode 1

Top