How to fix, "Section width greater than the pagewidth".


J

JmbSupport

I have Microsoft Access 2007.

When I do print preview of a simple report I get this message:

"The section width is greater than the pagewidth, and there are no items in
the additional space, so some pages may be blank. For example, the report
width may be wider than the page width."

It sounds easy to fix but I can't determine how to reduce the value of the
section width. When I search HELP I can not find a definition of the section
width on a report or how to change it's value. I am not looking to add
program code, I am looking to use Access software as a user not a programmer.

There are not value past the width allowable for printing.
 
Ad

Advertisements

F

fredg

I have Microsoft Access 2007.

When I do print preview of a simple report I get this message:

"The section width is greater than the pagewidth, and there are no items in
the additional space, so some pages may be blank. For example, the report
width may be wider than the page width."

It sounds easy to fix but I can't determine how to reduce the value of the
section width. When I search HELP I can not find a definition of the section
width on a report or how to change it's value. I am not looking to add
program code, I am looking to use Access software as a user not a programmer.

There are not value past the width allowable for printing.
The message is misleading. There is no separate Section Width, as
such, in a report. It is the Report's Width that is too wide.

The combined width of the report plus the width of the left and right
margins is greater than the width of the paper.
Either make the width of the report less (by dragging the right edge
leftward) or decrease the width of the left and right margins, or
both.

If you can't drag the right edge of the report towards the left you
probably have a control (usually a line) extending to the current
right position. It can be just at the extreme top or bottom of a
section which means it is going to be hard to see in Design View.
Use the Object drop-down control to highlight each line in turn until
you find the culprit. Reposition it or make it shorter, then drag the
right edge to the wanted size. There may be more than just one line
that needs to be adjusted.
 
E

e.g.gruber

The message is misleading. There is no separate Section Width, as
such, in a report. It is the Report's Width that is too wide.

The combined width of the report plus the width of the left and right
margins is greater than the width of the paper.
Either make the width of the report less (by dragging the right edge
leftward) or decrease the width of the left and right margins, or
both.

If you can't drag the right edge of the report towards the left you
probably have a control (usually a line) extending to the current
right position. It can be just at the extreme top or bottom of a
section which means it is going to be hard to see in Design View.
Use the Object drop-down control to highlight each line in turn until
you find the culprit. Reposition it or make it shorter, then drag the
right edge to the wanted size. There may be more than just one line
that needs to be adjusted.
Gentle people, I am at wits end ... Trying to print a payment slip
from a
report in ms access on a paper - portrait, paper width 102mm, paper
height 296mm, report width 91,55 mm, left margin 3,42 mm, right margin
3,4 mm, report height 285mm, top margin 3mm, bottom margin 5,01 mm.
This ought to leave me ample space to print my report onto one page,
but yet - I get a properly printed page followed by a white page ...
Dragged the right edge of the report as far as it did go to the left
and
ended - no surprise - at 91,55 mm report width! I even tried to
extend
the paper size and to reduce the report size to no avail! One thing I
have to mention - all values in the report are turned vertically!

Any ideas where I may go wrong?
 
E

e.g.gruber

Thanks for the reply!

To the best of my knowledge - decimal point or comma is set
from the options for the region you are in. In my case it is a
decimal comma and I can't help it - the payment slip is
102mm wide and 296mm high. Finally - all values turned
vertically has historic reasons, but I tried landscape as well
with the same result (i.e. the same error message).

A sleepless night helped to come up with a further line of
investigation which I followed in the morning. While doing
so I stumbled accidentally on the explanation for this
message and the solution:

It is not (NOT) sufficient to look just at the objects and
their placement in the report! Unfortunately I am on a
German language system and I can only hope my trans-
lations will really reflect how I found the culprit and fixed
the problem. Clicking on "File" while looking at a report
and then clicking on "Page setup" (or similar) opens a
window with printing options for the report. Under
heading "Columns" (or similar - on the right hand side)
one finds values for column width and height. If those
values are larger than report plus margins - the error
message appears! Erasing the values and activating
the checkbox "like detail area" (or similar) solves the
problem.

Best regards!
Ernst
 
P

powellp.trinitycr

Thanks for the reply!

To the best of my knowledge - decimal point or comma is set
from the options for the region you are in. In my case it is a
decimal comma and I can't help it - the payment slip is
102mm wide and 296mm high. Finally - all values turned
vertically has historic reasons, but I tried landscape as well
with the same result (i.e. the same error message).

A sleepless night helped to come up with a further line of
investigation which I followed in the morning. While doing
so I stumbled accidentally on the explanation for this
message and the solution:

It is not (NOT) sufficient to look just at the objects and
their placement in the report! Unfortunately I am on a
German language system and I can only hope my trans-
lations will really reflect how I found the culprit and fixed
the problem. Clicking on "File" while looking at a report
and then clicking on "Page setup" (or similar) opens a
window with printing options for the report. Under
heading "Columns" (or similar - on the right hand side)
one finds values for column width and height. If those
values are larger than report plus margins - the error
message appears! Erasing the values and activating
the checkbox "like detail area" (or similar) solves the
problem.

Best regards!
Ernst
Thank you, Ernst!! I am using only one column and printing on a half-sheet. However, I had to adjust the column size smaller and then it worked.
 
M

mfeher1971

Thank you, Ernst!! I am using only one column and printing on a half-sheet. However, I had to adjust the column size smaller and then it worked.
I just had this same problem, but I was able to fix it by going to the tiny! icon in the upper-left corner of the Design View of the report. Right-clicking on it gives me a menu of options for what to do and try and correctthe problem. I chose "Remove Extra Space" or something like that and voila, everything was resized laterally for me. (I had previously a lot of extra columns and information in my report, but I removed those, resized, and repositioned the remaining columns, so now everything fits better and the resulting exported printout is about a third of the original size.)

Mike
 
Ad

Advertisements

H

hanabananaiguana

THANK YOU, THANK YOU,THANK YOU, THANK YOU!
I have been banging my head on the keyboard, and you have solved my problem
 
Ad

Advertisements

Joined
Nov 3, 2020
Messages
1
Reaction score
1
I found a solution , that does work for me
I reduced the report width by 2 cm
and detail height by 2cm
that worked for me...
Thanks.
 
  • Like
Reactions: Ian

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top