home network not working with my Vista Premium SP1 laptop



I am unable to locate other computers (running XP) on my home network from my
laptop running Vista Home Premium SP1 and they can not see the laptop either.
The problem was rare prior to SP1 and usually was fixed with a reboot, but
it seems that since SP1 I have not been able to see other PCs at all. I can
reliably get to the Internet, my workgroup name is the same on all PCs,
network discovery is on, and I have shares set up on all PCs. I usually
connect wirelessly, but have also tested it wired with the same results. I
cannot ping other PCs, but I can see the rest of my network from the laptop
using NIS 2008 Network Details view, and I can VNC into the other PCs from
the laptop using RealVNC. I have also tried disabling the firewall on the
laptop and one XP machine, but no change. Can anyone help with this?

Mike L

hey Mike,

I'm having the same Problem. I have a similar setup. Laptop can't see my
home pc but Home PC can see the laptop. I can't figure this one out.

Did you find any information?


Mick Murphy


Have a read of the above link re Vista File and Printer Sharing.

Permissions/Share info is there as well.

If using Norton, McAfee, Trend Micro I.S., make sure file and printer
sharing is enabled in THEIR firewall .(LAN allowed)

1st thing to do is make sure that the Workgroup Name of ALL the computers is
the SAME.

In Vista Network and Sharing:

Network Discovery: ON (So it can see the other computers)

Network set to Private (Public is for hotspots, airports, etc)

File Sharing: ON

Public Folder Sharing: ON (Vista’s Public Folder is the same as XP’s Shared

Password Protected: OFF (unless you want to set up identical usernames, and
passwords (they can be different) on ALL computers in your Network). If you
have it ON, you will be asked for a username and password when you try to
access a Vista computer from an XP computer, or a Vista Computer.

Also, If you haven’t done so already, run XP’s Network Setup Wizard (in
Start >All Programs >Accessories >Communications), and tell the Wizard to
enable File and Printer Sharing.
Or > Start > Control Panel > Network Connections > Set up a Home or Small
Office Network.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question