Help with Dos copy command under XP


Carol Hefling

I need to write a batch file that will copy files to a CD without user

I have tried the dos copy command to send directly to the D drive (copy *.*
d:) using a UDF formatted cd. This receives an error message.

I have tried to copy these commands to the c:\documents and
settings\user\local settings\application data\microsoft\cd burning file.
This also recieves an error message.

Any help would be greatly appreciated.


R. C. White

Hi, Carol.

It works for me. (Don't you just love that kind of answer?)

What error message(s) do you receive?

In your longer example, you may need to use quotation marks around any path
name that includes a space. Put the quotes around the entire pathname,
starting with the drive letter. In other words:

copy c:\program files\*.* d:\

would not work, because the computer would be looking for a folder named
"program" and trying to copy from it to a folder named "files" - and not
finding either folder. It might also complain that you typed an extra
parameter (d:\) that it didn't know how to handle. You would need to type:

copy "c:\ program files\*.*" d:\


Carol Hefling

Does it work for you copying to a CD-RW? Acutally this is a CD/DVD.

The error I get is a combination of "parameter is incorrect" or "invalid
function". I have tried to copy one individual file, all files, (*.*) and
sets of files (*.zip).

I also tried adding the quotes to and it didn't work.

It works fine in Windows using the copy & paste, drag & drop or send to so
it isn't the cd itself.

Any ideas?


Invalid function or parameter incorrect indicates to me that you do not have
the path enclosed in quotes.

The syntax of the command is important.

command source destination switches

The from and To locations need to be enlcosed in separate sets of quote
marks if there is any space within the name.

will not work. To have this work you would need to type


If any switches are to be used they need to be behind the destination path.

For more syntax information help click Start/Run. Type CMD and hit enter.
Type COPY /? and hit enter. Maximize the window and scroll to the top to see
all the switches for the command as well as the syntax.

You also might be able to do more with the XCOPY command. It is really
powerful in XP, much more than it was with any previous DOS versions.


These are the commands I am using

Copy *.* d:
Copy "*.*" d:
Copy "*.bat" d:

None of these works when trying to copy to the d drive yet I have no problem
copying to another directory on the hard drive, nor do I have a problem when
using the send to command (within windows) or the copy and paste to D drive.

I think it's the packet writing software embedded in XP. Is there a way of
turning this off?


Carol Hefling

For those who may be having the same trouble. I found that the upgrade to
Roxio's basic pre-installed software fixed this problem.

Thanks for the help.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads