HELP - Radio buttons and other controls suddenly moving in Excel 2010 only


R

RJQMAN

I have a long and complex program that works perfectly in excel 2003
and 2007, but I suddenly found this evening that when it is loaded
into 2010, it crashes. I have spent hours trying to understand why
and I keep running up against a wall. I have excel 2003 and 2007 on
one computer where I developed the program and tested with both. A
user brought over her laptop with 2010 on it this afternoon
complaining the program would not run. She was right.

It seems to start OK, and the command buttons on the opening screen
work fine, once macros are enabled. But as the program moves to the
next worksheet (by clicking the command button), trouble starts.

The new sheet has a lot of control buttons on it. The program hides
many rows so that only a few of the buttons are displayed. The
buttons are radio buttons, command buttons, etc. When you try to open
this worksheet, the program goes crazy - but only with excel 2010. It
worked fine with 2003 and 2007 on my computer and on others as well.
Plus I had one friend that had 2010 and it worked on her computer! I
am completely confused and baffled.

When this sheet opens, most (but not all) of the buttons on the
worksheet suddenly move somewhere else, and then the program crashes -
I can't understand why they are moving, but that seems to be causing
the crash. When I step through the program, it hangs up at a statement
that tries to define the value of one of the buttons that has moved
somewhere- I have not even found it yet. For all I know it may have
moved to another sheet.

I have the property for the buttons set at '1' with the intention that
they would be hidden if the row they are in is hidden. This worked
fine in 2003 and 2007 on every computer it ran on. I do not know what
to do and I am in trouble - the program is set to be used in two days
with a huge group of kids participating in a series of events (over
5,000 kids) at several school sites, and now I unexpectedly find that
some users that have excel 2010 cannot use it and I don't have any
idea how to fix it. Can anyone help me? I am in trouble.

Thanks in advance. I hope someone can help...
 
Ad

Advertisements

R

RJQMAN

I have a long and complex program that works perfectly in excel 2003
and 2007, but I suddenly found this evening that when it is loaded
into 2010, it crashes.  I have spent hours trying to understand why
and I keep running up against a wall. I have excel 2003 and 2007 on
one computer where I developed the program and tested with both.  A
user brought over her laptop with 2010 on it this afternoon
complaining the program would not run. She was right.

It seems to start OK, and the command buttons on the opening screen
work fine, once macros are enabled.  But as the program moves to the
next worksheet (by clicking the command button), trouble starts.

The new sheet has a lot of control buttons on it.  The program hides
many rows so that only a few of the buttons are displayed.  The
buttons are radio buttons, command buttons, etc. When you try to open
this worksheet, the program goes crazy - but only with excel 2010.  It
worked fine with 2003 and 2007 on my computer and on others as well.
Plus I had one friend that had 2010 and it worked on her computer!  I
am completely confused and baffled.

When this sheet opens, most (but not all) of the buttons on the
worksheet suddenly move somewhere else, and then the program crashes -
I can't understand why they are moving, but that seems to be causing
the crash. When I step through the program, it hangs up at a statement
that tries to define the value of one of the buttons that has moved
somewhere- I have not even found it yet.  For all I know it may have
moved to another sheet.

I have the property for the buttons set at '1' with the intention that
they would be hidden if the row they are in is hidden.  This worked
fine in 2003 and 2007 on every computer it ran on.  I do not know what
to do and I am in trouble - the program is set to be used in two days
with a huge group of kids participating in a series of events (over
5,000 kids) at several school sites, and now I unexpectedly find that
some users that have excel 2010 cannot use it and I don't have any
idea how to fix it.  Can anyone help me?  I am in trouble.

Thanks in advance.  I hope someone can help...

I have been working on the problem for almost 12 hours. I think the
problem may be that some of the activeX controls are not really
attached to the cell that is hidden - they are attached to some other
cell, and therefore do not hide. I do not know how to attach them to
a specific cell. They seem to be 'attached' when using 2003 and 2007
with vista, but not necessarily when using 2010 with windows 7. Help
please...
 
R

RJQMAN

I have been working on the problem for almost 12 hours.   I think the
problem may be that some of the activeX controls are not really
attached to the cell that is hidden - they are attached to some other
cell, and therefore do not hide.  I do not know how to attach them to
a specific cell.  They seem to be 'attached' when using 2003 and 2007
with vista, but not necessarily when using 2010 with windows 7.  Help
please...- Hide quoted text -

- Show quoted text -

Now the problem is suddenly occuring on some computers with Excel
2007. I open the program and check the one sheet that is giving me
problems. It looks great. Then I hide a row on that sheet, and about
2/3 of the activex controls go crazy - 1/3 seems to be fine. I cannot
see any difference in any of the properties or settings for the ones
that are fine.

The activex contoils tend to move straight straight down the sheet -
never up. And I do not think they move side to side, but someimes I
cannot even find out where they are. If I hide one row anywhere on
that page, the controls jump. The program hides part of the page, and
the part that had the activex buttons is supposed to be there so the
user can make a choice. The portion of the page is there, but the
buttons are long gone. If the code tries to control those buttons, it
cannot even find them when they are there - the program crashes. I am
frustrated and confused - I have been working on this problem for many
hours and I am facing a critical deadline - the program has to be used
Friday evening and it is now 1 AM Friday morning here. Can anyone
please help me? What is going on - the program was written in Excel
2003, and seemed to work fine on every computer it was tested on for a
couple of months - then problems started to be reported. Now it seems
to crash on more than half of the computers it is loaded onto with 07
and 10. It is as though the controls used to be attached to the
cells, but now are just moving unpredictably. However the program has
never crashed on 2003 as far as I can tell.

A friend said that perhaps the security systems on the computers have
been upgraded and now are damaging the activex controls. Is that even
possible? I need help very much. Thank you.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top