Group policy does not apply


C

Christoph Kling

Hello,

I downloaded the *.adm files for Office 2003 and added the Outlook specific
template to my group policy. The policy I use is "ForcePSTPath" to set the
directory Outlook saves its PST/OST files in (%userprofile%\Local
settings\Application Data\Microsoft\Outlook). After "gpupdate" on the
affected computers, I tried it out, but no setting was applied in Outlook! I
searched within the registry and found the value in
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\11.0\Outlook but not in
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook where it has to be
according to http://support.microsoft.com/default.aspx?scid=kb;en-us;896591

Can anybody tell me why the setting is not applied?

Regards

Christoph Kling
 
Ad

Advertisements

S

Sue Mosher [MVP-Outlook]

According to your description, the policy *is* being applied correctly. Policy settings are placed in the HKCU\Software\Policies key. Settings there work the same as in the corresponding locations in HKCU\Software, only they are mandatory settings the user cannot override.

Note that the ForcePSTPath policy affects only new .pst and .ost files. It does not move existing files.

--
Sue Mosher, Outlook MVP
Author of Configuring Microsoft Outlook 2003

and Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers
 
C

Christoph Kling

Hello,

how would I delete existing .ost files so that the setting can take effect?

Regards

Christoph Kling

According to your description, the policy *is* being applied correctly.
Policy settings are placed in the HKCU\Software\Policies key. Settings there
work the same as in the corresponding locations in HKCU\Software, only they
are mandatory settings the user cannot override.

Note that the ForcePSTPath policy affects only new .pst and .ost files. It
does not move existing files.

--
Sue Mosher, Outlook MVP
Author of Configuring Microsoft Outlook 2003

and Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers
 
S

Sue Mosher [MVP-Outlook]

Ouch! I hope your users don't have big mailboxes!

I'd push out a new default mail profile with a .prf file.

But why? IIRC, %userprofile%\Local settings\Application Data\Microsoft\Outlook is the default location for .ost and .pst files. In other words, pushing out this change will be no change at all.

--
Sue Mosher, Outlook MVP
Author of Configuring Microsoft Outlook 2003

and Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers
 
C

Christoph Kling

Hello,

my computers have different system drives (c: and f:). The path to *.ost
files seems to be saved within the server saved profile so that always when
I change the path on a computer, it is applied on the other computer as
well. The consequence is, that the user always has to change the path while
starting outlook. Somebody in the german outlook newsgroup recommended to
define that setting with a group policy.
The other problem occuring now is, that the path in the group policy is not
applied at all. I still have to change the path on every outlook start.
Either ForcePSTPath from the outlook .adm does not work (office sp2 is
installed) or the given path with %userprofile% does not reflect the current
%userprofile% path, rather the "last" login path.

Regards

Christoph Kling

Ouch! I hope your users don't have big mailboxes!

I'd push out a new default mail profile with a .prf file.

But why? IIRC, %userprofile%\Local settings\Application
Data\Microsoft\Outlook is the default location for .ost and .pst files. In
other words, pushing out this change will be no change at all.

--
Sue Mosher, Outlook MVP
Author of Configuring Microsoft Outlook 2003

and Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers
 
S

Sue Mosher [MVP-Outlook]

"Server-saved profile"? Are you saying that you're using roaming profiles and accessing your mailbox through more than one machine? Since ForcePSTPath affects only to new .ost and .pst files, it would not be relevant to your scenario. You do not want to recreate the .ost file every time the user switches machine. In your scenario, it is recommended that you not use Cached Exchange mode at all.

--
Sue Mosher, Outlook MVP
Author of Configuring Microsoft Outlook 2003

and Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers
 
Ad

Advertisements

C

Christoph Kling

Hello,

yes, I am using roaming profiles, I wasn't aware of the term for that. The
point is: it even did not work after I manuelly deleted the ost file.
Outlook wanted to recreate it within the path were is has been saved on
another machine. Is it possible to find out the location where the actual
path to the ost file is saved? In this case, I could create my own .adm file
or just add it directly in my group policy.
Since I do not want to disable cache mode at all, I need another solution
beside ForcePSTPath, however I think the policy does not work in my eyes
because of the described behaviour above.

Regards

Christoph Kling

"Server-saved profile"? Are you saying that you're using roaming profiles
and accessing your mailbox through more than one machine? Since ForcePSTPath
affects only to new .ost and .pst files, it would not be relevant to your
scenario. You do not want to recreate the .ost file every time the user
switches machine. In your scenario, it is recommended that you not use
Cached Exchange mode at all.

--
Sue Mosher, Outlook MVP
Author of Configuring Microsoft Outlook 2003

and Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers
 
S

Sue Mosher [MVP-Outlook]

No, that won't work. You cannot control mail profile settings with group policy, at least not out of the box. For security reasons, .ost files are tied

The policy works fine. You're simply trying to force Outlook to do something it was never designed to to. Why do you want to use Cached Exchange mode in the first place, given that it was designed for use in scenarios where the user is at the same machine all the time, not when they're roaming.
--
Sue Mosher, Outlook MVP
Author of Configuring Microsoft Outlook 2003

and Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers
 
C

Christoph Kling

Hello,

okay then where is the mailbox content stores if cache mode is disabled and
how can I solve the problem with different paths on different machines (with
roaming profiles)?

Regards

Christoph Kling

No, that won't work. You cannot control mail profile settings with group
policy, at least not out of the box. For security reasons, .ost files are
tied

The policy works fine. You're simply trying to force Outlook to do something
it was never designed to to. Why do you want to use Cached Exchange mode in
the first place, given that it was designed for use in scenarios where the
user is at the same machine all the time, not when they're roaming.
--
Sue Mosher, Outlook MVP
Author of Configuring Microsoft Outlook 2003

and Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers
 
Ad

Advertisements

S

Sue Mosher [MVP-Outlook]

If Cached Exchange mode is not applied, then the mailbox content is only on the Exchange server and thus available from any machine.

--
Sue Mosher, Outlook MVP
Author of Configuring Microsoft Outlook 2003

and Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top