First casualty of UAC


Gerry Hickman


I've not have any problems with UAC in general, but today I tested
McAfee VirusScan Enterprise 8.5i and there was a major problem with the
installation and the MSI did a roll back and that was that.

I'm guessing the issue was related to the installation of the low-level
drivers (filters) or Win32 services; UAC did not prompt, it just failed.
I tried running it as "Administrator", but no joy.

I then disabled UAC in Control Panel and suddenly it installed fine. Not
sure what's going on there.


Sounds like the MSI was improperly coded.

UAC is simply a go-between between users and applications; it is not
automatic. Applications must know when they need higher privileges and then
request UAC to be displayed to the user.

- JB


There is a beta version of McAfee..... available which gets past that
problem, AFAIK it's still in beta and I don't recall if it's publically
available or not.

In the meantime for some virus protection you could try AVG free edition or
Avast's free version unitll McAfee release their Vista compatible version
unless your happy with the way your McAfee version installed.

Colin T

Gerry Hickman

Hi Gary,

I started it as Pseudo-Admin, it failed, I then used "Run as
Administrator" (what ever that means) and it still failed. I then turned
off UAC in CP and it worked.

Gerry Hickman

Hi Colin,

As far as I know 8.5i _is_ the official Vista version, are you saying
there's a BETA that's more recent than 8.5i?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question