File type association buttons grayed out for non-admin


M

Mister.Fred.Ma

I'm running Windows XP Professional 2002, Service Pack 2. When logged
into my main account (which is a non-admin account, I go to a file
explorer window, Tools->FolderOptions->FileTypes -- all the buttons
(New, Delete, Change, Advanced) are grayed out for all file types. I
can log in as administrator and the buttons are not grayed out. I read
on usenet that these file associations are system-wide, and must be
made from an admin account. However, the changes I made from the admin
account do not propagate to the non-admin account, even after a reboot
(I did confirm that the changed association took effect by first
logging into the admin account). Hence, I am lead to believe that
non-admin file associations are separate from admin file associations,
and neither are system-wide.

Another usenet thread said that some applications lock the association.
In my case, I want PDF files to be associated with Acrobat Reader, not
Acrobat itself. I could find no preferences in Acrobat to lock the
association. Furthermore, the file association buttons are grayed out
for all file types (when logged in as non-admin).

I looked under my Symantec AV & Kerio firewall, as well as Windows
Security Center, to find options that may prevent non-admins from
changing file associations, but found none.

There have been mentions on Usenet of registry hacks that are needed to
enable non-admins to change file associations. I would rather not muck
around with the registry. What causes this inability of non-admins to
change file associations? Are there any clean fixes i.e. without
resorting to registry hacking?

Thanks.
 
Ad

Advertisements

M

Marian Gutu

Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.pdf. Is Acrobat your
default application for pdf files?
--
Marian Gutu

MCP, MCSAs, MCSEs
Be nice, society already sucks!

May the Force be with you!
http://www.google.com
 
W

Wesley Vogel

File Types New, Delete, Change and Advanced grayed out

The NoFileAssociate value can exist in either of these keys or both of them.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\Policies\Explorer
and/or
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\
CurrentVersion\Policies\Explorer

Value Name: NoFileAssociate
Data Type: REG_DWORD
Value Data: 0 or 1
0 = The user can add, delete, and change file type associations.
1 = The user cannot add, delete, or change file type associations.

When this policy is enabled, the New, Delete, Change, and Advanced buttons
are unavailable on the File Types tab of the Folder Options tool in Control
Panel.

HKEY_CURRENT_USER applies only to the current user.

HKEY_LOCAL_MACHINE applies to all users of the computer.

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In
 
M

Mister.Fred.Ma

Marian said:
Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.pdf. Is Acrobat your
default application for pdf files?

Yes. I was hoping to deal with the larger problem of not being able to
change file associations in general. Looks like there is no
alternative to dealing with the registry.
 
M

Mister.Fred.Ma

Wesley said:
File Types New, Delete, Change and Advanced grayed out

The NoFileAssociate value can exist in either of these keys or both of them.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\Policies\Explorer
and/or
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\
CurrentVersion\Policies\Explorer

Value Name: NoFileAssociate
Data Type: REG_DWORD
Value Data: 0 or 1
0 = The user can add, delete, and change file type associations.
1 = The user cannot add, delete, or change file type associations.

When this policy is enabled, the New, Delete, Change, and Advanced buttons
are unavailable on the File Types tab of the Folder Options tool in Control
Panel.

HKEY_CURRENT_USER applies only to the current user.

HKEY_LOCAL_MACHINE applies to all users of the computer.

Hope this helps. Let us know.


Hi, Wesley,

When logged in as non-admin,
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
exists, but is missing the NoFileAssociate value. When I try to create
it, I get:

Error create value: Error writing to registry

I then switched to the admin account. The key
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
did not exist, so I created it. I also created the REG_DWORD value
NoFileAssociate and set it to 0. This was visible when logged in as
non-admin after rebooting. However, the file type association buttons
are still grayed out. I imagine that the local machine setting hasn't
been propagated to the non-admin user because it has been overridden by
yet another safety setting.

Thanks for your attempt to help. Further suggestions are welcome.
 
W

Wesley Vogel

If NoFileAssociate does not exist, it's the same as being set to 0.

Can you associate .pdf files as a nonadministrator by right clicking a .pdf
file...
Click Properties | General tab | Change button |
Browse button to look for Acrobat Reader if not listed


Try nofileassocundo.reg here...
http://www.kellys-korner-xp.com/xp_tweaks.htm
314. File Associations are Greyed Out

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In
 
Ad

Advertisements

M

Mister.Fred.Ma

I'm running Windows XP Professional 2002, Service Pack 2. When logged
into my main account (which is a non-admin account, I go to a file
explorer window, Tools->FolderOptions->FileTypes -- all the buttons
(New, Delete, Change, Advanced) are grayed out for all file types. I
can log in as administrator and the buttons are not grayed out. I read
on usenet that these file associations are system-wide, and must be
made from an admin account. However, the changes I made from the admin
account do not propagate to the non-admin account, even after a reboot
(I did confirm that the changed association took effect by first
logging into the admin account). Hence, I am lead to believe that
non-admin file associations are separate from admin file associations,
and neither are system-wide.

Another usenet thread said that some applications lock the association.
In my case, I want PDF files to be associated with Acrobat Reader, not
Acrobat itself. I could find no preferences in Acrobat to lock the
association. Furthermore, the file association buttons are grayed out
for all file types (when logged in as non-admin).

I looked under my Symantec AV & Kerio firewall, as well as Windows
Security Center, to find options that may prevent non-admins from
changing file associations, but found none.

There have been mentions on Usenet of registry hacks that are needed to
enable non-admins to change file associations. I would rather not muck
around with the registry. What causes this inability of non-admins to
change file associations? Are there any clean fixes i.e. without
resorting to registry hacking?


Wesley said:
File Types New, Delete, Change and Advanced grayed out

The NoFileAssociate value can exist in either of these keys or both of
them.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\Policies\Explorer
and/or
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\
CurrentVersion\Policies\Explorer

Value Name: NoFileAssociate
Data Type: REG_DWORD
Value Data: 0 or 1
0 = The user can add, delete, and change file type associations.
1 = The user cannot add, delete, or change file type associations.

When this policy is enabled, the New, Delete, Change, and Advanced
buttons are unavailable on the File Types tab of the Folder Options tool
in Control Panel.

HKEY_CURRENT_USER applies only to the current user.

HKEY_LOCAL_MACHINE applies to all users of the computer.

Hope this helps. Let us know.


When logged in as non-admin,
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
exists, but is missing the NoFileAssociate value. When I try to create
it, I get:

Error create value: Error writing to registry

I then switched to the admin account. The key
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
did not exist, so I created it. I also created the REG_DWORD value
NoFileAssociate and set it to 0. This was visible when logged in as
non-admin after rebooting. However, the file type association buttons
are still grayed out. I imagine that the local machine setting hasn't
been propagated to the non-admin user because it has been overridden by
yet another safety setting.


Wesley said:
If NoFileAssociate does not exist, it's the same as being set to 0.

Can you associate .pdf files as a nonadministrator by right clicking a .pdf
file...
Click Properties | General tab | Change button |
Browse button to look for Acrobat Reader if not listed

Try nofileassocundo.reg here...
http://www.kellys-korner-xp.com/xp_tweaks.htm
314. File Associations are Greyed Out


Thanks for the further suggestions, Wesley. It turns out that the
problem was solved in an non-obvious way. The non-admin account was
given Power User status. I didn't even realize that Windows XP made
distinctions between nonadmin accounts, since these distinction is not
visible when I was creating the account. I guess it simplifies the
creation of an account.
 
W

Wesley Vogel

And *nowhere* in Help does it say you have to have the rights to change file
associations, I looked before you posted this.

Glad you got it worked out.

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In
 
Ad

Advertisements

M

Mister.Fred.Ma

Wesley said:
And *nowhere* in Help does it say you have to have the rights to change file
associations, I looked before you posted this.

Well, that's just how the explanation came across to me. I haven't
actually checked out its accuracy -- all's I know is that the person
who said it also fixed the problem somehow.
Glad you got it worked out.

Thanks for your help.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top