External USB drive issues


R

RJF

New HP Pavillion desktop that came with Vista Home Premium. HP Support is no
help here btw.

Machine has a media card reader with a USB 2.0 port on the front. Boot up
Vista, Computer sees everything with no problem (Devices with removable
storage shows DVD drive and Removable Drives F through J (the individual
media reader slots).

When I plug in an external USB hard drive to the front, everything is there
(USB drive shows up as Local Disk K: under the Hard Drives section, DVD and
Drives F Through J under the Devices With Removable Storage section).

When I plug a 2nd external USB drive to the rear of the system, all the
removable drives go bye-bye with the exception of the DVD.

USB ports in the back of the system are ok, I have a printer plugged in
there and have moved that from slot to slot to verify the USB ports were
working.

Any ideas?
 
Ad

Advertisements

R

R. McCarty

You've either exceeded the 500 mA power limitation or the available
bandwidth of the USB controller. When this happens part of all of the
devices will seem to disappear from the system.

You can check the status in Device Manager, by opening and checking:
1.) USB controller(s), Advanced (TAB) = Shows Bandwidth usage
2.) USB Root Hub, Power (TAB) = Shows current draw

USB1(.1) devices are routed to "Standard" Hubs. USB-2.0 devices
are internally routed to a *single (Enhanced) controller.

*Newer motherboards actually provide 2 or more enhanced controllers.
 
R

RJF

First - Thanks for the quick reply!

This points me in the right direction. I am thinking it is the 500 mA power
limitation I am bumping into here. Too bad HP support couldn't tell me
that - would have saved me hours of frustration!

Not a problem switching the USB drives in and out when I need to do
something with either of them - don't have to have both running at the same
time anyhow -
 
R

Richard Urban

This is why people use an external self powered USB hub plugged into a wall
outlet. You don't bump into a similar limitation (well, I guess eventually
you could if you go crazy).

--


Regards,

Richard Urban MVP
Microsoft Windows Shell/User
 
J

jparkes

NewHPPavillion desktop that came withVistaHome Premium.HPSupport is no
help here btw.

Machine has a media card reader with aUSB2.0 port on the front. Boot upVista, Computer sees everything with no problem (Devices with removable
storage shows DVD drive and Removable Drives F through J (the individual
media reader slots).

When I plug in an externalUSBhard drive to the front, everything is there
(USBdrive shows up as Local Disk K: under the Hard Drives section, DVD and
Drives F Through J under the Devices With Removable Storage section).

When I plug a 2nd externalUSBdrive to the rear of the system, all the
removable drives go bye-bye with the exception of the DVD.

USBports in the back of the system are ok, I have a printer plugged in
there and have moved that from slot to slot to verify theUSBports were
working.

Any ideas?

I am having the exact same problem on a HP m7658n that was upgraded to
Vista. I have tried two powered USB hubs from the back ports but they
still do not work. My card reader does not work at all. I got it back
for while by deleting all the drivers under USB and let Vista add them
back but it takes forever especially when you are using a USB mouse.
The Hauppauge 26xxx TV Tuner card will not work with Media Center in
Vista either. HP told me they were working on both issues.
 
Ad

Advertisements

M

MICHAEL

I am having the exact same problem on a HP m7658n that was upgraded to
Vista. I have tried two powered USB hubs from the back ports but they
still do not work. My card reader does not work at all. I got it back
for while by deleting all the drivers under USB and let Vista add them
back but it takes forever especially when you are using a USB mouse.
The Hauppauge 26xxx TV Tuner card will not work with Media Center in
Vista either. HP told me they were working on both issues.

Have you applied this update?

http://support.microsoft.com/?kbid=925528
Reliability update for the USB stack in Windows Vista


-Michael
 
J

JohnP

Have you applied this update?

http://support.microsoft.com/?kbid=925528
Reliability update for theUSBstack in Windows Vista

-Michael- Hide quoted text -

- Show quoted text -

Yes. The USB card reader still doesn't work and I still keep getting
"Unknown Device" in Device Manager and an exclamation point besides
"USB Mass Storage Device". A 2nd "USB Mass Storage Device" used to
show up when the 4 card drives worked. They do not appear under
"Drives" anymore either.
 
R

RJF

Hmmm - Windows update shows nothing about update 925528. Not sure why that
wouldn't have been picked up.

Thanks for the assist -

BTW - I now have both external USB drives working on the system (at the same
time). Using an external powered USB hub.

Thanks again all!
 
Ad

Advertisements

J

JohnP

Hmmm - Windows update shows nothing about update 925528. Not sure why that
wouldn't have been picked up.

Thanks for the assist -

BTW - I now have both external USB drives working on the system (at the same
time). Using an external powered USB hub.







- Show quoted text -

Are your Card Reader slots also working? I am on a chat with HP right
now concerning the TV Tuner. He has me running "upgradeassistant.exe"
from the HP upgrade CD, then install patch sp26950.exe 1/1 (1.76M) ,
then RESET Media Center by following the third direction at
http://h10025.www1.hp.com/ewfrf/wc/...9039&cc=us&dlc=en&lc=en&jumpid=reg_R1002_USEN
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top