Excel won't let me type a formula using commas!


B

brandon_05mn

Please help, this is my problem. Some formulas don't work when I type them in.

For example, when I type this formula, it will say there is an error.
"=SUM(1,2,3)"
That does not work, it says invalid format.
but if I do a formula with a range (instead of commas), it works. Such as
"=SUM(A5:C5)" - that works just fine.

I am guessing this has something to do with the commas in the formula. When
I start to type a formula, a formula helper thing will be displayed that is
showing the format of the formula. This format example does not include
commas. It uses spaces instead. So I tried to type the formula with spaces
(instead of commas) and that doesn't work either.

I consider myself a advanced user of excel, I have extensive experience with
excel formulas, so this is really bothering me (especially since I can't type
many formulas because they need commas and that doesn't work).

One more thing. I have existing spreadsheets that I am using (I have created
these months ago). On these, I have formulas that contain commas and they all
work. But if I double-click on the cell (as if I am going to edit the
formula, but I don't edit it, I keep it the same) and press enter, the same
error appears. If I hit escape, it cancels the formula edit request and goes
back to how it was.

I did try to uninstall and reinstall excel, that didn't work. But I think it
is still pulling my info from somewhere.

Thanks for all of your help.
 
Ad

Advertisements

D

Dave Mills

Could this be related to regional settings? The comma is the decimal delimiter
in most of Europe.
 
S

Shane Devenshire

Hi,

There is nothing wrong with the formula you showed us unless commas don't
mean separaters.

Try choosing Tools, Options, International, and checking to see what decimal
separator and thousands separator you are using. You can uncheck Use system
separators and then change the above options. These are related to your
system settings.
 
S

Simon Murphy

Brandon
Check your regional settings in Windows. It sounds like your culture
setting have been changed.

If its not that then check that Lotus compatibility has not been set for
the affected sheets.

Cheers
Simon
Excel development website: www.codematic.net
 
Ad

Advertisements

H

Harlan Grove

Simon Murphy said:
If its not that then check that Lotus compatibility has not been set for
the affected sheets.
....

?!

Neither Lotus 123 nor Lotus Symphony (the original, not the new OOo
1.x clone) were ever afflicted with space as argument separator. Have
you really seen this behavior due to Lotus compatibility being
activated and fixed by Lotus compatibility being deactivated?
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top