Errors 1231/1232 Unidentified Network

Discussion in 'Windows Vista Networking' started by Guest, Jul 2, 2007.

  1. Guest

    Guest Guest


    I have a problem that I'm quite sure is Vista-Asscociated.

    I recently switched from directly being plugged into my modem, to a
    router-system at home for my computer.

    However, the problem is that I get the "Unidentified Network" in the
    Networks section, and I can't ping my own IP or Default gate way, as it gives
    me a "PING: transmit failed, error code 1231." message.

    Currently, all my settings in the IPv4 protocol are set to auto, and setting
    them manually makes no difference, except that it gives me error 1232 instead
    of 1231...

    It's probably also worth mentioning that Vista does connect to the network,
    calling it the 'Network #', and during that second or two, I can get all the
    numbers in ipconfig, but very soon after, Vista changes the 'Network #' to
    'Unidentified Network', and all the numbers in ipconfig are lost. Vista also
    states the my IP is used on the Network by another computer, even though it
    definitely isn't.

    I've tried pretty much everything I could, including


    I'm currently using Realtek RTL8168/8110 Family PCI Gigabit Ethernet NIC
    running Vista Ultimate.
    I have 4 other computers at home, all capable of connecting to the network,
    and going on the internet and everything. (all running XP)

    Vista obviously cannot repair the problem itself.
    Any help would be greately appreciated.

    Guest, Jul 2, 2007
    1. Advertisements

  2. Guest

    Barb Bowman Guest

    as a test, can you set your NIC to 100mbps full duplex?

    1. Click Start, type ncpa.cpl in the Start Search box, and then
    click ncpa.cpl in the Programs list.

    If you are prompted for an administrator password or confirmation,
    type the password, or click Continue.
    2. Right-click the Gigabit network connection, and then click

    If you are prompted for an administrator password or confirmation,
    type the password, or click Continue.
    3. On the Networking tab, click Configure.
    4. On the Advanced tab, click the property that is in the Property
    5. In the Value box, click the value that represents the 100 Mbps
    Full Duplex setting, and then click OK.


    Barb Bowman
    MS Windows-MVP
    Barb Bowman, Jul 2, 2007
    1. Advertisements

  3. Guest

    Guest Guest

    okay done.. nothing really happened.. the network connection disabled itself,
    then enabled itself again and is still "Unidentified Network", same situation.
    Guest, Jul 3, 2007
  4. Guest

    Barb Bowman Guest

    what router are you using? brand/model/hardware rev? what firmware?
    have you tried a factory reset of the router?

    if the stack itself has become corrupt in Vista, try a reset by
    opening an elevated cmd prompt (run as administrator) and typing

    netsh int ip reset [enter]

    then, please post the complete results of ipconfig /all from that


    Barb Bowman
    MS Windows-MVP
    Barb Bowman, Jul 3, 2007
  5. Guest

    Guest Guest

    I'm using a Xincom Twin Wan Router XC-DPG502 Ver 2.1 Rel 2O.
    I'm not doing a factory reset because I need to keep a lot of my settings on
    the router.
    I tried the reset, no difference. Btw: It's still set on full 100mbs duplex.

    Here's the IPConfig /all results:

    Guest, Jul 4, 2007
  6. Guest

    Barb Bowman Guest

    hard to tell from what you posted (I expected you to copy the output
    to the clipboard and paste in here as a reply) but I don't see any
    IPv4 at all in that image.

    from an elevated command prompt please run the following

    netsh int ip reset resetnet.txt [enter]

    restart your computer

    what happens?


    Barb Bowman
    MS Windows-MVP
    Barb Bowman, Jul 4, 2007
  7. Guest

    Guest Guest

    That picture I put up is exactly how it came when I typed in ipconfig /all
    after running cmd as administrator...
    I don't know how to copy/paste the ipconfig results onto the clipboard :S

    I also did the netsh int ip reset reset.txt and for some reason (this didn't
    happen last time I tried it) it said "Reseting Echo Request, failed.
    Acess Denied.

    Reseting User Interface, Ok!
    A reboot is required..." etc.

    After rebooting, it's still the same, and reseting int ip gives the same

    Guest, Jul 5, 2007
  8. Guest

    Barb Bowman Guest

    with the cmd window open, click the icon on the upper left corner,
    then edit, then select all.

    click that icon again, then edit, then copy and paste into notepad
    and save it. then copy it in here.

    please post the contents of the reset.txt file as well. the entire

    are you sure you are running an elevated cmd prompt?

    you right click the command prompt in the accessories group and then
    un as administrator?


    Barb Bowman
    MS Windows-MVP
    Barb Bowman, Jul 5, 2007
  9. Guest

    Guest Guest

    Yes, I'm positive I'm running an elevated cmd prompt.
    Here's the ipconfig results:

    Microsoft Windows [Version 6.0.6000]
    Copyright (c) 2006 Microsoft Corporation. All rights reserved.

    C:\Windows\System32>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : AlexNew
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection 2:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Realtek RTL8168/8111 Family PCI-E
    Ethernet NIC (NDIS 6.0)
    Physical Address. . . . . . . . . : 00-19-DB-4D-E6-AE
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::d92:f26d:92aa:fa52%11(Preferred)
    Default Gateway . . . . . . . . . :
    DHCPv6 IAID . . . . . . . . . . . : 234887643
    DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter Local Area Connection* 9:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 02-00-54-55-4E-01
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 10:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes


    I typed in 'netsh int ip reset resetnet.txt', all it gives me is

    C:\Windows\System32>netsh int ip reset resetnet.txt
    Reseting Echo Request, failed.
    Access is denied.

    Reseting Interface, OK!
    A reboot is required to complete this action.

    Where is the .txt file located? I tried searching for resetnet in
    "Everywhere", Vista didn't find it..

    Guest, Jul 5, 2007
  10. Guest

    Barb Bowman Guest

    Barb Bowman, Jul 5, 2007
  11. Guest

    Barb Bowman Guest

    have you tried deleting the NIC from dev mgr, then shutting down the
    computer completely, then turning it back on and letting it
    rediscover the NIC and install drivers?


    Barb Bowman
    MS Windows-MVP
    Barb Bowman, Jul 5, 2007
  12. Guest

    Guest Guest

    Did, nothing even close to the name "reset" except this one 15kb random app..

    Do you abosolutely need the .txt? can we go around that info or get it
    differently somehow?
    Guest, Jul 6, 2007
  13. Guest

    Barb Bowman Guest

    Barb Bowman, Jul 6, 2007
  14. Guest

    Guest Guest

    Checked/Enabled, set to auto obtain.

    P.S: I just intalled VMware and I'm running a virtual system (XP), and the
    internet works fine. So it's definitely a problem with Vista. Something in
    security, because I would only use this computer through a router, and at
    home.. so is there a way to turn off like.. ALL security features for the
    networks? Turning off Firewall doesn't work, I'm thinking maybe more
    administrative tools or something? And then add security as I go along..?
    Would that work?

    Thanks for all your help btw, I'm sure you can figure out what's wrong.
    Guest, Jul 7, 2007
  15. Guest

    Barb Bowman Guest

    there is no question that something is wrong with tcp/ipv4 in Vista
    as the info you posted did not show an IPv4 IP address or subnet,
    etc. I posted the following ealier but don't see that you have done

    "have you tried deleting the NIC from dev mgr, then shutting down
    the computer completely, then turning it back on and letting it
    rediscover the NIC and install drivers?"


    Barb Bowman
    MS Windows-MVP
    Barb Bowman, Jul 7, 2007
  16. Guest

    Guest Guest

    Yes I have... it reinstalls the same driver, no difference.
    Guest, Jul 7, 2007
  17. Guest

    Barb Bowman Guest

    well, we are down to only a few options. the fact that you were
    previously directly connected to the Internet without a router left
    you more vulnerable to exploits than being behind a router. I don't
    know the details of how you went from being directly connected via a
    modem to having a 4-5 computer network.

    But some questions -
    did you disable and services or programs?
    did you have a virus that you repaired?

    the fact that the ipconfig /all only shows IPv6 active but no sign
    of IPv4 while the GUI appears to show IPv4 active certainly proves
    there is a problem. (it would be worth a final test to disable IPv6
    in network props for the NIC just to see what shows up in ipconfig


    Barb Bowman
    MS Windows-MVP
    Barb Bowman, Jul 7, 2007
  18. Guest

    Guest Guest

    Hey Barb.. You'll be happy to know I have got it working!! =D
    Basically, the problem was that the Xincom router firmware was a little
    outdated, and they released a new version 2 months ago, this year, so
    upgrading that router fixed all the problems. Everything works great now.

    Thanks a lot for your help, I can configure the rest myself.
    You obviously are very knowledgeable in this area, so I guess if you're
    helping other people, suggest to upgrade their firmware ;)
    Thanks again.

    Guest, Jul 8, 2007
  19. Guest

    Barb Bowman Guest

    glad it's working. my second reply asked you about firmware :)


    Barb Bowman
    MS Windows-MVP
    Barb Bowman, Jul 8, 2007
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.