DVD decoder/playback issue in Vista x64...



2 days ago my Vista x64 RC1 OS decided to stop playing DVD's through WMPlayer
11. Everytime I'd attempted to play a DVD WMPlayer 11 would state "Your
system is low on memory. This program will now close." and refuse to play
anything. I'd also attempt to play VOB files through WMPlayer 11; same issue.
Up until that point, DVD's played beautifully through the generic Vista x64
Ultimate decoder or my Nvidia DVD decoder. The only change I made to my
system was that I installed Real Player. I uninstalled Real player, restarted
the machine; same error.

I didn't have much on my Vista machine so I wiped it clean, formatted the
drive, and re-installed Vista x64. Upon restart I immediately went to play a
DVD; the same error occurred. Also, if I ran the 64-bit version of WMPlayer
11, it would state "No valid DVD decoder is installed." Windows Vista
Ultimate comes with a DVD decoder (as evidenced by the website stating it and
by me using it before). I ran the 32-bit version of WMPlayer 11 and the "low
memory" error reoccurred. I went into the Task Manager and right-clicked on
wmplayer.exe *32 and noticed Virtualization was check marked (as it should be
due to it being a 32-bit program in x64 environment. With it unchecked and in
the same instance of WMPlayer 11, DVD's began to play just fine. I exited out
of WMPlayer 11, restarted it, and Virtualization was checked again and
wouldn't play DVD's.

I then decided to install my Nvidia DVD decoder. It had worked before on my
previous installation of Vista x64. The codec would only run if WMPlayer 11
32-bit was running and the Virtualization was unchecked. The 64-bit version
of WMPlayer 11 would still state no valid DVD decoder was installed.

Frustrated, I ran Media Center for Vista x64 and it stated "the DVD decoder
is either not installed or caused an error, please restart Media Center." I
then re-installed Vista x64 2 more times with the same exact result.

DVD's do play in Vista x64, however, under a Nero program like Showtime
(utlizing the Nvidia decoder). However, prior to these errors, I ALWAYS used
WMPlayer 11 in Vista x64 to play DVD's without error.

I have a hard drive on the same machine with Windows XP Pro (32-bit) and it
plays DVD's just fine (same Nvidia decoder).

Has anyone had an issue with Vista x64 that would cause a program to out of
nowhere begin to have Virtualization-type errors when no changes to my
hardware or virtual memory have taken place? Especially after 3 re-installs
of the OS?

My specs are:
AMD Athlon 64-bit 4400+ X2
2 Gb of Corsair DDR RAM
2 7800 GT's @ 256 Mb of video RAM each
250 Gb Western Digital SATA 2 hard drive


They killed the decoder on 11/13(14)I installed the newest(old
still)purevideo(nvidia) decoder trial and it fixed it.If You set the system
clock back before 11/13 Youll see.


My specs are not as good but similar to yours and I am getting the same
message. It can't be our systems. I will post any info I find or can be
e-mailed at (e-mail address removed)

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads