Dual boot startup problem

Y

You Know Who ~

Greetings:

I currently have a dual-boot drive with Windows 98 on C and Windows Home Xp
on D. The startup menu gives me a choice. I now don't need the win98
installation anymore, but can't seem to boot directly on the D Drive.

When I tell the computer to boot from D:\, windows is looking for a file in
the old C:\windows folder.

Have tried the control console rebuild cfg but that only let me add an
entry, rather than fix it so that I can only boot from D:

My current ini file is listed below. Deleting the last line does not work.
Would really appreciate any suggestions.
thanks
b


[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="WinXP" D:\windows
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /noexecute=optin /fastdetect
C:\="Microsoft Windows"
 
Y

You Know Who ~

Perhaps I should have added: Drive D with XP is using NTFS formatting while,
of course, win98 is using Fat32 on the C drive.
thanks
b
 
P

peter

P

Pegasus \(MVP\)

You Know Who ~ said:
Greetings:

I currently have a dual-boot drive with Windows 98 on C and Windows Home Xp
on D. The startup menu gives me a choice. I now don't need the win98
installation anymore, but can't seem to boot directly on the D Drive.

When I tell the computer to boot from D:\, windows is looking for a file in
the old C:\windows folder.

Have tried the control console rebuild cfg but that only let me add an
entry, rather than fix it so that I can only boot from D:

My current ini file is listed below. Deleting the last line does not work.
Would really appreciate any suggestions.
thanks
b


[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="WinXP" D:\windows
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /noexecute=optin /fastdetect
C:\="Microsoft Windows"

The syntax of boot.ini is incorrect. It should look like this:

[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /noexecute=optin /fastdetect
C:\="Microsoft Windows"

Note that the file implies that you have two disks, not just
one. Is this correct?

If this does not work, report exactly what happens. Don't
just say "It's looking for a file in the old C:\Windows folder".
This tells us nothing at all!
 
Y

You Know Who ~

Yes, C and D are seperate drives, both master drives
b

Pegasus (MVP) said:
You Know Who ~ said:
Greetings:

I currently have a dual-boot drive with Windows 98 on C and Windows Home Xp
on D. The startup menu gives me a choice. I now don't need the win98
installation anymore, but can't seem to boot directly on the D Drive.

When I tell the computer to boot from D:\, windows is looking for a file in
the old C:\windows folder.

Have tried the control console rebuild cfg but that only let me add an
entry, rather than fix it so that I can only boot from D:

My current ini file is listed below. Deleting the last line does not work.
Would really appreciate any suggestions.
thanks
b


[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="WinXP" D:\windows
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /noexecute=optin /fastdetect
C:\="Microsoft Windows"

The syntax of boot.ini is incorrect. It should look like this:

[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /noexecute=optin /fastdetect
C:\="Microsoft Windows"

Note that the file implies that you have two disks, not just
one. Is this correct?

If this does not work, report exactly what happens. Don't
just say "It's looking for a file in the old C:\Windows folder".
This tells us nothing at all!
 
R

Ron Sommer

After making the changes to the XP Home line and making sure that you can
boot into XP, you can delete the C:\="Microsoft Windows" line.

Note: the C drive will have to remain the boot drive.
--
Ron Sommer

You Know Who ~ said:
Yes, C and D are seperate drives, both master drives
b

Pegasus (MVP) said:
You Know Who ~ said:
Greetings:

I currently have a dual-boot drive with Windows 98 on C and Windows Home Xp
on D. The startup menu gives me a choice. I now don't need the win98
installation anymore, but can't seem to boot directly on the D Drive.

When I tell the computer to boot from D:\, windows is looking for a file in
the old C:\windows folder.

Have tried the control console rebuild cfg but that only let me add an
entry, rather than fix it so that I can only boot from D:

My current ini file is listed below. Deleting the last line does not work.
Would really appreciate any suggestions.
thanks
b


[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="WinXP" D:\windows
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /noexecute=optin /fastdetect
C:\="Microsoft Windows"

The syntax of boot.ini is incorrect. It should look like this:

[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /noexecute=optin /fastdetect
C:\="Microsoft Windows"

Note that the file implies that you have two disks, not just
one. Is this correct?

If this does not work, report exactly what happens. Don't
just say "It's looking for a file in the old C:\Windows folder".
This tells us nothing at all!
 
Y

You Know Who ~

Pegasus (MVP) said:
You Know Who ~ said:
Greetings:

I currently have a dual-boot drive with Windows 98 on C and Windows Home Xp
on D. The startup menu gives me a choice. I now don't need the win98
installation anymore, but can't seem to boot directly on the D Drive.

When I tell the computer to boot from D:\, windows is looking for a file in
the old C:\windows folder.

Have tried the control console rebuild cfg but that only let me add an
entry, rather than fix it so that I can only boot from D:

My current ini file is listed below. Deleting the last line does not work.
Would really appreciate any suggestions.
thanks
b


[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="WinXP" D:\windows
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /noexecute=optin /fastdetect
C:\="Microsoft Windows"

The syntax of boot.ini is incorrect. It should look like this:

[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /noexecute=optin /fastdetect
C:\="Microsoft Windows"

Note that the file implies that you have two disks, not just
one. Is this correct?

If this does not work, report exactly what happens. Don't
just say "It's looking for a file in the old C:\Windows folder".
This tells us nothing at all!

Ok, I set my bios to boot from the HDD1 drive (which has XP on it) instead
of HDD0

I have both a boot.ini and boot.int file on that drive
Also have the NTLDR file as well as the NTDETECT.com file and NTLDP file
on that drive.

It refuses to load, giving the message that it is missing:
<windows root>/system32/hal.dll
However, the file is there in the windows directory of the XP windows. so i
assume it is looking in C:\ but I am not sure why it is looking there.

Thank you very much for helping.

b
 
P

Pegasus \(MVP\)

You Know Who ~ said:
Pegasus (MVP) said:
You Know Who ~ said:
Greetings:

I currently have a dual-boot drive with Windows 98 on C and Windows
Home
Xp
on D. The startup menu gives me a choice. I now don't need the win98
installation anymore, but can't seem to boot directly on the D Drive.

When I tell the computer to boot from D:\, windows is looking for a
file
in
the old C:\windows folder.

Have tried the control console rebuild cfg but that only let me add an
entry, rather than fix it so that I can only boot from D:

My current ini file is listed below. Deleting the last line does not work.
Would really appreciate any suggestions.
thanks
b


[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="WinXP" D:\windows
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /noexecute=optin /fastdetect
C:\="Microsoft Windows"

The syntax of boot.ini is incorrect. It should look like this:

[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /noexecute=optin /fastdetect
C:\="Microsoft Windows"

Note that the file implies that you have two disks, not just
one. Is this correct?

If this does not work, report exactly what happens. Don't
just say "It's looking for a file in the old C:\Windows folder".
This tells us nothing at all!

Ok, I set my bios to boot from the HDD1 drive (which has XP on it) instead
of HDD0

I have both a boot.ini and boot.int file on that drive
Also have the NTLDR file as well as the NTDETECT.com file and NTLDP file
on that drive.

It refuses to load, giving the message that it is missing:
<windows root>/system32/hal.dll
However, the file is there in the windows directory of the XP windows. so i
assume it is looking in C:\ but I am not sure why it is looking there.

Thank you very much for helping.

b

As Ron Sommer said, drive C: must remain your boot drive.
By changing the BIOS, you have created yourself several
problems:
- Boot.ini is now incorrect.
- The WinXP registry has a large number of entries that
point to drive D:. They are now all incorrect.
 
R

Ron Sommer

You Know Who ~ said:
Pegasus (MVP) said:
You Know Who ~ said:
Greetings:

I currently have a dual-boot drive with Windows 98 on C and Windows Home Xp
on D. The startup menu gives me a choice. I now don't need the win98
installation anymore, but can't seem to boot directly on the D Drive.

When I tell the computer to boot from D:\, windows is looking for a file in
the old C:\windows folder.

Have tried the control console rebuild cfg but that only let me add an
entry, rather than fix it so that I can only boot from D:

My current ini file is listed below. Deleting the last line does not work.
Would really appreciate any suggestions.
thanks
b


[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="WinXP" D:\windows
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /noexecute=optin /fastdetect
C:\="Microsoft Windows"

The syntax of boot.ini is incorrect. It should look like this:

[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /noexecute=optin /fastdetect
C:\="Microsoft Windows"

Note that the file implies that you have two disks, not just
one. Is this correct?

If this does not work, report exactly what happens. Don't
just say "It's looking for a file in the old C:\Windows folder".
This tells us nothing at all!

Ok, I set my bios to boot from the HDD1 drive (which has XP on it) instead
of HDD0

I have both a boot.ini and boot.int file on that drive
Also have the NTLDR file as well as the NTDETECT.com file and NTLDP file
on that drive.

It refuses to load, giving the message that it is missing:
<windows root>/system32/hal.dll
However, the file is there in the windows directory of the XP windows. so
i assume it is looking in C:\ but I am not sure why it is looking there.

Thank you very much for helping.

b
I have never heard of boot.int.
The hal.dll error could be from an incorrect boot.ini.
The rdisk value is now 0, because you changed the boot disk.
I have heard of XP booting and saying that it was on D.
I have never tried it myself.
 
Y

You Know Who

Not sure if there is a problem. Since winXP seems to be running fine on
drive D and is happy there, my thought was to leave it alone. Since my bios
lets me boot off the drive holding XP (which is still drive D) I assumed I
could start XP from there.

Are you saying that the startup files must always be on Drive C?

thanks


Andy said:
See
<http://groups.google.com/group/microsoft.public.win2000.general/browse_frm/
thread/ed1be28f5db0b674/f6064f5e00cad2a6?lnk=st&q=%22Removing+a+Win98+boot+d
rive%22+group%3Amicrosoft.public.win2000.general&rnum=1&hl=en#f6064f5e00cad2
a6>
for ideas on how to do it.

Greetings:

I currently have a dual-boot drive with Windows 98 on C and Windows Home Xp
on D. The startup menu gives me a choice. I now don't need the win98
installation anymore, but can't seem to boot directly on the D Drive.

When I tell the computer to boot from D:\, windows is looking for a file in
the old C:\windows folder.

Have tried the control console rebuild cfg but that only let me add an
entry, rather than fix it so that I can only boot from D:

My current ini file is listed below. Deleting the last line does not work.
Would really appreciate any suggestions.
thanks
b


[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="WinXP" D:\windows
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /noexecute=optin /fastdetect
C:\="Microsoft Windows"
 
T

Timothy Daniels

You Know Who said:
Not sure if there is a problem. Since winXP seems to be
running fine on drive D and is happy there, my thought
was to leave it alone. Since my bios lets me boot off
the drive holding XP (which is still drive D) I assumed I
could start XP from there.

Are you saying that the startup files must always be on Drive C?


If by "startup files", you mean the boot files ntldr, boot.ini,
and ntdetect.com, they can be on any partition on any HD
in the system. All that is necessary is that the HD is at the
head of the HD boot order and that the partition is a Primary
partition and marked "active". The OS can also be in any
partition (Primary or Extended) on any HD in the system.

If you continue with this thread, it would help to explicitly
state whether by "Drive C" you mean the HD that the OS's
partition is on, or the HD that the boot files are on, or the
partition that contains the OS, or the partition that contains
the boot files. The partition that contains the OS will be
named "Local Disk C:" by the OS if the OS was installed
without any other partitions visible to the installer. Otherwise,
if there was already a partition visible named "Local Disk C:",
the installer would have given the name "Local Disk D:" to
the new OS's partition. It sounds like the latter was your
case.

*TimDaniels*
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top