DRIVER_IRQL_NOT_LESS_OR_EQUAL Stop Error: RT61.sys


B

bex

Hi,
I'm running a 4-year-old laptop (Dell Inspiron 1100) with Windows XP Home
Edition 32-bit version (SP2).

Last week I reformatted my hard drive and reinstalled windows XP Home and
office 2007 - prior to this reinstallation I had Windows XP Pro on the
computer.

Two days after I reinstalled my Wireless Card (D-Link AirPlus G DWL-G630
version E1) I started getting a stop error, either on start-up or up to an
hour afterwards, and only when the wireless card was inserted. The stop error
referrs to the device driver for the wireless card, rt61.sys. After updating
the driver for the card from the manufacturers website, I am still getting
this error.

Full text of the bugcheck:

A problem has occurred and Windows has been shut down to prevent damage to
your computer.

DRIVER_IRQL_NOT_LESS_OR_EQUAL

If this is the first time you have seen this Stop error screen, restart your
computer. If this screen appears again, follow these steps: Check to make
sure any new hardware or software is properly installed. If this is a new
installation, ask your hardware or software manufacturer for any windows
updates you might need.

If problems continue, disable BIOS memory options such as caching or
shadowing. If you need to use SAFE mode to remove or disable components,
restart your computer, press F8 to select Advanced Startup Options, and then
select Safe Mode.

Technical Information:

STOP:0x000000D1(0x205500BF, 0x00000002, 0x00000000, 0xF71B55A1)

RT61.sys-Address f71b55A1 base at F7A5000 Date Stamp 42a19999

Beginning Dump of physical memory
Physical memory dump complete
Contact your system adminstrator or technical support group for further
assistance.

alternatively, here is the Error Signature from the Error Report:
BCC Code:100000d1
BCP1:205500BF
BCP2:00000002
BCP3:00000000
BCP4:F71F75A1
OsVer:5_1_2600
SP:2_0
Product:768_1


Sorry if much of that is bumf. Anyway, salient facts: I've been trying to
fix this for a couple of days and nothing I do is working. I know what the
problem relates to (my wireless card) but I've had the card for two years
running on the computer so there should be some way to make it work. From
what I can tell from reading other people's online complaints the problem is
more likely to occur on Dell Laptops, but no-one has got any help from dell
so far, and they haven't replied to me yet. I think the problem may be XP
Home specific as it never occurred on my system when I ran XP Pro: nothing
much has changed. My antivirus software is still AVGFree. Being a student, I
don't really want to go out and buy another wireless card, especially if it
may not fix the problem and there is a better fix available. I do have a BIOS
update for the computer that I can apply, but am a bit scared to (and it's
from 2004 and doesn't list the problem anyway). Basically I'm pretty computer
literate but have about reached my limit of good ideas here and really need a
hand! If the problem has occured so many times there must be some way of
fixing it, short of a hammer.

Please, does anyone know how to fix this so my computer will stop
complaining about my wireless card?
 
Ad

Advertisements

M

Mark L. Ferguson

Well, the main difference between Home and Pro is the "Administrator"
functions. My approach would be to test for some "Permissions" problem. My
first step would be to boot the Safe Mode (F8 on restart) and log on as the
default "Administrator" account to install the wireless driver. I may be
wasting your time, but I think it's worth a shot.

--
Please use the Communities guidelines when posting.
http://www.microsoft.com/wn3/locales/help/help_en-us.htm
Use the "Ratings" feature. It helps the new users.
Mark L. Ferguson MS-MVP
https://mvp.support.microsoft.com/profile/Mark.Ferguson
 
B

bex

Hi Mark,
When I reformatted the computer I was moderately aware of the administrator
function, and my own account is subtitled 'Computer Administrator' and is the
only one which shows up on the log-on screen. Not sure if that is relevant.

Anyway, I followed your advice and booted up in Safe mode. I went in to the
Administrator account. (I had removed the wireless card -the accompanying
documentation suggests you should before installing the driver - this might
explain the following/or not).

First I tried to run the device installation software from the cd to
uninstall it. I got the error message '1607: Unable to install InstallShield
Scripting Runtime'. I then tried to uninstall using the 'Add/Remove Programs
Wizard'. When I clicked the 'change/remove' button not much happened. I
sucessfully uninstalled another program.

So, then I opened the Add Hardware wizard and ran it to check for improperly
installed components. There was no mention of the wireless card (well,
obviously, I'd taken it out - I thought I had better to uninstall/install the
software). There was a red x through 'Broadcom 440x 10/100 Integrated
Controller' with the explanatory message ' This device is disabled (code 22)
in safe mode'. Assuming that was just because of safe mode. So, ticked
enable, restarted computer.

ran chkdsk to get rid of any gremlins accumulated from successive BSODS.

rebooted in Safe mode and attempted to install the driver for the Wireless
card. It gave me the same error message ' 1607: Unable to install
installshield scripting runtime.'

Any idea what is going on? It's driving me nuts, I'm supposed to be working
on my honours thesis.

Please let me know if you can think of anything. I really appreciate your
trying to help, it's brilliant.

Regards,
Bex.
 
Ad

Advertisements

Joined
Oct 9, 2016
Messages
1
Reaction score
0
Search for the latest version of your D-Link driver. If you already have I don't know how to fix it.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top