DNS and internet...

Discussion in 'Microsoft Windows 2000 DNS' started by William Stacey, Dec 11, 2003.

  1. On your DNS server, you need to add a forwarder entry to your ISP's DNS
    server IP and/or use root-hints. This will allow your DNS server to resolve
    external domain names.

    --
    William Stacey, MVP

    "James" <> wrote in message
    news:012801c3c01e$49f5c020$...
    > I have this problem with DNS on my server. On the client
    > machines, if I place the servers ip address, as the first
    > dns server, clients can log in and use mapped drives and
    > our database just fine, BUT they cnnot surf the web. If I
    > place the ip for our ISP first, they can surf the web, but
    > not connect to the server....why is that?
    >
    >
    > thanks
    >
    > james
     
    William Stacey, Dec 11, 2003
    #1
    1. Advertisements

  2. William Stacey

    James Guest

    I have this problem with DNS on my server. On the client
    machines, if I place the servers ip address, as the first
    dns server, clients can log in and use mapped drives and
    our database just fine, BUT they cnnot surf the web. If I
    place the ip for our ISP first, they can surf the web, but
    not connect to the server....why is that?


    thanks

    james
     
    James, Dec 11, 2003
    #2
    1. Advertisements

  3. In news:012801c3c01e$49f5c020$,
    James <> posted a question
    Then Kevin replied below:
    > I have this problem with DNS on my server. On the client
    > machines, if I place the servers ip address, as the first
    > dns server, clients can log in and use mapped drives and
    > our database just fine, BUT they cnnot surf the web. If I
    > place the ip for our ISP first, they can surf the web, but
    > not connect to the server....why is that?
    >
    >
    > thanks
    >
    > james


    You should NOT use the ISP's DNS in any posistion, on any machine in an AD
    domain, remove that. Your internal DNS probably has a "." forward lookup
    zone, if you delete that zone then it will resolve internet names. You can
    enable a forwarder to your ISP's DNS on the forwarders tab.
    300202 - HOW TO: Configure DNS for Internet Access in Windows 2000
    http://support.microsoft.com/?id=300202&FR=1

    --
    Best regards,
    Kevin D4 Dad Goodknecht Sr. [MVP]
    Hope This Helps
    ============================
    When responding to posts, please "Reply to Group" via your
    newsreader so that others may learn and benefit from your issue.
    To respond directly to me remove the nospam. from my email.
    ==========================================
    --
    http://www.lonestaramerica.com/
    ==========================================
    Use Outlook Express?... Get OE_Quotefix:
    It will strip signature out and more
    http://home.in.tum.de/~jain/software/oe-quotefix/
    ==========================================
    Keep a back up of your OE settings and folders with
    OEBackup:
    http://www.oehelp.com/OEBackup/Default.aspx
    ==========================================
     
    Kevin D. Goodknecht [MVP], Dec 11, 2003
    #3
  4. William Stacey

    Guest Guest

    Thank you very much, will try tonight after 5pm.

    Sincerely,

    James Dicken


    >-----Original Message-----
    >In news:012801c3c01e$49f5c020$,
    >James <> posted a

    question
    >Then Kevin replied below:
    >> I have this problem with DNS on my server. On the

    client
    >> machines, if I place the servers ip address, as the

    first
    >> dns server, clients can log in and use mapped drives

    and
    >> our database just fine, BUT they cnnot surf the web.

    If I
    >> place the ip for our ISP first, they can surf the web,

    but
    >> not connect to the server....why is that?
    >>
    >>
    >> thanks
    >>
    >> james

    >
    >You should NOT use the ISP's DNS in any posistion, on

    any machine in an AD
    >domain, remove that. Your internal DNS probably has

    a "." forward lookup
    >zone, if you delete that zone then it will resolve

    internet names. You can
    >enable a forwarder to your ISP's DNS on the forwarders

    tab.
    >300202 - HOW TO: Configure DNS for Internet Access in

    Windows 2000
    >http://support.microsoft.com/?id=300202&FR=1
    >
    >--
    >Best regards,
    >Kevin D4 Dad Goodknecht Sr. [MVP]
    >Hope This Helps
    >============================
    >When responding to posts, please "Reply to Group" via

    your
    >newsreader so that others may learn and benefit from

    your issue.
    >To respond directly to me remove the nospam. from my

    email.
    >==========================================
    >--
    > http://www.lonestaramerica.com/
    >==========================================
    >Use Outlook Express?... Get OE_Quotefix:
    >It will strip signature out and more
    > http://home.in.tum.de/~jain/software/oe-quotefix/
    >==========================================
    >Keep a back up of your OE settings and folders with
    >OEBackup:
    > http://www.oehelp.com/OEBackup/Default.aspx
    >==========================================
    >
    >
    >.
    >
     
    Guest, Dec 11, 2003
    #4
  5. William Stacey

    Guest Guest

    The "enable forwarder" is greyed out, and it
    says "forwaders are not available because this is a root
    server"

    james
    >-----Original Message-----
    >On your DNS server, you need to add a forwarder entry to

    your ISP's DNS
    >server IP and/or use root-hints. This will allow your

    DNS server to resolve
    >external domain names.
    >
    >--
    >William Stacey, MVP
    >
    >"James" <> wrote in

    message
    >news:012801c3c01e$49f5c020$...
    >> I have this problem with DNS on my server. On the client
    >> machines, if I place the servers ip address, as the

    first
    >> dns server, clients can log in and use mapped drives and
    >> our database just fine, BUT they cnnot surf the web. If

    I
    >> place the ip for our ISP first, they can surf the web,

    but
    >> not connect to the server....why is that?
    >>
    >>
    >> thanks
    >>
    >> james

    >
    >
    >.
    >
     
    Guest, Dec 11, 2003
    #5
  6. In news:1252d01c3c038$ec41e970$,
    <>
    posted a question
    Then Kevin replied below:
    > The "enable forwarder" is greyed out, and it
    > says "forwaders are not available because this is a root
    > server"
    >


    Delete the "." forward lookup zone as per my previous post.
    --
    Best regards,
    Kevin D4 Dad Goodknecht Sr. [MVP]
    Hope This Helps
    ============================
    When responding to posts, please "Reply to Group" via your
    newsreader so that others may learn and benefit from your issue.
    To respond directly to me remove the nospam. from my email.
    ==========================================
    --
    http://www.lonestaramerica.com/
    ==========================================
    Use Outlook Express?... Get OE_Quotefix:
    It will strip signature out and more
    http://home.in.tum.de/~jain/software/oe-quotefix/
    ==========================================
    Keep a back up of your OE settings and folders with
    OEBackup:
    http://www.oehelp.com/OEBackup/Default.aspx
    ==========================================
     
    Kevin D. Goodknecht [MVP], Dec 12, 2003
    #6
  7. William Stacey

    ML.net Guest

    Make sure you restart DNS otherwise it is still grayed out.

    ML.net

    "Kevin D. Goodknecht [MVP]" <> wrote in message
    news:%...
    > In news:1252d01c3c038$ec41e970$,
    > <>
    > posted a question
    > Then Kevin replied below:
    > > The "enable forwarder" is greyed out, and it
    > > says "forwaders are not available because this is a root
    > > server"
    > >

    >
    > Delete the "." forward lookup zone as per my previous post.
    > --
    > Best regards,
    > Kevin D4 Dad Goodknecht Sr. [MVP]
    > Hope This Helps
    > ============================
    > When responding to posts, please "Reply to Group" via your
    > newsreader so that others may learn and benefit from your issue.
    > To respond directly to me remove the nospam. from my email.
    > ==========================================
    > --
    > http://www.lonestaramerica.com/
    > ==========================================
    > Use Outlook Express?... Get OE_Quotefix:
    > It will strip signature out and more
    > http://home.in.tum.de/~jain/software/oe-quotefix/
    > ==========================================
    > Keep a back up of your OE settings and folders with
    > OEBackup:
    > http://www.oehelp.com/OEBackup/Default.aspx
    > ==========================================
    >
    >
     
    ML.net, Dec 12, 2003
    #7
  8. In news:,
    ML.net <> posted a question
    Then Kevin replied below:
    > Make sure you restart DNS otherwise it is still grayed out.
    >
    > ML.net
    >


    Actually all you need to do is refresh the DNS console, as the article I
    posted states.



    --
    Best regards,
    Kevin D4 Dad Goodknecht Sr. [MVP]
    Hope This Helps
    ============================
    When responding to posts, please "Reply to Group" via your
    newsreader so that others may learn and benefit from your issue.
    To respond directly to me remove the nospam. from my email.
    ==========================================
    --
    http://www.lonestaramerica.com/
    ==========================================
    Use Outlook Express?... Get OE_Quotefix:
    It will strip signature out and more
    http://home.in.tum.de/~jain/software/oe-quotefix/
    ==========================================
    Keep a back up of your OE settings and folders with
    OEBackup:
    http://www.oehelp.com/OEBackup/Default.aspx
    ==========================================
     
    Kevin D. Goodknecht [MVP], Dec 12, 2003
    #8
  9. In news:,
    ML.net <> posted their thoughts, then I offered mine
    > Make sure you restart DNS otherwise it is still grayed out.
    >
    > ML.net
    >


    No need to restart DNS or the system.

    --
    Regards,
    Ace

    Please direct all replies to the newsgroup so all can benefit.
    This posting is provided "AS IS" with no warranties.

    Ace Fekay, MCSE 2000, MCSE+I, MCSA, MCT, MVP
    Microsoft Windows MVP - Active Directory
    --
    =================================
     
    Ace Fekay [MVP], Dec 12, 2003
    #9
  10. William Stacey

    Jeff Cochran Guest

    On Thu, 11 Dec 2003 11:38:01 -0800, "James"
    <> wrote:

    >I have this problem with DNS on my server. On the client
    >machines, if I place the servers ip address, as the first
    >dns server, clients can log in and use mapped drives and
    >our database just fine, BUT they cnnot surf the web. If I
    >place the ip for our ISP first, they can surf the web, but
    >not connect to the server....why is that?


    Because you're using DNS incorrectly. :)

    You should only have your DNS in the client settings, and set your DNS
    to forward unanswered queries to your ISP.

    Jeff
     
    Jeff Cochran, Dec 12, 2003
    #10
  11. J> [Nearly the canonical text ...] why is that?

    <URL:http://homepages.tesco.net./~J.deBoynePollard/FGA/dns-client-all-proxies-must-provide-same-service.html>
    <URL:http://homepages.tesco.net./~J.deBoynePollard/FGA/dns-monolithic-server-as-proxy.html>
     
    Jonathan de Boyne Pollard, Dec 12, 2003
    #11
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. =Cobra=

    DNS ??? and two dedicated Web Servers Running DNS on both.

    =Cobra=, Sep 22, 2003, in forum: Microsoft Windows 2000 DNS
    Replies:
    2
    Views:
    633
    Jonathan de Boyne Pollard
    Sep 24, 2003
  2. Bob Doyle
    Replies:
    3
    Views:
    8,589
    Dean Wells [MVP]
    Sep 27, 2003
  3. Amanda

    DNS Issues with Windows 2000 DC and DNS

    Amanda, Oct 31, 2003, in forum: Microsoft Windows 2000 DNS
    Replies:
    2
    Views:
    422
    Michael Johnston [MSFT]
    Nov 3, 2003
  4. Roy Lawson

    Internal DNS problems and w2k DNS

    Roy Lawson, Feb 12, 2004, in forum: Microsoft Windows 2000 DNS
    Replies:
    3
    Views:
    397
    Kevin D. Goodknecht [MVP]
    Feb 12, 2004
  5. David Quick

    ISP DNS server and Internal DNS server

    David Quick, Mar 4, 2004, in forum: Microsoft Windows 2000 DNS
    Replies:
    6
    Views:
    641
    Ace Fekay [MVP]
    Mar 6, 2004
  6. Ratmoler Hamstak
    Replies:
    2
    Views:
    1,024
    Jonathan de Boyne Pollard
    Apr 13, 2004
  7. Cobra
    Replies:
    6
    Views:
    672
    Kevin D. Goodknecht [MVP]
    May 23, 2004
  8. MC

    Can't reach Internet from DNS server using DNS

    MC, Jun 2, 2006, in forum: Microsoft Windows 2000 DNS
    Replies:
    4
    Views:
    2,162
Loading...