Disable 'send message' shortcuts (ctrl+enter, alt+s) in Outloook


G

Guest

I often accidentally send an unfinished email. I use keyboard shortcuts when
editing text, and can therefore easily hit alt+s, or, even more easily,
ctrl+enter, both of which send the message. No doubt some people find these
shortcuts useful, but I would love to disable them, and various people have
said the same. I know that in theory I can assign alt+s to some dummy macro
or something, but it doesn't solve the ctrl+enter problem.

----------------
This post is a suggestion for Microsoft, and Microsoft responds to the
suggestions with the most votes. To vote for this suggestion, click the "I
Agree" button in the message pane. If you do not see the button, follow this
link to open the suggestion in the Microsoft Web-based Newsreader and then
click "I Agree" in the message pane.

http://www.microsoft.com/office/community/en-us/default.mspx?mid=b869574e-efc2-4e98-a840-bad7a42febc8&dg=microsoft.public.outlook.general
 
Ad

Advertisements

S

Sue Mosher [MVP-Outlook]

You can disable Ctrl+Enter or any key combination With either Group Policy Objects or a manual edit of the registry. The policy approach is explained at http://office.microsoft.com/en-us/assistance/HA011402401033.aspx. Concentrate on the section on "Disabling shortcut keys," which contains the key code information you'll need if you edit the registry by hand. Make a backup first!

For the non-policy approach, navigate in the Registry Editor to the HKCU\Software\Microsoft\Office\11.0\Outlook key and create a new key named DisabledShortcutKeysCheckBoxes (assuming one does not already exist). For each key combination you want to disable, create a new string (REG_SZ) value in the DisabledShortcutKeysCheckBoxes key, give it a name appropriate for the key you want to disable and enter the key code from the article mentioned above. For example, the code for Ctrl+Enter would be 13,8 and for Alt+S, it would be 16,83.
 
G

Guest

My problem is that this happens at least 2-3 times a month while I'm at work,
and I'm unable to edit the registry at work due to administrator
restrictions. It would be nice to see this avaialbe as a user configurable
option within the application.
 
G

Guest

Sue Mosher said:
You can disable Ctrl+Enter or any key combination With either Group Policy Objects or a manual edit of the registry. The policy approach is explained at http://office.microsoft.com/en-us/assistance/HA011402401033.aspx. Concentrate on the section on "Disabling shortcut keys," which contains the key code information you'll need if you edit the registry by hand. Make a backup first!

For the non-policy approach, navigate in the Registry Editor to the HKCU\Software\Microsoft\Office\11.0\Outlook key and create a new key named DisabledShortcutKeysCheckBoxes (assuming one does not already exist). For each key combination you want to disable, create a new string (REG_SZ) value in the DisabledShortcutKeysCheckBoxes key, give it a name appropriate for the key you want to disable and enter the key code from the article mentioned above. For example, the code for Ctrl+Enter would be 13,8 and for Alt+S, it would be 16,83.

--
Sue Mosher, Outlook MVP
Author of
Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers
 
G

Guest

Hi,

I've changed my registry settings but it didn't seem to make a difference:

Key:
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\DisableShortcutKeysCheckBox
Name: Ctrl+Enter
Value: 13,8

This is a really frustrating issue, there should be an easier way...

Thanks

Gerard
 
G

Guest

The same happened to me, I did exactly this and the problem still exists . I
use outlook in spanish and spanish keyboard. Does it have something to do
with this?
 
Ad

Advertisements

I

ITchick

Has anyone found a solution for Vista? I can disable Alt S but not control
enter. Thank you.
 
S

Still_learning

What would the value be for ALT + click?

GS said:
Hi,

I've changed my registry settings but it didn't seem to make a difference:

Key:
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\DisableShortcutKeysCheckBox
Name: Ctrl+Enter
Value: 13,8

This is a really frustrating issue, there should be an easier way...

Thanks

Gerard
 
D

Diane Poremsky [MVP]

That’s for the research pane, right? AFAIK< you can't disable it, although
many would like to.

--
Diane Poremsky [MVP - Outlook]



Outlook Tips by email:
mailto:dailytips-subscribe-request@lists.outlooktips.net

EMO - a weekly newsletter about Outlook and Exchange:
mailto:EMO-NEWSLETTER-SUBSCRIBE-REQUEST@PEACH.EASE.LSOFT.COM

Let's Really Fix Outlook 2010
http://forums.slipstick.com/forumdisplay.php?f=34
 
K

Kristin

I'd like to reiterate that this is a really significant problem. I can't
fully communicate my frustration with this shortcut in this message. I too
use keyboard shortcuts at work when typing and have accidentally sent an
unfinished message.

First, there absolutely should not be a "send message" keyboard shortcut.
Who knows how many people have gotten fired because of this "convenience".

Second, there should be a simple way to disable all "send message"
shortcuts.

Third, Microsoft is constantly asking us to confirm things. But if you want
it to confirm "send message", no, you can't do that.

I'm trying to figure out how to disable the ctrl+enter shortcut from your
earlier message, but this is way over my head. Really, I have to edit the
Registry? You've got to be kidding.

Kristin

Diane Poremsky said:
That’s for the research pane, right? AFAIK< you can't disable it, although
many would like to.

--
Diane Poremsky [MVP - Outlook]



Outlook Tips by email:
mailto:dailytips-subscribe-request@lists.outlooktips.net

EMO - a weekly newsletter about Outlook and Exchange:
mailto:EMO-NEWSLETTER-SUBSCRIBE-REQUEST@PEACH.EASE.LSOFT.COM

Let's Really Fix Outlook 2010
http://forums.slipstick.com/forumdisplay.php?f=34

Still_learning said:
What would the value be for ALT + click?
 
Ad

Advertisements

D

Diane Poremsky [MVP]

what version of outlook do you use? In 2007 you can choose to use
Ctrl+Enter from the tools, options menu. Alt+S can't be disabled - and there
absolutely needs to be a keyboard shortcut for keyboarders - not everyone
uses a mouse for everything.

If you accidently send mail you can do one of two things- misspell the first
word so spell check when sending stops the send or type garbage (i.e.
something like "sdfkdf") in the cc field so it can't resolve to an email
address.

See http://www.outlook-tips.net/archives/2006/20060118.htm

--
Diane Poremsky [MVP - Outlook]



Outlook Tips by email:
mailto:dailytips-subscribe-request@lists.outlooktips.net

EMO - a weekly newsletter about Outlook and Exchange:
mailto:EMO-NEWSLETTER-SUBSCRIBE-REQUEST@PEACH.EASE.LSOFT.COM

Let's Really Fix Outlook 2010
http://forums.slipstick.com/forumdisplay.php?f=34

Kristin said:
I'd like to reiterate that this is a really significant problem. I can't
fully communicate my frustration with this shortcut in this message. I
too
use keyboard shortcuts at work when typing and have accidentally sent an
unfinished message.

First, there absolutely should not be a "send message" keyboard shortcut.
Who knows how many people have gotten fired because of this "convenience".

Second, there should be a simple way to disable all "send message"
shortcuts.

Third, Microsoft is constantly asking us to confirm things. But if you
want
it to confirm "send message", no, you can't do that.

I'm trying to figure out how to disable the ctrl+enter shortcut from your
earlier message, but this is way over my head. Really, I have to edit the
Registry? You've got to be kidding.

Kristin

Diane Poremsky said:
That’s for the research pane, right? AFAIK< you can't disable it,
although
many would like to.

--
Diane Poremsky [MVP - Outlook]



Outlook Tips by email:
mailto:dailytips-subscribe-request@lists.outlooktips.net

EMO - a weekly newsletter about Outlook and Exchange:
mailto:EMO-NEWSLETTER-SUBSCRIBE-REQUEST@PEACH.EASE.LSOFT.COM

Let's Really Fix Outlook 2010
http://forums.slipstick.com/forumdisplay.php?f=34

message
What would the value be for ALT + click?

:

Hi,

I've changed my registry settings but it didn't seem to make a
difference:

Key:
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\DisableShortcutKeysCheckBox
Name: Ctrl+Enter
Value: 13,8

This is a really frustrating issue, there should be an easier way...

Thanks

Gerard


:

You can disable Ctrl+Enter or any key combination With either Group
Policy Objects or a manual edit of the registry. The policy approach
is
explained at
http://office.microsoft.com/en-us/assistance/HA011402401033.aspx.
Concentrate on the section on "Disabling shortcut keys," which
contains
the key code information you'll need if you edit the registry by
hand.
Make a backup first!

For the non-policy approach, navigate in the Registry Editor to the
HKCU\Software\Microsoft\Office\11.0\Outlook key and create a new key
named DisabledShortcutKeysCheckBoxes (assuming one does not already
exist). For each key combination you want to disable, create a new
string (REG_SZ) value in the DisabledShortcutKeysCheckBoxes key,
give
it a name appropriate for the key you want to disable and enter the
key
code from the article mentioned above. For example, the code for
Ctrl+Enter would be 13,8 and for Alt+S, it would be 16,83.

--
Sue Mosher, Outlook MVP
Author of
Microsoft Outlook Programming - Jumpstart for
Administrators, Power Users, and Developers



message I often accidentally send an unfinished email. I use keyboard
shortcuts when
editing text, and can therefore easily hit alt+s, or, even more
easily,
ctrl+enter, both of which send the message. No doubt some people
find these
shortcuts useful, but I would love to disable them, and various
people have
said the same. I know that in theory I can assign alt+s to some
dummy macro
or something, but it doesn't solve the ctrl+enter problem.

----------------
This post is a suggestion for Microsoft, and Microsoft responds to
the
suggestions with the most votes. To vote for this suggestion,
click
the "I
Agree" button in the message pane. If you do not see the button,
follow this
link to open the suggestion in the Microsoft Web-based Newsreader
and
then
click "I Agree" in the message pane.

http://www.microsoft.com/office/community/en-us/default.mspx?mid=b869574e-efc2-4e98-a840-bad7a42febc8&dg=microsoft.public.outlook.general
 
Joined
Jun 23, 2010
Messages
1
Reaction score
0
Finally - the right combination of codes and keys

Sue Mosher [MVP-Outlook] said:
For the non-policy approach, navigate in the Registry Editor to the HKCU\Software\Microsoft\Office\11.0\Outlook key and create a new key named DisabledShortcutKeysCheckBoxes (assuming one does not already exist). For each key combination you want to disable, create a new string (REG_SZ) value in the DisabledShortcutKeysCheckBoxes key, give it a name appropriate for the key you want to disable and enter the key code from the article mentioned above. For example, the code for Ctrl+Enter would be 13,8 and for Alt+S, it would be 16,83.
Unfortunately, this contains a couple of inaccuracies which means you'll have a tough time getting it to work (as I did).

The correct registry key is actually
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\11.0\Outlook\DisabledShortcutKeysCheckBoxes]

If any of that path does not exist, you will have to create the necessary keys for it (for me, the path only went as far as HKCU\Software\Policies\Microsoft, your mileage may vary).

Within that DisabledShortcutKeysCheckBoxes key itself you will need to create one String value for each shortcut key you want to block. I called mine "AltS" and "CtrlEnter", but the naming is entirely arbitrary, only the value of the string matters. The correct value for CtrlS is shown in the original post - "13,8" , but the code for Alt-S is in fact "83,16".

Once this is set, you just need to restart Outlook for it to take effect.

From the Microsoft article referenced in the original Sue Mosher post, you can work these values out for the shortcut of your choice as follows.

Modifier or key Value
ALT 16
CONTROL 8
SHIFT 4
A-Z A sequential number between 65 and 90, where A = 65, and Z = 90

Remember that the Modifier goes AFTER the keystroke in the String value (i.e. Alt-S = S,Alt = "83,16").

Hope that helps someone anyway, it took me a while to figure it out!
 
Joined
Nov 12, 2010
Messages
1
Reaction score
0
Disable shortcut keys in only some Outlook windows? Ctrl+D & Delete in Reminder

I need to disable the Ctrl+D and Delete shortcut keys in the Outlook 2010 Reminders dialog box only.

Is there a way to limit the applicability of the Registry based shortcut key disable keys to just certain windows within Outlook, particularly the Reminders dialog box?

(Or, to simply prevent the Reminders dialog box from EVER taking focus unless the user explicitly switches to that window?)

Thanks!
 
Joined
Mar 24, 2012
Messages
1
Reaction score
0
I NEED TO TURN OFF THAT !@# "ALT + S" OUTLOOK 2010 HOT KEY THAT "SENDS" EMAILS!

I HAVE BEEN BURNED WAY TOO MANY TIMES BY THIS, SENDING EMAILS THAT ARE NOT READY FOR PRIMETIME!

WHAT IS WRONG WITH YOU MICROSOFT? WAIT I DON'T HAVE ENOUGH TIME IN MY LIFE TO HEAR THAT ANSWER!

HOW DO I TURN THIS FREAKING THING OFF!

PLEASE!!!!!!!!!
 
Joined
May 26, 2013
Messages
1
Reaction score
0
Unfortunately, this contains a couple of inaccuracies which means you'll have a tough time getting it to work (as I did).

The correct registry key is actually
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\11.0\Outlook\DisabledShortcutKeysCheckBoxes]

If any of that path does not exist, you will have to create the necessary keys for it (for me, the path only went as far as HKCU\Software\Policies\Microsoft, your mileage may vary).

Within that DisabledShortcutKeysCheckBoxes key itself you will need to create one String value for each shortcut key you want to block. I called mine "AltS" and "CtrlEnter", but the naming is entirely arbitrary, only the value of the string matters. The correct value for CtrlS is shown in the original post - "13,8" , but the code for Alt-S is in fact "83,16".

Once this is set, you just need to restart Outlook for it to take effect.

From the Microsoft article referenced in the original Sue Mosher post, you can work these values out for the shortcut of your choice as follows.

Modifier or key Value
ALT 16
CONTROL 8
SHIFT 4
A-Z A sequential number between 65 and 90, where A = 65, and Z = 90

Remember that the Modifier goes AFTER the keystroke in the String value (i.e. Alt-S = S,Alt = "83,16").

Hope that helps someone anyway, it took me a while to figure it out!
Thank you SO MUCH for this correction! I've been pulling my hair out trying to get my registry edits to work - not realizing that I had the digits reversed in the string value!
 
Ad

Advertisements

Joined
Aug 31, 2015
Messages
1
Reaction score
0
Hi RinkleDinkle,
Thanks VERY MUCH for providing the correct information to disable the ALT_S and CtrlEnter in Outlook 2003. Saves frustration using Outlook and frustration using incorrect information in posts on other websites related to this issue. The internet is great but as with a book, "Smart people believe only half of what they read (find), brilliant people know which half!" ;-)
Bob
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top