Deperation time - 0xD1 BSOD p17.sys/portcls.sys



[apologies in advance for length of post]

Exasperation with my PC has finally led me to post

My system as it stands now: Athlon64 754 3000+/AsusK8VSE Del/1Gig Geil
DDR/Geforce 6800GT256MB/Soundblaster Audigy/Antec NeoHE 430/Fusion HDTV
card/Seagate 120GigIDE/Western Digital 250Gig SATA/LG 4120B 12x DVD-RW DL

for 6months + now I've been getting BSOD errors at random times. At first
this was mainly occuring with 3D games (Oblivion, HL2 etc) and nv4_disp.sys
etc and sometimes portcls.sys, but then it started happening more often and
usually D1 with portcls.sys. (was using onboard sound at time) A few times
while I was in the desktop (no 3D/graphics intense stuff going)

tried all the usual suspects. Extensive memory test (memtest 86 no errors
after hours), driver cleaning + reinstalling, reinstall software,
virus/spyware check, background tasks, overheating [Did actually clean out
my GFX card heatsink which had clogged up] - eventually complete reinstall
of WinXP with the latest drivers. WindowsXP was on the IDE drive.

Did extensive reading and research about portcls.sys errors and found that
it could be a problem with my onboard sound. Disabled onboard sound
completely (no Audigy at this point) and still got a couple nv4_disp and I
think win32 bluescreens.

Decided to make brand new partition on my SATA drive and do completely fresh
install of WinXP on this drive. Unfortunately same errors still occuring.
I buy an Audigy sound card to see if thats the issue - I've come across a
few posts about portcls/onboard sound issues - but this doesn't fix
anything. My regular BSOD's in 3D games seems to have come to an end, but
I've been getting many errors otherwise - watching DVD's & other video files
with both winmedia player and WinDVD's - even random blue screen even
without apparent sound playing (could be IE page click sound though). I
count at least 4-5 times I've been wathing a DVD/Video in full screen, heard
the windows messenger new message sound and instant bluescreen. Have had it
blue screen sometimes when I'm away from the computer.

I also have had a couple of other BSOD, win32, ntoskernel, UDFS_FILE_SYSTEM,
0x50, 0x7E etc, and after another extensive memtest86 run (many hours zero
errors), I decide to buy a new powersupply (rationalising it with reducing
noise anyway - I HAVE made my system really quiet when I'm not doing
anything stressful). Buy Antec NeoHE 430watt a couple days ago .. I have
had 3 BSOD's since then, including one during writing this post, all with
p17.sys and D1 DRIVER_IRQL_NOT_LESS_OR_EQUAL error.

I have of course looked at the IRQ's in device manager for possible
conflicts, disabling one or two onboard devices in bios, and moving the
soundcard to diff PCI slot (its currently as IRQ19 all to itself) - although
IRQL not usually hardware conlfict? Used original drivers with Audigy and
latest from creative, WinXP SP2 and critical updates installed. Bios, Via,
Amd, VGA, everything driverwise is up to date.

The absolute HARDEST thing about this problem is that I can't make it
happen - I've tried running a video while playing an mp3 having people
message me on MSN while browsing the internet and other crap - I can't
create the problem.

I've even tried downloading windows debugging software + symbols library,
not that I can make out too much from it. Following Information usually
Arg1: READ_ADDRESS: f7cf75ec (or) f7c8a685 (or) f7cc75ec etc(memory
Arg2: CURRENT_IRQL: 9 (always this with p17.sys errors)
Arg3: 00000000
always something like:
p17+276f7 (or p17+217d6)
(memory address varies) ff10 call dword ptr [eax] <- always appears

Stack trace always has the list of addresses and always has at the top
p17+0x276d6 (or p17+0x276f7)
---followed by a few p17+0xXXXX etc
---then ALWAYS followed by:
portcls!CKsShellRequestor::'vector deleting destructor'+0x48
---all stack traces differ after this

I'm not sure if this is relevant or not?

I've read various posts stating issues with VIA chipsets + Creative
soundblaster cards, and then I read other posts from people with similar VIA
+ Creative systems working just fine (or having issues resolved). Another
option for me (I guess) would be to swap out motherboard for another socket
754 board using diff chipset (but this just seems a waste, although
cheapish). It may eventually come to this, but I've always been able to
diagnose and/or fix PC problems in the past - and I'd really like to know
whats going on here.

Have I completely ruled out a memory error through 2 extensive memtest86

Am eager for any suggestions - especially ones that don't require
replacement of hardware :)

Thanks in Advance,


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question