debugger not automatically attaching aspnet_wp.exe as a debugged process


M

Mark Kamoski

Hi--

All of sudden (?) the VS.NET v1 IDE is NOT automatically attaching
aspnet_wp.exe as a debugged process.

Why?

Here is the situation.

VS.NET (v1)

Framework (latest version)

VB.NET code

ASP.NET application

Run code in IDE by choosing >Debug, >Start.

Code launches.

Go to the IDE, choose >Debug, >Processes.

The process "aspnet_wp.exe" is listed in the "Available Processes" list but
it is NOT listed in the "Debugged Processes" list.

It should be in the "Debugged Processes" list automatically!!!

As a result, the code will NOT hit any breakpoints.

How can this be fixed?

(Note that I know that I can select "aspnet_wp.exe" in the "Available
Processes" list and choose >Attach, >Common Language Runtime, and the
breakpoints will work and the process will become listed in the "Debugged
Processes" list. However, one should not have to set this manually every
time.)

Any ideas?

Please advise.

Thank you very much.

--Mark
 
Ad

Advertisements

J

Jim Cheshire [MSFT]

Hi Mark,

In your project properties, do you have ASP.NET Debugging enabled?

Jim Cheshire [MSFT]
Developer Support
ASP.NET
(e-mail address removed)

This post is provided as-is with no warranties and confers no rights.

--------------------
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top