Could not load file or assembly ONLY ON XP


S

SQACSharp

A .Net 4.0 C# application use an Net 4.0 managed C++ dll.

The application works correctly on Windows 7 but when running the
application on Windows XP I get the following error :

Could not load file or assembly 'MyCLIDll.dll' or one of its
dependencies. The specified module could not be found

Note that visual studio 2010 is only installed on my windows 7 but the
4.0 framework runtimes is correctly installed on xp. If my
application is built using 3.5 framework it works, so it's a 4.0
specific problem...and only on xp

I really need help

Thanks

mike
 
Ad

Advertisements

S

SQACSharp

- Nothing in event log
- Fusion log report nothing bad....everything comes from 4.0, no error
reported for that dll

I dont think it's releated to my dll, it's a 4.0 specific thing

So for you the only thing to do is to install Visual studio 2010 (not
wanted) on that winxp machine to debug it.

I'm currently creating a VM with xp and framework 4.0 to test it on a
second environment.
 
S

SQACSharp

Reproduced on virtual machine

With dependency Walker both non working computers are looking for
MSVCR100D.DLL

I'm currently trying to figure out how to change the project config to
avoid this problem.... I'm not a C++ expert I'm trying to understand
why compiling in net 4.0 add this dependency and how to fix this on
computer without MSVCR100D.DLL
 
S

SQACSharp

i'm very confused

1- Microsoft Visual C++ 2010 x86 redistributable 10.0.40219 is
installed on xp (just like on seven)
-> Still not able to find the msvcr100d.dll
2- I download a version of msvcr100d.dll and msvcr100.dll from the
internet and put it in the same directory
3- I have create a release version of my dll
-> The dll can now be opened by dependency walker without error but it
freeze when calling the dll inside my app

So look like there is another issue :( . DependencyWalker stop
complaining about msvcr100d.dll when msvcr100d.dll is copied in the
same directory manually. Looking for what else is missing now to make
the dll really working Is Microsoft Visual C++ 2010 x86
redistributable is the usal way to install VC10 CRT libraries on that
machine?

Thanks
 
S

SQACSharp

Ok... :(

Look like it need microsfot Visual C++ 2010 x86 Runtime 10.0.30319
(runtime NOT the "distribution" crap package)

After installing VS2010 on that machine and my application start to
work

After uninstalling microsfot Visual C++ 2010 x86 Runtime
10.0.30319 ... bang...same problem.


After an hour i'm stil trying to figure out **WHERE** to download this
package.

- Where I can download microsfot Visual C++ 2010 x86 Runtime
10.0.30319 ??
- Is there an obscur package to install that runtime?
- Is there any other way (than install the complete VS2010) to get
that microsfot Visual C++ 2010 x86 Runtime 10.0.30319
 
Ad

Advertisements

S

SQACSharp

almost 2 hours later still not sure about what to do with this. I have
to learn more about setup creation to see if the setup on end user
computer can fix the problem. I'm not even sure if c++ runtime is
installable like a standalone "pack" For some reasons after
uninstalling the runtime it never work again even after reinstalling
it. Anyway I have to play with setup, building a release version.
Still hope there is an easy way to do the missing magic
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top