Connecting to a Linux (samba) share from Vista


C

Chris Barnes

This is weird. From another computer in my office (one running WinXP
Pro), I can connect to a shared directory on a Linux machine running
samba. In fact, there are a hundred such computers - and I cannot to
the share from every single one of them.

Which of course means there is nothing wrong with the linux machine,
samba on that machine, nor my shared directory on that server.


But I cannot connect to the share from the PC in my office, which
happens to be running Vista (64bit, Enterprise). The networking on that
Vista machine otherwise works perfectly (can use IE, Thunderbird, IM
programs, etc.). The Windows Firewall is on, but "file and print
sharing" is listed as an exception.

Also, I can get TO the shared folders on the Vista machine.


Note that this is a fairly new problem - the sharing was working fine up
until about 2-3 weeks ago (when I did a Windows update). Solution?
 
Ad

Advertisements

C

Chris Barnes

One other factoid: I *can* connect to a samba share on a different
Linux box...
 
C

Chris Barnes

Well.... ok. I found the answer on my own.
http://www.geektieguy.com/2006/09/18/how-to-connect-to-older-samba-server-versions-using-vista-rc1/

He wrote:
I ran across an issue with my home network server, which is running an
older version of Linux and Samba to share files around the house. Vista
RC1 wouldn’t authenticate with the server. After some digging using
Google I found out that you need to change one of the local security
policies from “Send NTLMv2 response only” to “Send LM & NTLM - use
NTLMv2 session security if negotiated”.

HKLM/System/CurrentControlCset/Control/LSA - LMCompatibilityLevel

It’s 3 by default on Vista RC1 (NTLM2 only) and I had to change it to 1
(LM & NTLM, NTLMv2 if negotiated).
 
Ad

Advertisements

G

GTS

If Ultimate or Buisness version of Vista -

- Run secpol.msc
- Go to: Local Policies > Security Options
- Find "Network Security: LAN Manager authentication level"
- Change Setting from "Send NTLMv2 response only" to
"Send LM & NTLM - use NTLMv2 session security if negotiated"

If Home version (which lacks secpol) either save these 3 lines to a text
file with a reg extension and run it

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"LmCompatibilityLevel"=dword:00000001

OR
Manually edit the registry

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\LMCompatibilityLevel
If it doesn't already exist, create a DWORD value named
LmCompatibilityLevel
Set the value to 1
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top