COMException after upgrade to .Net 3.5


Jesse Hansen

We have an in-house developed application that uses a 3rd party COM control.
We recently upgraded the application to .Net 3.5. Everything runs smoothly on
Windows XP. We had previously tried the .Net 2.0 version on Windows Vista,
and it runs just fine as long as you have not. However, when we upgrade the
same machine to .Net 3.5 (preperatory to upgrading the application) the .Net
2.0 version will not run. It fails with this error:

Exception Source: atEmulatorCtrl2k2
Exception Type: System.Runtime.InteropServices.COMException
Exception Message: Object variable or With block variable not set
Exception Target Site: Apply

---- Stack Trace ----
atemu2k2.AccuTermClasses.Settings.Apply(flags As Int32)
Insight.exe: N 00000
atemu2k2.ControlWrapper.atEmulatorDotNet.set_InitialSettings(Value As
Insight.exe: N 00116
Insight.exe: N 01117
Insight.exe: N 00019
Insight.exe: N 00168
Insight.exe: N 00224
Insight.exe: N 00047

I have searched everywhere and cannot find anything that seems to match my
situation. I'm especially confused that the combination of Vista and .Net 3.5
seems to be the trigger. With 2.0 on Vista or 3.5 on XP the application runs
just fine.

I have run the application as both a limited user and administrator. Our
application is deployed currently to people with limited user accounts on XP.

Jesse Hansen

I should also have noted that I have isolated the problem to this specific
component. A plain vanilla Windows Forms project with this component dropped
in will create the same error.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question