Combo box auto populate problem with CAPS


S

slickdock

When caps lock is on, auto populate in my combo boxes gives me unpredictable
results. When caps lock is off, all is fine.

Has anyone heard of this? Is there a fix? If not, how can I programmatically
turn off caps lock when the combo box is in use?
 
Ad

Advertisements

D

Dirk Goldgar

slickdock said:
When caps lock is on, auto populate in my combo boxes gives me
unpredictable
results. When caps lock is off, all is fine.

Has anyone heard of this? Is there a fix? If not, how can I
programmatically
turn off caps lock when the combo box is in use?

What do you mean by "auto populate"? Do you mean "autoexpand"?

Does your combo box contain entries that differ only in case (upper vs.
lower)?

Please give an example of the unpredictable results you're getting,
contrasting what you get with what you expect to get.
 
S

slickdock

Sorry, Yes, I mean autoexpand, not auto populate.
The choices in the combo box may be any combination: Upper case, lower case,
or a mix.

What I mean by unpredictable is hard to put into words, but I'll show
examples:
Lets say Beard is in the list. But Beeman is not in the list.

If I type in all caps "BEA", the field auto expands to "Beard" properly.

If I type in all lower case "bee", I see "bee", as you would expect to see
when you don't have a match. Then I can easily backspace the second "e" to
find a correct match.

If I type in all caps "BEE", I see "BeEard". My cursor is then resting after
the capital E, then I have to delete forward and backward to erase everything
in the box before I can start finding a valid entry.

So the problem seems to be limited to the not in list behavior.
 
D

Dirk Goldgar

slickdock said:
Sorry, Yes, I mean autoexpand, not auto populate.
The choices in the combo box may be any combination: Upper case, lower
case,
or a mix.

What I mean by unpredictable is hard to put into words, but I'll show
examples:
Lets say Beard is in the list. But Beeman is not in the list.

If I type in all caps "BEA", the field auto expands to "Beard" properly.

If I type in all lower case "bee", I see "bee", as you would expect to see
when you don't have a match. Then I can easily backspace the second "e"
to
find a correct match.

If I type in all caps "BEE", I see "BeEard". My cursor is then resting
after
the capital E, then I have to delete forward and backward to erase
everything
in the box before I can start finding a valid entry.

So the problem seems to be limited to the not in list behavior.

Interesting. I can't reproduce this on a very simple test form, using
Access 2003. What version of Access are you using? Is there any code (or
macros) associated with the combo box's events?
 
S

slickdock

Version is Access 2002 sp3. No events at all associated with any of the combo
boxes. They all behave this way. In every one of my databases. It's like the
second you type a character that it can't find, it displays the wrong
character in upper case, inserted into the middle of the string of the found
text.
 
D

Dirk Goldgar

slickdock said:
Version is Access 2002 sp3. No events at all associated with any of the
combo
boxes. They all behave this way. In every one of my databases. It's like
the
second you type a character that it can't find, it displays the wrong
character in upper case, inserted into the middle of the string of the
found
text.

That's weird and I don't know why. I can't verify it as a bug, because I
don't have a copy of Access 2002 installed anywhere. Did you try a web
search for Access 2002 bugs?

Would you be interested in sending me a small example database that acts
this way for you, so I can see if it behaves this way for me using Access
2003? If so, please cut it down to just the minimum elements necessary to
display the problem, compact it, and zip it before sending. You can send it
to the address derived by removing NO SPAM and ".invalid" from the reply
address of this message. If that address isn't visible to you, you can get
my address from my web site, which is listed in my sig. Do *not* post my
real address in the newsgroup -- I don't want to be buried in spam and
viruses.
 
Ad

Advertisements

S

slickdock

It's on the way. Expect an email from karen at wpi dot com.
Thank you.
 
S

slickdock

Thank you for your advice to "turn off the AllowAutocorrect option on the
combo box. That option is on the Other tab of the control's property sheet."
You nailed it!! :)
 
Ad

Advertisements

Joined
Sep 16, 2014
Messages
1
Reaction score
0
Setting the AllowAutoCorrect to No also worked for me in Access 2007. Thanks for the help!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top