Com Port error

Discussion in 'Windows XP Basics' started by Jim Gainsley, Jul 22, 2006.

  1. Jim Gainsley

    Jim Gainsley Guest

    We are attempting to run some 16-bit software which ran nicely under
    Win98SE, but fails to communicate with Com 1 under WinXP Pro SP2. We get the
    message in a command prompt window in a dialogue box titled MS-DOS
    Subsystem, "Driver doesn't support baud rate (9600). Close Ignore" We've
    tried several baud rates with the same result. Each time we configured the
    com1 port in Device Manager for the intended baud rate.

    I don't find anything in the Resource Guide about this. Anyone have any
    ideas about what we can do?

    Jim
     
    Jim Gainsley, Jul 22, 2006
    #1
    1. Advertisements

  2. Jim Gainsley

    Rick Rogers Guest

    Hi,

    You should check with the software distributer for assistance. By the by,
    WindowsXP does not support 16-bit programs that attempt to directly address
    the system hardware. Software needs to pass hardware instructions to the
    operating system.

    --
    Best of Luck,

    Rick Rogers, aka "Nutcase" - Microsoft MVP

    Windows help - www.rickrogers.org

    "Jim Gainsley" <> wrote in message
    news:...
    > We are attempting to run some 16-bit software which ran nicely under
    > Win98SE, but fails to communicate with Com 1 under WinXP Pro SP2. We get
    > the
    > message in a command prompt window in a dialogue box titled MS-DOS
    > Subsystem, "Driver doesn't support baud rate (9600). Close Ignore" We've
    > tried several baud rates with the same result. Each time we configured
    > the
    > com1 port in Device Manager for the intended baud rate.
    >
    > I don't find anything in the Resource Guide about this. Anyone have any
    > ideas about what we can do?
    >
    > Jim
    >
    >
     
    Rick Rogers, Jul 23, 2006
    #2
    1. Advertisements

  3. Jim Gainsley

    Robert Gault Guest

    Jim Gainsley wrote:
    > We are attempting to run some 16-bit software which ran nicely under
    > Win98SE, but fails to communicate with Com 1 under WinXP Pro SP2. We get the
    > message in a command prompt window in a dialogue box titled MS-DOS
    > Subsystem, "Driver doesn't support baud rate (9600). Close Ignore" We've
    > tried several baud rates with the same result. Each time we configured the
    > com1 port in Device Manager for the intended baud rate.
    >
    > I don't find anything in the Resource Guide about this. Anyone have any
    > ideas about what we can do?
    >
    > Jim
    >
    >

    What is the program you are trying to run?
     
    Robert Gault, Jul 23, 2006
    #3
  4. On Sat, 22 Jul 2006 12:31:02 -0500, "Jim Gainsley"
    <> wrote:

    >We are attempting to run some 16-bit software which ran nicely under
    >Win98SE, but fails to communicate with Com 1 under WinXP Pro SP2. We get the
    >message in a command prompt window in a dialogue box titled MS-DOS
    >Subsystem, "Driver doesn't support baud rate (9600). Close Ignore" We've
    >tried several baud rates with the same result. Each time we configured the
    >com1 port in Device Manager for the intended baud rate.


    My guess is that your application is programmed to access I/O
    registers directly, and not through Windows' API calls, as it should.
    Windows 98 allows such direct hardware access, but XP does not.

    The obvious solution is, of course, to upgrade the software to proper
    32-bit design, but that may not be a possibility for you?

    You might try to install '98 on a virtual machine and see if VMware's
    hardware emulation can handle your situation.

    --
    RoRo
     
    Robert Roland, Jul 23, 2006
    #4
  5. Jim Gainsley

    Jim Gainsley Guest

    The program is a C8051 compiler for the Dallas cpu by Kiel and they do not
    provide an upgraded version for this particular CPU..


    "Robert Gault" <> wrote in message
    news:f8Cwg.162745$...
    > Jim Gainsley wrote:
    > > We are attempting to run some 16-bit software which ran nicely under
    > > Win98SE, but fails to communicate with Com 1 under WinXP Pro SP2. We get

    the
    > > message in a command prompt window in a dialogue box titled MS-DOS
    > > Subsystem, "Driver doesn't support baud rate (9600). Close Ignore"

    We've
    > > tried several baud rates with the same result. Each time we configured

    the
    > > com1 port in Device Manager for the intended baud rate.
    > >
    > > I don't find anything in the Resource Guide about this. Anyone have any
    > > ideas about what we can do?
    > >
    > > Jim
    > >
    > >

    > What is the program you are trying to run?
     
    Jim Gainsley, Jul 23, 2006
    #5
  6. Jim Gainsley

    Jim Gainsley Guest

    Okay we can try that, just a minute... Well it doesn't work but I get a
    different message, simply, "cannot communicate with port 1". This is a
    standard Keil message. And no, we can't get a 32bit version of this
    particular complier. Any other thoughts?

    Jim



    "Robert Roland" <> wrote in message
    news:...
    > On Sat, 22 Jul 2006 12:31:02 -0500, "Jim Gainsley"
    > <> wrote:
    >
    > >We are attempting to run some 16-bit software which ran nicely under
    > >Win98SE, but fails to communicate with Com 1 under WinXP Pro SP2. We get

    the
    > >message in a command prompt window in a dialogue box titled MS-DOS
    > >Subsystem, "Driver doesn't support baud rate (9600). Close Ignore"

    We've
    > >tried several baud rates with the same result. Each time we configured

    the
    > >com1 port in Device Manager for the intended baud rate.

    >
    > My guess is that your application is programmed to access I/O
    > registers directly, and not through Windows' API calls, as it should.
    > Windows 98 allows such direct hardware access, but XP does not.
    >
    > The obvious solution is, of course, to upgrade the software to proper
    > 32-bit design, but that may not be a possibility for you?
    >
    > You might try to install '98 on a virtual machine and see if VMware's
    > hardware emulation can handle your situation.
    >
    > --
    > RoRo
    >
     
    Jim Gainsley, Jul 23, 2006
    #6
  7. Jim Gainsley

    Robert Gault Guest

    Jim Gainsley wrote:
    > The program is a C8051 compiler for the Dallas cpu by Kiel and they do not
    > provide an upgraded version for this particular CPU..
    >


    Are you referring to a program from this site, http://www.keil.com/ ? I
    did not see a program that would run under WinXP. I might have some
    suggestions if I knew exactly what you were trying to do.
     
    Robert Gault, Jul 23, 2006
    #7
  8. Jim Gainsley

    Robert Gault Guest

    On a second look I did find this.
    Keil Evaluation software
    "Your computer must meet certain minimum system requirements for the
    evaluation software to function properly.

    * Windows 98, Windows NT Version 4, Windows 2000, Windows XP
    * Mouse or Similar Pointing Device
    * 30 Megabytes Free Hard Disk Space
    * 128 Megabytes of RAM"

    So if I'm looking at the correct company, your software should run. Have
    you checked with Keil product support?
     
    Robert Gault, Jul 23, 2006
    #8
  9. On Sun, 23 Jul 2006 14:02:11 -0500, "Jim Gainsley"
    <> wrote:

    >Well it doesn't work but I get a
    >different message, simply, "cannot communicate with port 1".


    Did you remember to map the virtual COM port to a physical one?

    --
    RoRo
     
    Robert Roland, Jul 24, 2006
    #9
  10. Jim Gainsley

    Jim Gainsley Guest

    No, how does one do that?

    "Robert Roland" <> wrote in message
    news:...
    > On Sun, 23 Jul 2006 14:02:11 -0500, "Jim Gainsley"
    > <> wrote:
    >
    > >Well it doesn't work but I get a
    > >different message, simply, "cannot communicate with port 1".

    >
    > Did you remember to map the virtual COM port to a physical one?
    >
    > --
    > RoRo
    >
     
    Jim Gainsley, Jul 26, 2006
    #10
  11. Jim Gainsley

    Jim Gainsley Guest

    They do have a program that works with later cpu's, but not the Dallas
    DS2250-64-16. Thanks a lot for your insights--keep;em coming<g>!

    (Incidentally we have found a way to make this work by using a USB to RS232
    converter cable, where the USB driver is configured for an unused com port,
    but we'd prefer to have it work directly.)

    Jim

    "Robert Gault" <> wrote in message
    news:bNSwg.165700$...
    > On a second look I did find this.
    > Keil Evaluation software
    > "Your computer must meet certain minimum system requirements for the
    > evaluation software to function properly.
    >
    > * Windows 98, Windows NT Version 4, Windows 2000, Windows XP
    > * Mouse or Similar Pointing Device
    > * 30 Megabytes Free Hard Disk Space
    > * 128 Megabytes of RAM"
    >
    > So if I'm looking at the correct company, your software should run. Have
    > you checked with Keil product support?
     
    Jim Gainsley, Jul 26, 2006
    #11
  12. On Wed, 26 Jul 2006 12:59:05 -0500, "Jim Gainsley"
    <> wrote:

    >No, how does one do that?


    It depends, of course, which visualization software you are using. I
    use VMware Workstation, and I do it like this:

    - Before you start your virtual machine, choose "Edit virtual machine
    settings".
    - In the "Hardware" tab, click "Add", and then "Next".
    - Choose "Serial port", and click "Next".
    - Choose "Use physical serial port on the host", and click "Next".
    - Choose which physical serial port you have your device connected to
    (COM1).
    - Click "Finish".
    - You will now have a new hardware device in your list, and when you
    start your virtual machine, output will be piped through to your
    physical port.

    --
    RoRo
     
    Robert Roland, Jul 27, 2006
    #12
  13. Jim Gainsley

    Jim Gainsley Guest

    Thanks very much! I'll see if it works for us--we have Virtual PC 2004 with
    the sp.

    "Robert Roland" <> wrote in message
    news:...
    > On Wed, 26 Jul 2006 12:59:05 -0500, "Jim Gainsley"
    > <> wrote:
    >
    > >No, how does one do that?

    >
    > It depends, of course, which visualization software you are using. I
    > use VMware Workstation, and I do it like this:
    >
    > - Before you start your virtual machine, choose "Edit virtual machine
    > settings".
    > - In the "Hardware" tab, click "Add", and then "Next".
    > - Choose "Serial port", and click "Next".
    > - Choose "Use physical serial port on the host", and click "Next".
    > - Choose which physical serial port you have your device connected to
    > (COM1).
    > - Click "Finish".
    > - You will now have a new hardware device in your list, and when you
    > start your virtual machine, output will be piped through to your
    > physical port.
    >
    > --
    > RoRo
    >
     
    Jim Gainsley, Jul 27, 2006
    #13
  14. On Thu, 27 Jul 2006 08:46:48 -0500, "Jim Gainsley"
    <> wrote:

    >Thanks very much! I'll see if it works for us--we have Virtual PC 2004 with
    >the sp.


    In VPC2004, the procedure us similar:

    - In the console, click your machine and click "Settings".
    - Choose the COM port, and then choose which physical COM port it
    should be mapped to.
    - Click "OK".

    --
    RoRo
     
    Robert Roland, Jul 30, 2006
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.