CMI Error 0x80070057 parameter incorrect after modifying database



TargetDesigner fails to open an previously working slx file (or create a new
one) with the above error.

I moved my database and repository from one PC to a newer one by copying the
files over. When I ran target designer the dependency check succeeded but the
build failed with all files not found. I opened the database in SQL Server
manager and modified the location of the repositiory files in table
RepositoryObjects, field SrcPath. This got the build working. I noticed that
the cmiRepRootPath record in ExtendedProperty was also wrong so I corrected
this, and now TDesign won't load existing slx or create new ones.

The error given is as in the subject.

EventViewer has some relevant log entries:

The CMI encountered the following error: 0x80070057 (-2147024809) The
parameter is incorrect.

The CMI encountered the following error: 0x80070057 (-2147024809) Method
CMI.GetDBProperties failed.

The CMI encountered the following error: 0x8004234A (-2147212470) An error
occurred in the running script Configuration: Windows XP Embedded Client
Source: ?
Description: The parameter is incorrect.

Help File: ?
HelpContext: 0
Error code: 0x80070057 (-2147024809)
Source Line Text: ?
Source Line number: 2617
Source Line position: 4


I have used CMI explorer to enumerate the database and this works OK:

*dbopen \\uksl6307\sqlexpress
Server : uksl6307\sqlexpress
Database : MantisSQLDB
Generation : {4D947BAC-41E0-49FA-89CE-9DDF1F61E6BA}
Open mode : ReadImport (1)
Enumeration time : 422.80 seconds
Component count : 12430 (29.40 per second)
Visible : 10556
Invisible : 1874
Prototypes : 53
Device drivers : 9534
Non-drivers : 2896
Feature comps : 1022
Group memberships : 17160
Cooked dependencies : 42572
Disabled : 183
Resource count : 258339
Missing restype : 0
Ordered : 189483
Component properties: 79244
Resource properties : 1879007
Dependency props : 32327
Total properties : 1990578
Unique prop names : 1195

I tried to use Component Database Manager to set the repository root but
this throws an error:'Cannot save import locations to the database'.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question