Clients cannot print


M

Mike Gallagher

Hello All,
I recently installed a new server, and the printing is an
issue with the new server (Windows 2000). Here's the
problem: When users try and print to the shared printer it
says "Failed to print". If I set the printer properties on
the server to print directly rather than spooling it works
fine. If I sign on as a member of the domain admin's group
to the user's machine spooling works fine.

The permissions on the printers say "everyone" has
printing access. However, only admins can print with
spooling enabled. I changed the permissions on the spooler
folder to mimic those of a print server in another
location, and it still didn't work.

Any ideas?

Mike Gallagher
 
Ad

Advertisements

M

Michael Holzemer

This is a workgroup? Try enabling the guest account and giving it print
permissions to that printer.
 
T

Teresa Barlow

Started having the same problem with "failed to print"
errors after stopping the print spooler service to clear
the spooler when a print job would not delete. This in on
a domain with guest account disabled. This is only
occuring with OfficeJet G85s, the HP2100s are not
affected ... any suggestions?

Thanks in advance,
Teresa Barlow
 
M

Mike Gallagher

This isn't in a workgroup, it's on an AD domain. It's
happening with all printers on this server. Domain admins
can print but nobody else.
 
B

Bruce Sanderson

The permissions on the system32\spool folder should be:
Administrators - Full Control - This folder, subfoders and files
CREATOR OWNER - Full Control - Subfolders and files only
Power Users - Modify - This folder, subfolders and files
SYSTEM - Full Control - This folder, subfolders and files
Users - Read & Execute - This folder, subfolders and files

In the Advanced, Permissions page,
Make sure that "Allow inheritable permissions from parent to propogate to
this object is checked"
Turn on Reset permisssions on all child objects..."
click OK, Yes

In the Permissions on the printers, make sure that CREATOR OWNER has the
Manage Documents permission.
 
Ad

Advertisements

Joined
Dec 16, 2009
Messages
1
Reaction score
0
RE: domain users can't print to network attached printer but admins can.

I had the same problem (twice actually, but was able to solve it by following the instructions of a thread at https://www.pcreview.co.uk/forums/thread-1568855.php, plus another thing.
Basic Gist:

(assuming the computer with the printer attached is registered in the domain and you can print from locally from that computer, and the printer is added to the active directory.)

1. Make sure on the local computer that the permissions are correct for the printer, and also the spool directory (windows/system32/spool). For me, I'd have thought that the permissions would include domain users, etc since the computer was in the domain, but they were there. So i added them, and then made sure all the files in the underlying directories were the same permission.

2. After saving the permissions, I was able to add the printer for more user from the active directory (domain user, not domain admin). But then for some reason I couldn't add more. (ARG!)

3. After playing with it more, I tried restarting the print spooler service on the local machine (run-->services.msc-->print Spooler (restart)).

4. After that I was able to add all the other users.

I suppose that after changing the permissions, i could have restarted the machine and that would have worked too. Since I haven't had this permission problem occur in all my implementations, I'm guessing that the way I added the computer to the domain didn't do everything it was supposed to (I think i just went to My Computer (properties), and joined the domain there... but not sure).


Anyhoo, after that, i've had no problem accessing the printer. Good luck all!

Michael Kim
IT
Pools.com Above Ground Pools
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top