Cgacutil CF 2.0


G

Guest

Hi,

Is a compiled compact framework (CF) 2.0 assembly (strongly named) can be
installled as GAC using .gac file method? I have created a strongly named
assembly (test.dll) and .gac file, and copied them to Windows directory of
device. The device has CF 2.0 installed. The content of the .gac file is

\Windows\test.dll

I have another application in Program Files folder of the device which
references the test.dll. However, the test.dll failed to get installed into
GAC. I tried this in Mobile 5.0 emulator, it failed too.

Thinking that it might be due to the errors in code, I have created similar
project but compiled for CF 1.0 and it works. The dll got installed into GAC
in the device.

To reconfirm that there is nothing wrong with the CF 2.0 dll, I tried to
install the dll manually using Pocket CMD by calling cgacutil.exe and it
succesffuly installed the dll as GAC in the device.

Is there anything I have missed out or installation of GAC via .gac file is
disabled for CF 2.0 ?

Thanks.
 
Ad

Advertisements

I

Ilya Tumanov [MS]

Please make sure your assembly is indeed signed. You can do so by using the
following command:

sn -vf assembly_name

Properly signed assembly should not show something like this: assembly_name
is a delay-signed or test-signed assembly
If it does, your assembly is not signed.

Best regards,

Ilya

This posting is provided "AS IS" with no warranties, and confers no rights.

*** Want to find answers instantly? Here's how... ***

1. Go to
http://groups-beta.google.com/group/microsoft.public.dotnet.framework.compactframework?hl=en
2. Type your question in the text box near "Search this group" button.
3. Hit "Search this group" button.
4. Read answer(s).
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top