CEAppMgr "Cannot copy the file"


J

JW

Dear NG,

CEAppMgr is giving me the following error when it trys to deploy my PPC
application:
"Cannot copy the file. Make sure the mobile device is connected, that
the mobile device has space available and is not write protected, and
that all setup programs on the device have been completed."

While I would love to know the solution to this problem, I would even
settle for some advice on what to try next.

Thanks,

James.

Details
=======

If I copy the CAB file manually to the device using Explorer and
ActiveSync the application deploys as expected and without issue - both
in the emulator and on two different physical devices (iPAQ HX 4700 and
iMATE Jam smartphone).

The call to CEAppMgr comes from an NSIS installer (Nullsoft Scriptable
Install System - I highly recommend it!), but I get the same error if I
manually call to CEAppMgr from the command line ("C:\Program
Files\Microsoft ActiveSync\CEAPPMGR.EXE" "C:\Program Files\Microsoft
ActiveSync\Triage Tool 2\TriageTool2.ini")

Per previous advice from this group I have turned on error reporting in
the registry (ReportErrors = 1). From the dialogs that this setting
generates CEAppMgr appears to find my INI and CAB file, and does not
report any problems with the INI file contents.

My SmartDevice project was originally built using Visual Studio .NET
2003 where everything worked perfectly. Since then it has been rebuilt
(from scratch by importing source files) as a Device Application (1.0)
project under Visual Studio 2005.

The target platform is PPC 2003 SE, CE 4.21, ARMV4 cpu. I notice that
the current project settings target ANY CPU, and so I have tried
generating an ARMV4 specific cab by manually calling cabwiz with the
/cpu switch.

To test the CAB file I have rebuilt it manually using current (Visual
Studio 2005, 4.0.4332.0) version and previous (VS 2003, 3.7.0.3083)
version of cabwiz.

I have tried using an earlier version of ActiveSync (3.7.1) instead of
the current (4.2) version.

INI File
=======
[CEAppManager]
Version = 1.0
Component = TT2

[TT2]
Description = Triage Tool 2
CabFiles = TriageTool2.CAB

CabWiz.log
==========
Warning: Section [DefaultInstall] key "AddReg" - there are no section
entries to process
Warning: Section [DefaultInstall] key "AddReg" - there are no section
entries to process
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top