Can't detect wireless networks; HP Wireless Asst. doesn't acknowle



Hi all. I'm on a Compaq Presario v3231AU running Windows Vista Business SP1.
Apologies, this is quite long but I want to get it right, and I need help! My
integrated wireless is screwed up somehow, and it's really puzzling me. It
didn’t work yesterday, then worked briefly today - just as I had typed out a
long explanation to post here - and now it doesn't again.

I hadn't used wifi in about a month, and back then it worked like a song.
(This is post SP1, so that can’t be it.) Yesterday, I was at my local pub,
which has free wifi, and my computer couldn't find the network. My flatmate
could connect on his Macbook. So there was a network with a strong signal.

The wireless switch is set to on. The light is blue (on). However, when I
boot up the computer, the little white box that briefly appears to say
"Bluetooth: On" and "WLAN: On" only said "Bluetooth: On" on it - there wasn't
a mention of WLAN (so it's not like it's saying WLAN is disabled). Bluetooth
works fine.

When I went to the Network & Sharing Centre, I did a "diagnose why you can't
find any networks" and it said my wireless adapter was not
installed/configured. I googled this, and got some answers - most of which
were too technical or not exactly related to my problem. I did try some of
the answers, noticed in my Device Manager that the MS 6to4 and ISATAP things
had yellow exclamation mark signs, tried to update but it said I had the
latest versions and this made no difference.

I opened HP Wireless Assistant, and WLAN didn’t even appear there – not a
mention of it, like it doesn’t exist. Bluetooth was there, and it was on. HP
Wireless Assistant was set to show the icon in the notification area, and it

I finally gave up yesterday, but I did install a Broadcom driver from HP's
site, probably an old one, which overwrote the one I had already installed.

So this morning, I took my laptop to work with me and was typing out a post
for this forum when I booted up to get the correct wording on the messages I
was getting. All of a sudden, in the little white box, it said "Bluetooth:
Configured" and "WLAN: Configured", followed shortly by "Bluetooth: On" and
"WLAN: On". Ah ha! Magically it worked!

Then, it said it was installing a Broadcom Wireless 802.11 (or whatever)
driver, then said that was successful. The HP Wireless Assistant icon was not
in the notification area, although it was supposed to be. When I opened
Wireless Asst., there were both WLAN and Bluetooth, both set to on.

I took it to a nearby cafe and was successful in connecting to their free

BUT THEN - I get home tonight, boot up the computer, and it's right back to
where it was yesterday - no mention of WLAN in the little white box or the HP
Wireless Assistant. The Asst. icon is back in the notification are (I mention
this because it's about the only difference I notice.) Same result if I
diagnose, and my flatmate can see one or two networks around our house.

The only thing I did between yesterday and this morning was take it home
from the pub, charge it overnight, and take it to work this morning. Other
than that, I plugged into a LAN cable while I was at work (after I tested the
wifi at the cafe) so I could update iTunes and stuff. That worked fine, BTW
(it's my personal computer, not the company's, so I can't exactly ask IT to

Does ANYONE have any idea what is up? Or, more important, how to fix it? I’d
really appreciate any help.



I have the same problem.
Exactly the same!

I've noticed that nobody replied on your Question on the Vista forum.
That sucks! I wished that somebody had replied with the solution so people
like me could've gotten helped too...

I hope you got it fixed by now.
I don't know much about forums. If you've found a solution to that
disturbing thing, can you please send me an e-mail, cuz i don't know how i
got here and i don't think i'll end up in here again.

Anyway, i thank you regardlessly.
It's enough to know that somebody else is having the same problem and that
it's a common thing.
I thought i was losing my mind :S
"It's ON, afterwards it's OFF", "I'm at work it's OFF, i come home and it's
ON" :S koekoek :)

Thanks again!


Yep, i now know sure that i'm not alone :)
You explained my problem quite right.
The balloon appearce. It says "bluetooth:blush:n" but no "Wlan:*status*" :S
I don't want to send it back to HP if it's a common, simple to fix problem...

So guys, plzzzz help us! :(

Take care


I know for sure it's not a modem or router problem.
The problem is in my laptop, it won't recognize any wireless networks...

I'm gonna try to re-install or update my driver, but how do i do that?
(sorry if it sound stupid, but i'm no CPU expert)

Thanks though


:D I also have a tx1000 :)
It only looks good... THAT'S ALL! :S

I'm tired of looking too... :(
I also downloaded the driver-update files at USELESS! :)

PS: I'm smiling out of misery :°0
What else can you do in a situation like this? :S

Take care, friend!

And to all the guys that wasted their times on us... Thanks and sorry.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question