Cannot delete domain in an existing forest


S

SM

I have the following setup:
1 Root Domain forest: rootdomain
1 Domain tree in rootdomain: domain1
(all Windows Server 2003 SP1)

I installed a domain controller in order to have domain2 as an
additional Domain tree in rootdomain forest. The installation went
fine, in AD Domains and Trusts the new Domain name appeared. By default
only a trust between rootdomain and domain2 was established. In AD Site
and Services the domain controller server name appeared as well. But
when I run dcdiag /test:DNS on the new domain controller there where
some problems. Not all DNS entries have been pushed into DNS.I demoted
the new domain controller without any problems. The domain controller
server name disappeared from AD Site and Services. The default trust
disappeared as well. I deleted the DNS entries (CNAME ect.) in DNS too.
So far so good. I run DCPROMO again. When I entered the DNS domain
name, I go the error:

Active Directory Installation Wizard
The name XXX is already in use on this network. Type a name that is not
in use.

This means I am not able to implement a domain controller for this DNS
domain name again. I went to AD Domains and Trusts and I still can see
domain2.

I followed the procedures: (always logged on as Enterprise Admin and on
the root domain controller which holds the 5 operations master roles)

How To Remove Orphaned Domains from Active Directory
http://support.microsoft.com/?kbid=230306 (NTDSUTIL using metadata
cleanup)
and I get the error while executing the command remove selected domain
under NTDSUTIL:
"DsRemoveDsDomainW error 0x2162 The requested domain could not be
deleted because there exist domain controllers that still host this
domain."

How to remove data in Active Directory after an unsuccessful domain
controller demotion
http://support.microsoft.com/default.aspx?scid=kb;en-us;216498
and under list servers in sites for domain2 there are only those domain
controller listed which are needed for rootdomain and domain1.

There are no server entries for domain2 on any location in active
directory.

Using ADSI Edit under CN=Partitions,CN=Configuration,DC=domain2 there
is the entry CN=domain2 which I tried to delete.
But I got the error message "The requested domain could not be
deleted because there exist domain controllers that still host this
domain." (same error message as above)
There are no other object related to domain2 in ADSI edit, neither in
Lost and found configuration, nor in any trust domain entry in
CN=System, and no related entries in
CN=Servers,CN=Default-First-Site-name,CN=Sites,DC=domain2.

On the demoted Domain controller server for domain2 I found in the
Directory Service Event log the following entry:

************************************************************************************************************
During the cleanup operation of a failed Active Directory installation,
the following object could not be deleted from the remote domain
controller.

Object:
DC=domain2,DC=com
Remote domain controller:
dcr03.rootdomain.local

User Action
Delete this object manually.

Additional Data
Error value:
The requested domain could not be deleted because there exist domain
controllers that still host this domain. 8546
************************************************************************************************************

As you read the last line of the event it is the same error as in
NTDSUTIL and when I tried to delete domain2 from CN=partitions in ADSI
edit.

Apart from all postings in the newsgroups they discuss child domain
issues. But this is a domain controller for a domain tree in an
existing domain forest. I was not able to find a similar problem.

Can anybody help me in this issue, because I need this domain with this
particular domain DNS name quite urgent?

Thanks for your help in advance

SM
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top