Cannot access files on network



I cannot access files on the computers on my home network. Here is the

3 computers
desktop (A) with XP
desktop (B) with XP
laptop with Vista

Linksys router with the computers connected with an ethernet cable.

All 3 computers can access internet (cable)

"A" can see other 2 computers, laptop can see other 2 computers, "B" can
see only "A".

Folders with sharing enabled show up on all the computers, but files
within the folders cannot be accessed. An error screen states the "files
cannot be accessed, etc -- possibly don't have permission, etc."

There is only one user on each computer, the administrator.

Each computer has a different name -- the workgroup name is the same for all

Hope somebody has some ideas -- thanks for your help.

Jack \(MVP-Networking\).

Make sure that the Software Firewall on each computer allows free local
traffic. If you use 3rd party Firewall On, Vista/XP Native Firewall should
be Off, and the active Firewall has to adjusted to your Network IP numbers
on what is some time called the Trusted Zone (consult your 3rd Party
Firewall instructions.
General example,
Vista File and Printer Sharing-
Windows XP File Sharing -;en-us;304040
Printer Sharing XP -
Windows Native Firewall setting for Sharing XP -
Windows XP patch for Sharing with Vista -
Jack (MVP-Networking).


For Vista PC, you have to turn off Password Protected Sharing in the
Network and Sharing Center

Good Luck

Mick Murphy

A bit of info re networking XP and Vista:

Have a read of the above link re Vista File and Printer Sharing.

Permissions/Share info is there as well.

If using Norton, McAfee, Trend Micro I.S., make sure file and printer
sharing is enabled in THEIR firewall (or LAN allowed, depending on how their
Exceptions are worded in their Firewall)

1st thing to do is make sure that the Workgroup Name of ALL the computers is
the SAME.

In Vista Network and Sharing:

Network Discovery: ON (So it can see the other computers)

Network set to Private (Public is for hotspots, airports, etc)

File Sharing: ON

Public Folder Sharing: ON (Vista’s Public Folder is the same as XP’s Shared

Password Protected: OFF (unless you want to set up identical usernames and
passwords on ALL computers in your Network) If you have it ON, and no
identical usernames/passwords, you will be asked for a username and password
when you try to access a Vista computer from an XP computer, or a Vista

Also, run the XP’s Home or Small Office Network File and Printer Sharing
Wizard, even if you had an XP Network set up prior to adding a Vista computer
to it(redoing the Wizard seems to work for XP machines!).

In “My Network Placesâ€: “Set up a Home or Small Office Networkâ€
OR under Accessories > Communications > Network Setup Wizard > Allow File
and Printer Sharing.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question