Can not make local printer available in a remote desktop session


M

Michael Vestel

This is updated with some more info

I’d like to make my local printer available in a remote desktop session.

I’ve followed these instructions
To make your local printer available in a session
1. In the Remote Desktop Connection window, click Options.
2. On the Local Resources tab, under Local devices, click Printers.
3. Click Connect.
Notes Depending on the policies of your network, local printer mapping might
be disabled for some or all remote connections. However, you can print to
network printers.

But I still only see my PDF printer and image write available in the remote
session.

To be clear, I’m remote desktop connected to a computer and want to be able
to print locally.

According the note: “Depending on the policies of your network, local
printer mapping might be disabled for some or all remote connections.â€

So I want to figure out why its not working so I can ask my administrators
to make changes to let me do this. Please let me know how to trouble shoot
this. What are the first things to check to see where its hanging up.

I run Windows XP

The printer is hp LaserJet 1320 PS.

Printer is installed on the Printer port (LPT1), NOT USB. Local Devices and
Resources that are brought to the session are:
Printers, smart cards, serial ports and all the drives and the clipboard,
everything.

I installed the printer onto both computers and tested successfully. So
both drivers are working when its hooked up to the computer.

I installed it on LPT1 on both.
 
Ad

Advertisements

S

SteveH

I think you need to be an administrator to set up printer options/permissions.

Steve
 
M

Michael Vestel

As i mentioned, i want to know waht to change and have my administrator do
this, though i have admin rights on the local computer (home)
 
S

SteveH

Hello

Do you normally have rights to print from the same networked printer you are
hoping to print from?

For instance, if you are at work and can normally print from this printer;
now you are at home and wish to print from the same printer so that when you
go to work in the morning the print job is waiting for you?

If so, it might be that there is a 'permissions' issue. Because you can
print from printer A at work does not mean you can print from printer A at
home - you might be logged onto a different domain. The administrator will
need to grant you the same permissions remotely as you have at work and he
will be able to do that in an Active Directory environment.

This might help:

http://support.microsoft.com/kb/312135/en-us

Steve
 
M

Michael Vestel

Sorry, but I think you have it backwards. The desire is complicated, and I
think confused...Here is a clearer description I hope:

Home computer has Laserjet1320 attached. I’m sitting home, logged into Work
computer via remote desktop.

I want to print a document I’m looking at that resides on the work computer
I’ve accessed via remote desktop from home computer. I want to print it to my
laserjet connected to my home computer so I can pick it up off the printer
I’m sitting at.

I have no problem printing to printers connected to my work computer and
picking it up later, but that is not my goal here.

How do I control the permissions to let me do this. I’ve done the things
listed previously, like hooked the printer up to both computers and locally
printed to be sure the drivers are available and working on both machines.
I’ve made them available via the remote desktop dialog that says to let me
have access to the printers. (E.g. under local resources tab in the remote
desktop connection, I’ve clicked checkbox next to printers in the Local
devices and resources section)
 
S

SteveH

I know you say you have 'hooked' everything up, but was there an option in
Remote Desktop (when you were setting it up) to map either/both the work
printer and/or its drivers to your home computer?
 
Ad

Advertisements

M

Michael Vestel

No there was no such option i saw. there was a "sharing" option, which i gave
it a share name.
 
S

SteveH

Hello

My setup is a bit different here because I only remote on to check servers
have been backed up, but the principle should be the same.

When you first go to Start |Accessoties | remote desktop, you put in your
username and password.

You might then have been given the choice (checkboxes) of printers and disk
drives.

The best and simplest way of doing what you are trying to do it to check
ONLY disk drives - not printers. Press oK and go to your work PC. Then, copy
the files on your work computer to your home computer - map them to your home
computer.

Log off the remote connection. Now, on your own home computer you should see
your work files and should now be able to print them from your own home
printer.

Steve
 
Ad

Advertisements

R

Rich/rerat

Michael Vestel,
Have you considered that in the scenerio you described/desire, that your
work or home computer, or both cannot act as both the host & client in the
same Remote Desktop session. Or the model of your Home printer, may not work
in this type of Network session. The printer is hp LaserJet 1320, as you
stated, not a hp LaserJet 1320(N).

You have said that you have gotten this to work:
1. Home PC (client)=> Work PC (Host)=> Work Printer (Host Printer).
2. WorkPC (client)=> Home PC (Host)=> Home Printer (Host Printer).

What appears you are trying to do is:
Home PC (client)=> Work PC (Host)=>
WorkPC (client)=> Home PC (Host)=> Home Printer (Host Printer).

Have you tried:
2ND Home PC/Laptop (client)=> Work PC (Host)=>
WorkPC (client)=> 1ST Home PC (Host)=> Home Printer (attached to PC1).

Or hook your Printer to a Print Server device, this will create a different
IP address for your printer, that your Work PC can print to? Instead of
Looping back through your Home PC.
--
Add MS to your News Reader: news://msnews.microsoft.com
Rich/rerat (RRR News) <message rule>
<<Previous Text Snipped to Save Bandwidth When Appropriate>>


No there was no such option i saw. there was a "sharing" option, which i
gave
it a share name.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top