Call to web service via Mobile Device with WWAN fails when passing more than 1K size parameter value



I have a .net mobile application that makes a call to web service to
read/write data from device's SQL CE to SQL2K database. When I call
the web service methods with passing small strings, integers as
parameters and receive dataset back it is not a problem. But when I
pass Dataset as a parameter to a method (even if the dataset is empty)
OR strings of size 1K or larger the call fails with following error
message "Could not locate resource assembly".

I looked up for this error message in Microsoft groups; I found some
information about it. As per the recommendation I also deployed the
application via Visual Studio .net which also deployed the required
System.SR.dll assembly file. But I still get the same error message.

Although the same function call works when used 802.11b/g wireless
network OR Ethernet. The problem seems to occur only when using
GPRS/WWAN network. The network team has monitored the traffic from the
device to the server and confirmed that there is no data/packet loss.

Is anyone aware of this issue? Any workaround/fix for this?

FYI: I am using Pocket PC - Windows CE 4.0 on mobile device
(manufactured by Intermec). The application is developed in VB.Net with
..Net framework 1.1


I transform dataset to XML the send as string parameter to ws or Socket
listener... try


Thanks for your reply.

But I tried that also. I found further problem that if I pass a string
of 1K or larger, I get the same error.

If you have any further recommendation, please let me know.

Ani Kinare

Ilya Tumanov [MS]

There's no 1K (or any other size) limit. That's most likely a GPRS network

Please install to see the error message instead of "Could not
locate resource assembly".

Best regards,


This posting is provided "AS IS" with no warranties, and confers no rights.

*** Want to find answers instantly? Here's how... ***

1. Go to
2. Type your question in the text box near "Search this group" button.
3. Hit "Search this group" button.
4. Read answer(s).

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question