bizzare problem with ftp


S

Sergei Shelukhin

Hi. I have weird problems connecting to ftp servers. This includes both ftp
servers in my LAN, internet based ftp servers and Linux box I have connected
to this one via crossover.
I tried using IE, Mozilla, FTP Commander, Total Commander, and Absolute Perl
ftp autoupload - same things happen.
Connection for directory list cannot open, log is like this (this one's from
FTP Commander):

Connecting to 212.5.89.139
< 220 Ok
USER anonymous
< 331 Password required for anonymous.
PASS ****
< 230 User anonymous logged in.
< 257 "/" is current directory.
TYPE A < 200 Type set to A.
PORT 213,247,183,155,4,45 < 200 Port command successful.
LIST
< 425 Cannot open data connection.
Error 425 Cannot open data connection.

Before error, there's a pause.

I have Sygate firewall installed, but it doesn't seem to be it cause even if
I disable its service, disable the autostart and restart ftp still doesn't
work.

Other incoming connections, like DCC on IRC, seem to be working normally.

What's can problem be? Btw, OS is Windows 2000 sp4.
 
Ad

Advertisements

A

Alder

Not so bizarre, Sergei.

This is the normal behaviour of FTP when it is set to Active mode and
asked to cross a firewall that blocks the data channel. Try setting
your FTP clients to use Passive mode.

Terry
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top