Alt+Ctrl Characters

  • Thread starter Rodolphe Kreutzer
  • Start date

Rodolphe Kreutzer


I am having a lot of trouble typing special characters in Word. By special
characters, I mean the ones accessed by pressing Alt+Ctrl. According to my
keyboard layout, pressing Alt+Ctrl+"," should produce "<". This works in all
Windows editors, but does nothing in Microsoft Word. Pressing Alt+Ctrl+"."
should produce ">". This works in all Windows editors, but produces "…" in
Microsoft Word. It looks like Microsoft Word remaps most Alt+Ctrl keys, and
such keys either don't work or produce undesirable results. Can I force
Microsoft Word to respect my keyboard layout ?

I am using Vista and Word 2007.

Tony Jollans

You can certainly make Word respect your keyboard layout, but it sounds like
you have a very unusual layout, and I'd be interested to know how you set it
up, and what Windows editors you are using.

Alt+Ctrl+comma doesn't normally produce anything anywhere, but Shift+comma
will produce "<". Similarly Alt+Ctrl+period doesn't normally produce
anything, except in Word where it produces an ellipsis, as you report, but
Shift+period will produce ">". More generally Alt+Ctrl as a modifier
produces some special characters, depending on keyboard layout, is used as a
Windows key modifier for shortcuts, and is also overridden by some default
Word shortcuts, but can be overridden by you.

You can customize your keyboard in Word to produce almost anything in
response to almost any key combination, although some settings are harder to
do than others. For basic customization go to Tools > Customize > Keyboard
(in 2007: Office Button > Word Options > Customize tab > Keyboard)

Rodolphe Kreutzer

Thank you for your answer. It solved my problem.

By "Windows editors", I meant any field for entering text. Like the path
field in the Start > Run... window. Or like Notepad. All Alt+Ctrl
combinations work there, but only some of them worked in Microsoft Word.

I am using a French keyboard layout, shipped with Vista. The key combination
for ">" is trully Alt+Ctrl+"." while Shift+"." is reserved for another

I went to Word Options > Customize tab > Keyboard, and deleted the
interfering shortcuts. After I restarted Microsoft Word (the restart was
important !), the key combinations worked as they should. Thanks again.

Tony Jollans

With a bit of experimentation, I found the French Canadian Multilingual
Keyboard which has AltGr+period set to produce ">", and this works in Word
as well. However the (left)Alt+Ctrl+period produces the ellipsis.

In many cases the two modifiers, AltGr and Alt+Ctrl, are equivalent, but it
is not guaranteed, and this is one case where they are different. Could this
explain what you are seeing?

Rodolphe Kreutzer

Being right-handed, I use modifier keys on the left side. Also, there is no
"AltGr" label on my keyboard, even though my right Alt acts as AltGr.

In any case, the real explanation is that Microsoft Word has monopolized
Ctrl+Alt+"," and similar combinations, as shortcuts to its own functions.
These shortcuts are interfering with international layouts. I found a good
warning against this on an MSDN blog. Maybe Microsoft Word designers should
read it ! :

"Why Ctrl+Alt shouldn't be used as a shortcut modifier

You may have noticed that Windows doesn't use Ctrl+Alt as a keyboard
shortcut anywhere. (Or at least it shouldn't.) If a chorded modifier is
needed, it's usually Ctrl+Shift.

That's because Ctrl+Alt has special meaning on many keyboards. The
combination Ctrl+Alt is also known as AltGr, and it acts as an alternate
shift key. For example, consider the German keyboard layout", etc.

Tony Jollans

That web page is not entirely correct to say that Windows doesn't use
Ctrl+Alt as a modifier. There may not be any predefined shortcuts that use
it but if you set a shortcut key within Windows yourself (right-click a
shortcut on the desktop, say, choose Properties, put your cursor in the
Shortcut key box, and press the key you want as a shortcut) Windows will
define the shortcut as Ctrl+Alt+the key you choose - and you must use
Ctrl+Alt to invoke it - and it will override application settings. This is
part of the reason why Ctrl+Alt should be used with caution in applications.

That said, Word is very flexible in what you can do with it in this regard,
even if some of its defaults do cause problems in some environments - and
some international keyboards do make extensive use of AltGr as a modifier
(off the top of my head I think my UK keyboard has just seven such keys,
none of which are interefered with by Word).

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question