Ajax on .NET 2.0


P

Peter

I am trying to add the script manager to a web page ASP.NET 2.0


I am getting the following error when I try to run the website

Microsoft JScript runtime error: 'Sys' is undefined

Sys.WebForms.PageRequestManager._initialize('ScriptManager1',
document.getElementById('form1'));

How can I fix this problem?

Here's the web page

<%@ Page Language="C#" AutoEventWireup="true" CodeFile="Default.aspx.cs"
Inherits="_Default" %>

<%@ Register Assembly="System.Web.Extensions, Version=1.0.61025.0,
Culture=neutral, PublicKeyToken=31bf3856ad364e35"
Namespace="System.Web.UI" TagPrefix="asp" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
<title>Untitled Page</title>
</head>
<body>
<form id="form1" runat="server">
<asp:ScriptManager ID="ScriptManager1" runat="server">
</asp:ScriptManager>
<div>
</div>
</form>
</body>
</html>

Here's the web.config file

<?xml version="1.0"?>
<!--
Note: As an alternative to hand editing this file you can use the
web admin tool to configure settings for your application. Use
the Website->Asp.Net Configuration option in Visual Studio.
A full list of settings and comments can be found in
machine.config.comments usually located in
\Windows\Microsoft.Net\Framework\v2.x\Config
-->
<configuration>
<configSections>
<sectionGroup name="microsoft.web.preview"
type="Microsoft.Web.Preview.Configuration.PreviewSectionGroup,
Microsoft.Web.Preview">
<section name="search"
type="Microsoft.Web.Preview.Configuration.SearchSection,
Microsoft.Web.Preview" requirePermission="false"
allowDefinition="MachineToApplication"/>
<section name="searchSiteMap"
type="Microsoft.Web.Preview.Configuration.SearchSiteMapSection,
Microsoft.Web.Preview" requirePermission="false"
allowDefinition="MachineToApplication"/>
<section name="diagnostics"
type="Microsoft.Web.Preview.Configuration.DiagnosticsSection,
Microsoft.Web.Preview" requirePermission="false"
allowDefinition="MachineToApplication"/>
</sectionGroup>
</configSections>
<microsoft.web.preview>
<!--
<search enabled="true">
<providers>
<add name="WindowsLiveSearchProvider"
type="Microsoft.Web.Preview.Search.WindowsLiveSearchProvider,
Microsoft.Web.Preview"
appID="xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
siteDomainName="xxxxxx.xxxx.xxx" />
</providers>
</search>
-->
<!--
<searchSiteMap enabled="true">
<providers>
<add name="Navigation"
type="Microsoft.Web.Preview.Search.AspNetSiteMapSearchSiteMapProvider,
Microsoft.Web.Preview"/>
</providers>
</searchSiteMap>
-->
<!--
<diagnostics enabled="true"/>
-->
</microsoft.web.preview>
<appSettings/>
<connectionStrings/>
<system.web>
<!--
Set compilation debug="true" to insert debugging
symbols into the compiled page. Because this
affects performance, set this value to true only
during development.
-->
<compilation debug="true">
<assemblies>
<add assembly="Microsoft.Web.Preview, Version=1.3.61025.0,
Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
<add assembly="System.Web.Extensions, Version=1.0.61025.0,
Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></assemblies>
<buildProviders>
<add extension="*.asbx"
type="Microsoft.Web.Preview.Services.BridgeBuildProvider"/>
</buildProviders>
</compilation>
<pages>
<controls>
<add tagPrefix="asp" namespace="Microsoft.Web.Preview.UI"
assembly="Microsoft.Web.Preview"/>
<add tagPrefix="asp" namespace="Microsoft.Web.Preview.UI.Controls"
assembly="Microsoft.Web.Preview"/>
<add tagPrefix="asp" namespace="Microsoft.Web.Preview.Search"
assembly="Microsoft.Web.Preview"/>
<add tagPrefix="asp" namespace="Microsoft.Web.Preview.Diagnostics"
assembly="Microsoft.Web.Preview"/>
</controls>
</pages>
<httpHandlers>
<add verb="GET,HEAD,POST" path="*.asbx"
type="System.Web.Script.Services.ScriptHandlerFactory,
System.Web.Extensions, Version=3.5.0.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" validate="false"/>
<add verb="GET" path="SearchSiteMaps.axd"
type="Microsoft.Web.Preview.Search.SearchSiteMapHandler" validate="true"/>
<add verb="*" path="Diagnostics.axd"
type="Microsoft.Web.Preview.Diagnostics.DiagnosticsHandler"
validate="true"/>
</httpHandlers>
</system.web>
<system.codedom>
<compilers>
<compiler language="c#;cs;csharp" extension=".cs"
type="Microsoft.CSharp.CSharpCodeProvider, System, Version=2.0.0.0,
Culture=neutral, PublicKeyToken=b77a5c561934e089">
</compiler>
<compiler language="vb;vbs;visualbasic;vbscript" extension=".vb"
compilerOptions="/optioninfer+" type="Microsoft.VisualBasic.VBCodeProvider,
System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
</compiler>
</compilers>
</system.codedom>
<!--
The system.webServer section is required for running ASP.NET AJAX under
Internet
Information Services 7.0. It is not necessary for previous version of
IIS.
-->
<system.webServer>
<handlers>
<add name="ASBXHandler" verb="GET,HEAD,POST" path="*.asbx"
preCondition="integratedMode"
type="System.Web.Script.Services.ScriptHandlerFactory,
System.Web.Extensions, Version=3.5.0.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
<add name="SearchSiteMaps" preCondition="integratedMode" verb="GET"
path="SearchSiteMaps.axd"
type="Microsoft.Web.Preview.Search.SearchSiteMapHandler"/>
<add name="Diagnostics" preCondition="integratedMode" verb="*"
path="Diagnostics.axd"
type="Microsoft.Web.Preview.Diagnostics.DiagnosticsHandler"/>
</handlers>
</system.webServer>
</configuration>
 
Ad

Advertisements

A

Allen Chen [MSFT]

Hi Peter,

Please try to create a new ASP.NET AJAX-Enabled Web Site. Replace your
current web.config file with the web.config of this AJAX-Enabled Web Site
web site. It would work without any problems. (However, from your
description your current web.config needs some other configuration
settings. So please add them to accommodate your needs)

If you still see some exceptions please let me know and paste the exception
description here.

Regards,
Allen Chen
Microsoft Online Support

Delighting our customers is our #1 priority. We welcome your comments and
suggestions about how we can improve the support we provide to you. Please
feel free to let my manager know what you think of the level of service
provided. You can send feedback directly to my manager at:
(e-mail address removed).

==================================================
Get notification to my posts through email? Please refer to
http://msdn.microsoft.com/en-us/subscriptions/aa948868.aspx#notifications.

Note: MSDN Managed Newsgroup support offering is for non-urgent issues
where an initial response from the community or a Microsoft Support
Engineer within 2 business day is acceptable. Please note that each follow
up response may take approximately 2 business days as the support
professional working with you may need further investigation to reach the
most efficient resolution. The offering is not appropriate for situations
that require urgent, real-time or phone-based interactions. Issues of this
nature are best handled working with a dedicated Microsoft Support Engineer
by contacting Microsoft Customer Support Services (CSS) at
http://msdn.microsoft.com/en-us/subscriptions/aa948874.aspx
==================================================
This posting is provided "AS IS" with no warranties, and confers no rights.

--------------------
| From: "Peter" <[email protected]>
| Subject: Ajax on .NET 2.0
| Date: Thu, 13 Nov 2008 12:47:38 -0600
| Lines: 173
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
| X-RFC2646: Format=Flowed; Original
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
| Message-ID: <[email protected]>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: CPE-72-129-145-58.new.res.rr.com 72.129.145.58
| Path: TK2MSFTNGHUB02.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP06.phx.gbl
| Xref: TK2MSFTNGHUB02.phx.gbl
microsoft.public.dotnet.framework.aspnet:79829
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| I am trying to add the script manager to a web page ASP.NET 2.0
|
|
| I am getting the following error when I try to run the website
|
| Microsoft JScript runtime error: 'Sys' is undefined
|
| Sys.WebForms.PageRequestManager._initialize('ScriptManager1',
| document.getElementById('form1'));
|
| How can I fix this problem?
|
| Here's the web page
|
| <%@ Page Language="C#" AutoEventWireup="true" CodeFile="Default.aspx.cs"
| Inherits="_Default" %>
|
| <%@ Register Assembly="System.Web.Extensions, Version=1.0.61025.0,
| Culture=neutral, PublicKeyToken=31bf3856ad364e35"
| Namespace="System.Web.UI" TagPrefix="asp" %>
|
| <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
| "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
| <html xmlns="http://www.w3.org/1999/xhtml">
| <head runat="server">
| <title>Untitled Page</title>
| </head>
| <body>
| <form id="form1" runat="server">
| <asp:ScriptManager ID="ScriptManager1" runat="server">
| </asp:ScriptManager>
| <div>
| </div>
| </form>
| </body>
| </html>
|
| Here's the web.config file
|
| <?xml version="1.0"?>
| <!--
| Note: As an alternative to hand editing this file you can use the
| web admin tool to configure settings for your application. Use
| the Website->Asp.Net Configuration option in Visual Studio.
| A full list of settings and comments can be found in
| machine.config.comments usually located in
| \Windows\Microsoft.Net\Framework\v2.x\Config
| -->
| <configuration>
| <configSections>
| <sectionGroup name="microsoft.web.preview"
| type="Microsoft.Web.Preview.Configuration.PreviewSectionGroup,
| Microsoft.Web.Preview">
| <section name="search"
| type="Microsoft.Web.Preview.Configuration.SearchSection,
| Microsoft.Web.Preview" requirePermission="false"
| allowDefinition="MachineToApplication"/>
| <section name="searchSiteMap"
| type="Microsoft.Web.Preview.Configuration.SearchSiteMapSection,
| Microsoft.Web.Preview" requirePermission="false"
| allowDefinition="MachineToApplication"/>
| <section name="diagnostics"
| type="Microsoft.Web.Preview.Configuration.DiagnosticsSection,
| Microsoft.Web.Preview" requirePermission="false"
| allowDefinition="MachineToApplication"/>
| </sectionGroup>
| </configSections>
| <microsoft.web.preview>
| <!--
| <search enabled="true">
| <providers>
| <add name="WindowsLiveSearchProvider"
| type="Microsoft.Web.Preview.Search.WindowsLiveSearchProvider,
| Microsoft.Web.Preview"
| appID="xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
| siteDomainName="xxxxxx.xxxx.xxx" />
| </providers>
| </search>
| -->
| <!--
| <searchSiteMap enabled="true">
| <providers>
| <add name="Navigation"
| type="Microsoft.Web.Preview.Search.AspNetSiteMapSearchSiteMapProvider,
| Microsoft.Web.Preview"/>
| </providers>
| </searchSiteMap>
| -->
| <!--
| <diagnostics enabled="true"/>
| -->
| </microsoft.web.preview>
| <appSettings/>
| <connectionStrings/>
| <system.web>
| <!--
| Set compilation debug="true" to insert debugging
| symbols into the compiled page. Because this
| affects performance, set this value to true only
| during development.
| -->
| <compilation debug="true">
| <assemblies>
| <add assembly="Microsoft.Web.Preview, Version=1.3.61025.0,
| Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
| <add assembly="System.Web.Extensions, Version=1.0.61025.0,
| Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></assemblies>
| <buildProviders>
| <add extension="*.asbx"
| type="Microsoft.Web.Preview.Services.BridgeBuildProvider"/>
| </buildProviders>
| </compilation>
| <pages>
| <controls>
| <add tagPrefix="asp" namespace="Microsoft.Web.Preview.UI"
| assembly="Microsoft.Web.Preview"/>
| <add tagPrefix="asp" namespace="Microsoft.Web.Preview.UI.Controls"
| assembly="Microsoft.Web.Preview"/>
| <add tagPrefix="asp" namespace="Microsoft.Web.Preview.Search"
| assembly="Microsoft.Web.Preview"/>
| <add tagPrefix="asp" namespace="Microsoft.Web.Preview.Diagnostics"
| assembly="Microsoft.Web.Preview"/>
| </controls>
| </pages>
| <httpHandlers>
| <add verb="GET,HEAD,POST" path="*.asbx"
| type="System.Web.Script.Services.ScriptHandlerFactory,
| System.Web.Extensions, Version=3.5.0.0, Culture=neutral,
| PublicKeyToken=31bf3856ad364e35" validate="false"/>
| <add verb="GET" path="SearchSiteMaps.axd"
| type="Microsoft.Web.Preview.Search.SearchSiteMapHandler" validate="true"/>
| <add verb="*" path="Diagnostics.axd"
| type="Microsoft.Web.Preview.Diagnostics.DiagnosticsHandler"
| validate="true"/>
| </httpHandlers>
| </system.web>
| <system.codedom>
| <compilers>
| <compiler language="c#;cs;csharp" extension=".cs"
| type="Microsoft.CSharp.CSharpCodeProvider, System, Version=2.0.0.0,
| Culture=neutral, PublicKeyToken=b77a5c561934e089">
| </compiler>
| <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb"
| compilerOptions="/optioninfer+"
type="Microsoft.VisualBasic.VBCodeProvider,
| System, Version=2.0.0.0, Culture=neutral,
PublicKeyToken=b77a5c561934e089">
| </compiler>
| </compilers>
| </system.codedom>
| <!--
| The system.webServer section is required for running ASP.NET AJAX under
| Internet
| Information Services 7.0. It is not necessary for previous version of
| IIS.
| -->
| <system.webServer>
| <handlers>
| <add name="ASBXHandler" verb="GET,HEAD,POST" path="*.asbx"
| preCondition="integratedMode"
| type="System.Web.Script.Services.ScriptHandlerFactory,
| System.Web.Extensions, Version=3.5.0.0, Culture=neutral,
| PublicKeyToken=31bf3856ad364e35"/>
| <add name="SearchSiteMaps" preCondition="integratedMode" verb="GET"
| path="SearchSiteMaps.axd"
| type="Microsoft.Web.Preview.Search.SearchSiteMapHandler"/>
| <add name="Diagnostics" preCondition="integratedMode" verb="*"
| path="Diagnostics.axd"
| type="Microsoft.Web.Preview.Diagnostics.DiagnosticsHandler"/>
| </handlers>
| </system.webServer>
| </configuration>
|
|
|
|
 
P

Peter

I've done that, and it works until I change it from .NET 3.5 to .NET 2.0

But I just learned the IIS server will be upgraded to 3.5 so I don't have a
need for .NET 2.0 anymore

Thank You.
 
Ad

Advertisements

A

Allen Chen [MSFT]

Hi Peter,

OK. If you need any other assistance please feel free to ask.

Regards,
Allen Chen
Microsoft Online Support
--------------------
| From: "Peter" <[email protected]>
| References: <[email protected]>
<[email protected]>
| Subject: Re: Ajax on .NET 2.0
| Date: Fri, 14 Nov 2008 07:45:14 -0600
| Lines: 251
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
| X-RFC2646: Format=Flowed; Original
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
| Message-ID: <[email protected]>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: CPE-72-129-145-58.new.res.rr.com 72.129.145.58
| Path: TK2MSFTNGHUB02.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP05.phx.gbl
| Xref: TK2MSFTNGHUB02.phx.gbl
microsoft.public.dotnet.framework.aspnet:79874
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| I've done that, and it works until I change it from .NET 3.5 to .NET 2.0
|
| But I just learned the IIS server will be upgraded to 3.5 so I don't have
a
| need for .NET 2.0 anymore
|
| Thank You.
|
|
|
| | > Hi Peter,
| >
| > Please try to create a new ASP.NET AJAX-Enabled Web Site. Replace your
| > current web.config file with the web.config of this AJAX-Enabled Web
Site
| > web site. It would work without any problems. (However, from your
| > description your current web.config needs some other configuration
| > settings. So please add them to accommodate your needs)
| >
| > If you still see some exceptions please let me know and paste the
| > exception
| > description here.
| >
| > Regards,
| > Allen Chen
| > Microsoft Online Support
| >
| > Delighting our customers is our #1 priority. We welcome your comments
and
| > suggestions about how we can improve the support we provide to you.
Please
| > feel free to let my manager know what you think of the level of service
| > provided. You can send feedback directly to my manager at:
| > (e-mail address removed).
| >
| > ==================================================
| > Get notification to my posts through email? Please refer to
| >
http://msdn.microsoft.com/en-us/subscriptions/aa948868.aspx#notifications.
| >
| > Note: MSDN Managed Newsgroup support offering is for non-urgent issues
| > where an initial response from the community or a Microsoft Support
| > Engineer within 2 business day is acceptable. Please note that each
follow
| > up response may take approximately 2 business days as the support
| > professional working with you may need further investigation to reach
the
| > most efficient resolution. The offering is not appropriate for
situations
| > that require urgent, real-time or phone-based interactions. Issues of
this
| > nature are best handled working with a dedicated Microsoft Support
| > Engineer
| > by contacting Microsoft Customer Support Services (CSS) at
| > http://msdn.microsoft.com/en-us/subscriptions/aa948874.aspx
| > ==================================================
| > This posting is provided "AS IS" with no warranties, and confers no
| > rights.
| >
| > --------------------
| > | From: "Peter" <[email protected]>
| > | Subject: Ajax on .NET 2.0
| > | Date: Thu, 13 Nov 2008 12:47:38 -0600
| > | Lines: 173
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
| > | X-RFC2646: Format=Flowed; Original
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
| > | Message-ID: <[email protected]>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | NNTP-Posting-Host: CPE-72-129-145-58.new.res.rr.com 72.129.145.58
| > | Path: TK2MSFTNGHUB02.phx.gbl!TK2MSFTNGP01.phx.gbl!TK2MSFTNGP06.phx.gbl
| > | Xref: TK2MSFTNGHUB02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:79829
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | I am trying to add the script manager to a web page ASP.NET 2.0
| > |
| > |
| > | I am getting the following error when I try to run the website
| > |
| > | Microsoft JScript runtime error: 'Sys' is undefined
| > |
| > | Sys.WebForms.PageRequestManager._initialize('ScriptManager1',
| > | document.getElementById('form1'));
| > |
| > | How can I fix this problem?
| > |
| > | Here's the web page
| > |
| > | <%@ Page Language="C#" AutoEventWireup="true"
CodeFile="Default.aspx.cs"
| > | Inherits="_Default" %>
| > |
| > | <%@ Register Assembly="System.Web.Extensions, Version=1.0.61025.0,
| > | Culture=neutral, PublicKeyToken=31bf3856ad364e35"
| > | Namespace="System.Web.UI" TagPrefix="asp" %>
| > |
| > | <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
| > | "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
| > | <html xmlns="http://www.w3.org/1999/xhtml">
| > | <head runat="server">
| > | <title>Untitled Page</title>
| > | </head>
| > | <body>
| > | <form id="form1" runat="server">
| > | <asp:ScriptManager ID="ScriptManager1" runat="server">
| > | </asp:ScriptManager>
| > | <div>
| > | </div>
| > | </form>
| > | </body>
| > | </html>
| > |
| > | Here's the web.config file
| > |
| > | <?xml version="1.0"?>
| > | <!--
| > | Note: As an alternative to hand editing this file you can use the
| > | web admin tool to configure settings for your application. Use
| > | the Website->Asp.Net Configuration option in Visual Studio.
| > | A full list of settings and comments can be found in
| > | machine.config.comments usually located in
| > | \Windows\Microsoft.Net\Framework\v2.x\Config
| > | -->
| > | <configuration>
| > | <configSections>
| > | <sectionGroup name="microsoft.web.preview"
| > | type="Microsoft.Web.Preview.Configuration.PreviewSectionGroup,
| > | Microsoft.Web.Preview">
| > | <section name="search"
| > | type="Microsoft.Web.Preview.Configuration.SearchSection,
| > | Microsoft.Web.Preview" requirePermission="false"
| > | allowDefinition="MachineToApplication"/>
| > | <section name="searchSiteMap"
| > | type="Microsoft.Web.Preview.Configuration.SearchSiteMapSection,
| > | Microsoft.Web.Preview" requirePermission="false"
| > | allowDefinition="MachineToApplication"/>
| > | <section name="diagnostics"
| > | type="Microsoft.Web.Preview.Configuration.DiagnosticsSection,
| > | Microsoft.Web.Preview" requirePermission="false"
| > | allowDefinition="MachineToApplication"/>
| > | </sectionGroup>
| > | </configSections>
| > | <microsoft.web.preview>
| > | <!--
| > | <search enabled="true">
| > | <providers>
| > | <add name="WindowsLiveSearchProvider"
| > | type="Microsoft.Web.Preview.Search.WindowsLiveSearchProvider,
| > | Microsoft.Web.Preview"
| > | appID="xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
| > | siteDomainName="xxxxxx.xxxx.xxx" />
| > | </providers>
| > | </search>
| > | -->
| > | <!--
| > | <searchSiteMap enabled="true">
| > | <providers>
| > | <add name="Navigation"
| > | type="Microsoft.Web.Preview.Search.AspNetSiteMapSearchSiteMapProvider,
| > | Microsoft.Web.Preview"/>
| > | </providers>
| > | </searchSiteMap>
| > | -->
| > | <!--
| > | <diagnostics enabled="true"/>
| > | -->
| > | </microsoft.web.preview>
| > | <appSettings/>
| > | <connectionStrings/>
| > | <system.web>
| > | <!--
| > | Set compilation debug="true" to insert debugging
| > | symbols into the compiled page. Because this
| > | affects performance, set this value to true only
| > | during development.
| > | -->
| > | <compilation debug="true">
| > | <assemblies>
| > | <add assembly="Microsoft.Web.Preview, Version=1.3.61025.0,
| > | Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
| > | <add assembly="System.Web.Extensions, Version=1.0.61025.0,
| > | Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></assemblies>
| > | <buildProviders>
| > | <add extension="*.asbx"
| > | type="Microsoft.Web.Preview.Services.BridgeBuildProvider"/>
| > | </buildProviders>
| > | </compilation>
| > | <pages>
| > | <controls>
| > | <add tagPrefix="asp" namespace="Microsoft.Web.Preview.UI"
| > | assembly="Microsoft.Web.Preview"/>
| > | <add tagPrefix="asp" namespace="Microsoft.Web.Preview.UI.Controls"
| > | assembly="Microsoft.Web.Preview"/>
| > | <add tagPrefix="asp" namespace="Microsoft.Web.Preview.Search"
| > | assembly="Microsoft.Web.Preview"/>
| > | <add tagPrefix="asp" namespace="Microsoft.Web.Preview.Diagnostics"
| > | assembly="Microsoft.Web.Preview"/>
| > | </controls>
| > | </pages>
| > | <httpHandlers>
| > | <add verb="GET,HEAD,POST" path="*.asbx"
| > | type="System.Web.Script.Services.ScriptHandlerFactory,
| > | System.Web.Extensions, Version=3.5.0.0, Culture=neutral,
| > | PublicKeyToken=31bf3856ad364e35" validate="false"/>
| > | <add verb="GET" path="SearchSiteMaps.axd"
| > | type="Microsoft.Web.Preview.Search.SearchSiteMapHandler"
| > validate="true"/>
| > | <add verb="*" path="Diagnostics.axd"
| > | type="Microsoft.Web.Preview.Diagnostics.DiagnosticsHandler"
| > | validate="true"/>
| > | </httpHandlers>
| > | </system.web>
| > | <system.codedom>
| > | <compilers>
| > | <compiler language="c#;cs;csharp" extension=".cs"
| > | type="Microsoft.CSharp.CSharpCodeProvider, System, Version=2.0.0.0,
| > | Culture=neutral, PublicKeyToken=b77a5c561934e089">
| > | </compiler>
| > | <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb"
| > | compilerOptions="/optioninfer+"
| > type="Microsoft.VisualBasic.VBCodeProvider,
| > | System, Version=2.0.0.0, Culture=neutral,
| > PublicKeyToken=b77a5c561934e089">
| > | </compiler>
| > | </compilers>
| > | </system.codedom>
| > | <!--
| > | The system.webServer section is required for running ASP.NET AJAX
| > under
| > | Internet
| > | Information Services 7.0. It is not necessary for previous version
of
| > | IIS.
| > | -->
| > | <system.webServer>
| > | <handlers>
| > | <add name="ASBXHandler" verb="GET,HEAD,POST" path="*.asbx"
| > | preCondition="integratedMode"
| > | type="System.Web.Script.Services.ScriptHandlerFactory,
| > | System.Web.Extensions, Version=3.5.0.0, Culture=neutral,
| > | PublicKeyToken=31bf3856ad364e35"/>
| > | <add name="SearchSiteMaps" preCondition="integratedMode" verb="GET"
| > | path="SearchSiteMaps.axd"
| > | type="Microsoft.Web.Preview.Search.SearchSiteMapHandler"/>
| > | <add name="Diagnostics" preCondition="integratedMode" verb="*"
| > | path="Diagnostics.axd"
| > | type="Microsoft.Web.Preview.Diagnostics.DiagnosticsHandler"/>
| > | </handlers>
| > | </system.webServer>
| > | </configuration>
| > |
| > |
| > |
| > |
| >
|
|
|
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top