adprep /forestprep error

  • Thread starter Richard Mueller [MVP]
  • Start date

R

Richard Mueller [MVP]

My test domain has one Windows 2000 Server SP4. I ran:

adprep /forestprep

The adprep.log shows (at the end):
================
Adprep was about to call the following LDAP API. ldap_search_s(). The base
entry to start the search is LDAP API ldap_search_s() finished, return code
is 0x22


Adprep was unable to modify the security descriptor on object Adprep
encountered an LDAP error.

Error code: 0x22. Server extended error code: 0x208f, Server error message:
0000208F: NameErr: DSID-031001A5, problem 2006 (BAD_NAME), data 8350, best
match of:
''
..



Adprep was unable to update forest-wide information.

[Status/Consequence]

Adprep requires access to existing forest-wide information from the schema
master in order to complete this operation.

[User Action]

Check the log file, Adprep.log, in the
C:\WINNT\system32\debug\adprep\logs\20080428200531 directory for more
information.
==========
I cannot find information on the BAD_NAME error, or "unable to modify the
security descriptor on object <nothing>". No Exchange. No schema
modifications have been made. Does anyone have any ideas?
 
Ad

Advertisements

R

Richard Mueller [MVP]

I ran netdiag and found that no gateway was reachable. The TCP/IP config had
default gateway blank. I added the IP address of the computer (Windows 2000
Server) as the default gateway. Now when I re-ran adprep /forestprep it ran
successfully. Issue easily resolved, but the error message didn't help.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top