ActiveX error after upgrading to Vista



We run software called Retail Pro. Recently we installed a Vista machine,
and when this software is run it comes up with an error about files being
unavailable for barcode information. The program runs fine, but we use it to
print lables (that have bar codes on them) and when we attempt to print it
gives the error 'Bar Code ActiveX class not registered! (TBarCode3.ocx or
TBarCode2.ocx)'. I can't find much information about activeX, but I tried
to manually register them and also copy the files locally, but it didn't
change the error. The program and files are on a Windows 2003 server
machine. We've been running this for years on XP with no error, so I have a
feeling it's something new in Vista. Any ideas?

Rick Rogers


Agreed, it is most definitely something about how programs run in Vista.
Unlike XP, programs run within the user environment, not the system
environment. The error probably means that the files being written to (the
ActiveX controls) are in system folders, and this is no longer allowed. Try
running the program with elevated privileges to confirm that (right click
the startup shortcut or executable and use 'run as administrator'). If it
works - and I suspect it will - then the problem needs to be resolved by the
software vendor, as the code needs to be rewritten to be compliant.

Best of Luck,

Rick Rogers, aka "Nutcase" - Microsoft MVP

Windows help -


This has been a problem with various .OCX files written to the System32
folder. As stated, this is no longer allowed by Vista and the vendor needs to
fix the problem. Until then, there are a few workarounds:
Run the program in XP compatibility mode.

Run the program as administrator.

Manually register the files from an elevated CMD prompt.
From the search box, type CMD.
Right-click CMD.exe and Run As Administrator.
regsvr32 c:\windows\system32\filename.ocx

Check the file properties to ensure that during installation User
permissions have not been set to Special.
Search for any other .OCX files and make the permissions match.

Reinstall the software running the Install/Setup file as administrator.
Or, turn of UAC during the installation. NOTE: If the first two methods above
did not work, this one most likely will not work either.

Absolute worst case:
Reinstall the program as administrator.
Reinstall Vista as an upgrade.
(This will adopt all System32 files and correct permissions.)


Well, the actual file is on the file server, so it won't let me change the
compatibility mode. I tried manually registering the files like you
mentioned - It said it loaded, but with errors (still gave me the error in
the program after). The server runs Server 2003, so I'm not sure if
reinstalling it will change. Plus, that's all of the records our business
runs on, and even when backed up I don't like to mess with it too much. :)
I tried contacting the maker of the software to see if there is an update.
Do you think they could re-write the code for it to work, or is this more of
a networking issue? Thanks.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question