Acer Aspire 3680 atheros ar5005g wireless will not connect to mode




I cannot get my Acer Aspire 3680 with an Atheros AR5005g 802.11b/g wireless
adapter to connect to a Siemens SpeedStream 6520 ADSL wireless modem on the
Australian Telstra BigPond ADSL network.

I also had this same problem when the computer was brand new in 2007 and
found a fix via MSN, but I can no longer remember how or where to find the
fix. This recent issue happened when I reloaded XP version 5.1 build
2600.xpsp.050928-1517 : Service Pack 2

Silly thing is that I can see my neighbours wireless networks up and down
the street from within the network neighbourhood! I just cannot see my own

I do have internet connectivity as the ethernet connection works fine and
another Acer Aspire laptop we have also connects wirelessly to the modem

Any ideas of how to fix this issue would be appreciated?



Kelly said:

For these drivers you need to use extract instead of just clicking the
folder. It may seem as though all is well, but it isn't.

Hi Kelly, thanks for the reply.

I had tried extracting the drivers rather than loading, with no luck. I
have also restored to factory default, no luck. I do know a fix is
available, I just can not remember how. Last time, I was able to follow a
thread for kb815485. This time however, I cannot locate the same topic thread
as it was two years ago :unsure:

It must be something to do with backwards compatibility for the router or
something, but I just wouldn't have a clew how to trick it or amend the
router config.



Hi Darrell,

I have just finished an Acer with Atheros. The issue was that - this
particular file would seem to load fine, but didn't work. Only using the
extract measure, which listed the same files worked, thus my reply.

Good luck and keep us posted.

The links below may help you....


All the Best,

Taskbar Repair Tool Plus!!.htm


Hi Kelly,


Now this will sound bizarre, but here are the basics of what I did.

Firstly, using an Ethernet connection I setup the wireless router with SSID
and the network key from the service provider. Then turned the router off
and disconnected cable.

I restored the computer to full factory settings with OEM XP, but I did not
update XP. I also kept the original Atheros ar5005g driver.

Disabled all running items including firewalls etc and manually turned off
the Wireless by the on/off switch for this model Acer.

Disabled WZCSVC Startup Type from My Computer on the Desktop, I right
clicked, then went Computer Management, Service and Applications, Services,
Wireless Zero Configuration, Startup, Disabled, OK.

Whilst disabled, I began to manually setup a new wireless connection via
Wireless Network Setup Wizard. Typed in the SSID, manually assigned the
network key by cut and paste, used WEP instead of WAP, then chose set up a
network manually.

Then I re-booted the system, then went back into Wireless Zero
Configuration, changed Startup Type to Automatic, Apply, then Start, then OK.

Turned on the router, manually turned the wireless connection back on and
there we have it, connection in 10, 9, 8, 7 seconds.

Since then I have updated with SP3 and all is still going OK.

Many, many thanks for the help.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question