Static IP changes to dynamic automatically

Discussion in 'Microsoft Windows 2000 Advanced Server' started by S N, Oct 12, 2009.

  1. S N

    S N Guest

    I have a Windows 2000 server machine running IIS and hosting various
    websites on my intranet.
    All PCs in my network are running on DHCP except this server machine which
    has been allotted a static IP. The DNS server is also on this network.
    However, recently this server is behaving erratically. Its static IP
    automatically changes to automatic IP using DHCP- as a result of which the
    server becomes inaccessible because of unknown IP address.

    Kindly advise on how to ensure that the assigned IP address remains on the
    machine and does not change to automatic IP using DHCP.
     
    S N, Oct 12, 2009
    #1
    1. Advertisements

  2. S N

    Guest

    Hi,

    Normally, if you choose a static IP address, it should remain this
    way.
    Do you have an antivirus installed?

    Giorgos

    --

    NetPros community
    http://netpros.freeforums.org

    On Oct 12, 6:46 pm, "S N" <> wrote:
    > I have a Windows 2000 server machine running IIS and hosting various
    > websites on my intranet.
    > All PCs in my network are running on DHCP except this server machine which
    > has been allotted a static IP. The DNS server is also on this network.
    > However, recently this server is behaving erratically. Its static IP
    > automatically changes to automatic IP using DHCP- as a result of which the
    > server becomes inaccessible because of unknown IP address.
    >
    > Kindly advise on how to ensure that the assigned IP address remains on the
    > machine and does not change to automatic IP using DHCP.
     
    , Oct 12, 2009
    #2
    1. Advertisements

  3. S N <> wrote:
    > I have a Windows 2000 server machine running IIS and hosting various
    > websites on my intranet.
    > All PCs in my network are running on DHCP except this server machine
    > which has been allotted a static IP. The DNS server is also on this
    > network. However, recently this server is behaving erratically. Its
    > static IP automatically changes to automatic IP using DHCP- as a
    > result of which the server becomes inaccessible because of unknown IP
    > address.
    > Kindly advise on how to ensure that the assigned IP address remains
    > on the machine and does not change to automatic IP using DHCP.


    Something is corrupt in the registry.

    Uninstall the NIC but don't reboot
    Go through HKLM\system\currentcontrolset\control\network
    Find and delete all references to this NIC
    Reboot
    Let it redetect/reinstall the NIC

    You should be fine from then on. This has happened to me a few times over
    the years and I never figured out why.
     
    Lanwench [MVP - Exchange], Oct 12, 2009
    #3
  4. "Lanwench [MVP - Exchange]"
    <> wrote in message
    news:...
    >S N <> wrote:
    >> I have a Windows 2000 server machine running IIS and hosting various
    >> websites on my intranet.
    >> All PCs in my network are running on DHCP except this server machine
    >> which has been allotted a static IP. The DNS server is also on this
    >> network. However, recently this server is behaving erratically. Its
    >> static IP automatically changes to automatic IP using DHCP- as a
    >> result of which the server becomes inaccessible because of unknown IP
    >> address.
    >> Kindly advise on how to ensure that the assigned IP address remains
    >> on the machine and does not change to automatic IP using DHCP.

    >
    > Something is corrupt in the registry.
    >
    > Uninstall the NIC but don't reboot
    > Go through HKLM\system\currentcontrolset\control\network
    > Find and delete all references to this NIC
    > Reboot
    > Let it redetect/reinstall the NIC
    >
    > You should be fine from then on. This has happened to me a few times over
    > the years and I never figured out why.
    >
    >
    >



    Just to add and clarify, I found a post in the following link, that the
    poster got Microsoft PSS to assist in a similar issue. The reg entry you
    quoted is correct, but there is one more spot under 'network.' which is
    'config.' Not sure if that makes a difference or not, but

    http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_23453074.html

    "[...] We finally got Microsoft to help and they tracked down the problem.
    They found a corrupted registry entry in our TCP-IP configuration that
    doesn't allow the GUI to successfully change the TCP-IP settings.
    The reg entry is removed, and the computer restarted.
    TCP-IP service finds the reg entry missing, and rebuilds it.
    Voila - The GUI displays properly and will set/reset the TCP-IP setting
    properly.
    Unfortunately, I can't tell you what was the original cause of the corrupted
    reg entry.

    Deleting the following reg entry solved our problem:
    My computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Network\Config"


    --
    Ace

    This posting is provided "AS-IS" with no warranties or guarantees and
    confers no rights.

    Please reply back to the newsgroup or forum for collaboration benefit among
    responding engineers, and to help others benefit from your resolution.

    Ace Fekay, MCT, MCITP Windows 2008, MCTS Exchange 2007, MCSE & MCSA 2003 &
    2000, MCSA Messaging 2003
    Microsoft Certified Trainer

    For urgent issues, please contact Microsoft PSS directly. Please check
    http://support.microsoft.com for regional support phone numbers.
     
    Ace Fekay [MCT], Oct 13, 2009
    #4
  5. S N

    Dave Patrick Guest

    FPN, you can't be sure if and when ControlSet001 would be used again. Always
    should be in CurrentControlSet


    --

    Regards,

    Dave Patrick ....Please no email replies - reply in newsgroup.
    Microsoft Certified Professional
    Microsoft MVP [Windows]
    http://www.microsoft.com/protect


    "Ace Fekay [MCT]" wrote:
    > Just to add and clarify, I found a post in the following link, that the
    > poster got Microsoft PSS to assist in a similar issue. The reg entry you
    > quoted is correct, but there is one more spot under 'network.' which is
    > 'config.' Not sure if that makes a difference or not, but
    >
    > http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_23453074.html
    >
    > "[...] We finally got Microsoft to help and they tracked down the problem.
    > They found a corrupted registry entry in our TCP-IP configuration that
    > doesn't allow the GUI to successfully change the TCP-IP settings.
    > The reg entry is removed, and the computer restarted.
    > TCP-IP service finds the reg entry missing, and rebuilds it.
    > Voila - The GUI displays properly and will set/reset the TCP-IP setting
    > properly.
    > Unfortunately, I can't tell you what was the original cause of the
    > corrupted reg entry.
    >
    > Deleting the following reg entry solved our problem:
    > My
    > computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Network\Config"
    >
    >
    > --
    > Ace
    >
    > This posting is provided "AS-IS" with no warranties or guarantees and
    > confers no rights.
    >
    > Please reply back to the newsgroup or forum for collaboration benefit
    > among responding engineers, and to help others benefit from your
    > resolution.
    >
    > Ace Fekay, MCT, MCITP Windows 2008, MCTS Exchange 2007, MCSE & MCSA 2003 &
    > 2000, MCSA Messaging 2003
    > Microsoft Certified Trainer
    >
    > For urgent issues, please contact Microsoft PSS directly. Please check
    > http://support.microsoft.com for regional support phone numbers.
    >
     
    Dave Patrick, Oct 13, 2009
    #5
  6. "Dave Patrick" <> wrote in message
    news:...

    Good point. And I'm not sure why PSS would have indicated using 001. I
    should have edited that prior to posting. :)

    Thanks!

    Ace

    > FPN, you can't be sure if and when ControlSet001 would be used again.
    > Always should be in CurrentControlSet
    >
    >
    > --
    >
    > Regards,
    >
    > Dave Patrick ....Please no email replies - reply in newsgroup.
    > Microsoft Certified Professional
    > Microsoft MVP [Windows]
    > http://www.microsoft.com/protect
    >
    >
    > "Ace Fekay [MCT]" wrote:
    >> Just to add and clarify, I found a post in the following link, that the
    >> poster got Microsoft PSS to assist in a similar issue. The reg entry you
    >> quoted is correct, but there is one more spot under 'network.' which is
    >> 'config.' Not sure if that makes a difference or not, but
    >>
    >> http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_23453074.html
    >>
    >> "[...] We finally got Microsoft to help and they tracked down the
    >> problem.
    >> They found a corrupted registry entry in our TCP-IP configuration that
    >> doesn't allow the GUI to successfully change the TCP-IP settings.
    >> The reg entry is removed, and the computer restarted.
    >> TCP-IP service finds the reg entry missing, and rebuilds it.
    >> Voila - The GUI displays properly and will set/reset the TCP-IP setting
    >> properly.
    >> Unfortunately, I can't tell you what was the original cause of the
    >> corrupted reg entry.
    >>
    >> Deleting the following reg entry solved our problem:
    >> My
    >> computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Network\Config"
    >>
    >>
    >> --
    >> Ace
    >>
    >> This posting is provided "AS-IS" with no warranties or guarantees and
    >> confers no rights.
    >>
    >> Please reply back to the newsgroup or forum for collaboration benefit
    >> among responding engineers, and to help others benefit from your
    >> resolution.
    >>
    >> Ace Fekay, MCT, MCITP Windows 2008, MCTS Exchange 2007, MCSE & MCSA 2003
    >> & 2000, MCSA Messaging 2003
    >> Microsoft Certified Trainer
    >>
    >> For urgent issues, please contact Microsoft PSS directly. Please check
    >> http://support.microsoft.com for regional support phone numbers.
    >>

    >
     
    Ace Fekay [MCT], Oct 13, 2009
    #6
  7. S N

    Dave Patrick Guest

    No problem.


    --

    Regards,

    Dave Patrick ....Please no email replies - reply in newsgroup.
    Microsoft Certified Professional
    Microsoft MVP [Windows]
    http://www.microsoft.com/protect


    "Ace Fekay [MCT]" wrote:
    > Good point. And I'm not sure why PSS would have indicated using 001. I
    > should have edited that prior to posting. :)
    >
    > Thanks!
    >
    > Ace
     
    Dave Patrick, Oct 13, 2009
    #7
  8. S N

    S N Guest

    This is the problem faced by me.

    "Ace Fekay [MCT]" <> wrote in message
    news:...
    > "Lanwench [MVP - Exchange]"
    > <> wrote in
    > message news:...
    >>S N <> wrote:
    >>> I have a Windows 2000 server machine running IIS and hosting various
    >>> websites on my intranet.
    >>> All PCs in my network are running on DHCP except this server machine
    >>> which has been allotted a static IP. The DNS server is also on this
    >>> network. However, recently this server is behaving erratically. Its
    >>> static IP automatically changes to automatic IP using DHCP- as a
    >>> result of which the server becomes inaccessible because of unknown IP
    >>> address.
    >>> Kindly advise on how to ensure that the assigned IP address remains
    >>> on the machine and does not change to automatic IP using DHCP.

    >>
    >> Something is corrupt in the registry.
    >>
    >> Uninstall the NIC but don't reboot
    >> Go through HKLM\system\currentcontrolset\control\network
    >> Find and delete all references to this NIC
    >> Reboot
    >> Let it redetect/reinstall the NIC
    >>
    >> You should be fine from then on. This has happened to me a few times over
    >> the years and I never figured out why.
    >>
    >>
    >>

    >
    >
    > Just to add and clarify, I found a post in the following link, that the
    > poster got Microsoft PSS to assist in a similar issue. The reg entry you
    > quoted is correct, but there is one more spot under 'network.' which is
    > 'config.' Not sure if that makes a difference or not, but
    >
    > http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_23453074.html
    >
    > "[...] We finally got Microsoft to help and they tracked down the problem.
    > They found a corrupted registry entry in our TCP-IP configuration that
    > doesn't allow the GUI to successfully change the TCP-IP settings.
    > The reg entry is removed, and the computer restarted.
    > TCP-IP service finds the reg entry missing, and rebuilds it.
    > Voila - The GUI displays properly and will set/reset the TCP-IP setting
    > properly.
    > Unfortunately, I can't tell you what was the original cause of the
    > corrupted reg entry.
    >
    > Deleting the following reg entry solved our problem:
    > My
    > computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Network\Config"
    >
    >
    > --
    > Ace
    >
    > This posting is provided "AS-IS" with no warranties or guarantees and
    > confers no rights.
    >
    > Please reply back to the newsgroup or forum for collaboration benefit
    > among responding engineers, and to help others benefit from your
    > resolution.
    >
    > Ace Fekay, MCT, MCITP Windows 2008, MCTS Exchange 2007, MCSE & MCSA 2003 &
    > 2000, MCSA Messaging 2003
    > Microsoft Certified Trainer
    >
    > For urgent issues, please contact Microsoft PSS directly. Please check
    > http://support.microsoft.com for regional support phone numbers.
    >
     
    S N, Oct 13, 2009
    #8
  9. "S N" <> wrote in message
    news:...
    > This is the problem faced by me.


    I understand. Did you follow our suggestions to delete the registry key and
    reboot your machine?

    Ace
     
    Ace Fekay [MCT], Oct 13, 2009
    #9
  10. S N <> wrote:
    > This is the problem faced by me.


    Yes, I know. So try what I suggested. ;-)
     
    Lanwench [MVP - Exchange], Oct 13, 2009
    #10
  11. S N

    S N Guest

    Thanks a lot.
    It worked. Now the IP address stays in the GUI interface also.

    S N

    "Ace Fekay [MCT]" <> wrote in message
    news:%236Qb%...
    > "S N" <> wrote in message
    > news:...
    >> This is the problem faced by me.

    >
    > I understand. Did you follow our suggestions to delete the registry key
    > and reboot your machine?
    >
    > Ace
    >
    >
    >
     
    S N, Oct 14, 2009
    #11
  12. "S N" <> wrote in message
    news:uCtr$...

    You are welcome, and I'm glad to hear it worked!

    Ace


    > Thanks a lot.
    > It worked. Now the IP address stays in the GUI interface also.
    >
    > S N
    >
    > "Ace Fekay [MCT]" <> wrote in message
    > news:%236Qb%...
    >> "S N" <> wrote in message
    >> news:...
    >>> This is the problem faced by me.

    >>
    >> I understand. Did you follow our suggestions to delete the registry key
    >> and reboot your machine?
    >>
    >> Ace
    >>
    >>
    >>

    >
    >
     
    Ace Fekay [MCT], Oct 14, 2009
    #12
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. SOLOTECH

    Changing static IP on server.. what to do?

    SOLOTECH, Jul 17, 2003, in forum: Microsoft Windows 2000 Advanced Server
    Replies:
    0
    Views:
    480
    SOLOTECH
    Jul 17, 2003
  2. Andrew

    NIC not holding static IP

    Andrew, Jul 18, 2003, in forum: Microsoft Windows 2000 Advanced Server
    Replies:
    1
    Views:
    2,039
    Oren Nizri
    Jul 20, 2003
  3. Rex Winn

    Do I need two public static IP's???

    Rex Winn, Aug 11, 2003, in forum: Microsoft Windows 2000 Advanced Server
    Replies:
    1
    Views:
    478
    Colin M. McGroarty
    Aug 11, 2003
  4. Kindler Chase - nCubed

    Windows Server automatically changes date well into the future.

    Kindler Chase - nCubed, Jul 29, 2004, in forum: Microsoft Windows 2000 Advanced Server
    Replies:
    7
    Views:
    833
    Kindler Chase - nCubed
    Aug 1, 2004
  5. MMJII

    Static gateway address changes on reboot

    MMJII, Jan 5, 2007, in forum: Microsoft Windows 2000 Advanced Server
    Replies:
    1
    Views:
    439
    MMJII
    Jan 8, 2007
Loading...

Share This Page