making VLC the default for playing DVDs

Discussion in 'Windows XP Hardware' started by Jo-Anne, Jun 12, 2011.

  1. Jo-Anne

    Jo-Anne Guest

    I recently started playing DVDs on my WinXP laptop. Each time I put a DVD in
    the drive, it opens with PowerDVD. Since I like to use VLC Media Player, I
    close the PowerDVD window, open VLC Media Player, and click on the DVD
    drive. I'm sure there's a way to set VLC as the default DVD player. I'd be
    grateful for instructions on how to do this or even for a link to a website
    that explains it.

    Thank you!

    Jo-Anne
     
    Jo-Anne, Jun 12, 2011
    #1
    1. Advertisements

  2. Jo-Anne

    VanguardLH Guest

    Jo-Anne wrote:

    > I recently started playing DVDs on my WinXP laptop. Each time I put a DVD in
    > the drive, it opens with PowerDVD. Since I like to use VLC Media Player, I
    > close the PowerDVD window, open VLC Media Player, and click on the DVD
    > drive. I'm sure there's a way to set VLC as the default DVD player. I'd be
    > grateful for instructions on how to do this or even for a link to a website
    > that explains it.


    Not a hardware question. This is a software configuration issue or, at
    best, an issue with filetype associations in the operating system.
    VideoLan's forums are over at http://forum.videolan.org/.

    Right-click on the .vob file (or whatever you open to play the movie),
    select Open With, and browse to the VLC program's executable. Make sure
    you enable the Remember option in the browse dialog.

    Or you could set the file associations within VLC Player. Alas, for
    some reason, its designers decided that not all the simple options will
    be present in the advanced options. To set file associations in VLC's
    preferences, use the simple interface for its Preferences dialog. Then
    look under the Interface category of options. Enable the extension for
    whatever is the video file you are trying to open in VLC.
     
    VanguardLH, Jun 12, 2011
    #2
    1. Advertisements

  3. Jo-Anne

    Patok Guest

    Jo-Anne wrote:
    > I recently started playing DVDs on my WinXP laptop. Each time I put a DVD in
    > the drive, it opens with PowerDVD. Since I like to use VLC Media Player, I
    > close the PowerDVD window, open VLC Media Player, and click on the DVD
    > drive. I'm sure there's a way to set VLC as the default DVD player. I'd be
    > grateful for instructions on how to do this or even for a link to a website
    > that explains it.


    From my limited understanding, it seems that it's not possible. For
    some reason, VLC does not register itself as a DVD playing
    application. You can set it to play specific file types, but not devices.

    To see which programs will play DVDs upon insertion, right-click on
    the DVD drive, and in the AutoPlay tab you can see and set them. I
    personally see nothing wrong with the default PowerDVD for that
    purpose, and haven't changed it (but then, I don't usually play DVDs).
    For example, Media Player Classic registers as a DVD playing
    application - see if you'll like it instead.

    --
    You'd be crazy to e-mail me with the crazy. But leave the div alone.
    *
    Whoever bans a book, shall be banished. Whoever burns a book, shall burn.
     
    Patok, Jun 12, 2011
    #3
  4. Jo-Anne

    BillW50 Guest

    In news:it15pt$vrd$,
    Jo-Anne wrote:
    > I recently started playing DVDs on my WinXP laptop. Each time I put a
    > DVD in the drive, it opens with PowerDVD. Since I like to use VLC
    > Media Player, I close the PowerDVD window, open VLC Media Player, and
    > click on the DVD drive. I'm sure there's a way to set VLC as the
    > default DVD player. I'd be grateful for instructions on how to do
    > this or even for a link to a website that explains it.
    >
    > Thank you!
    >
    > Jo-Anne


    I am not 100% positive this will work, but it is worth a shot. There is
    a program called "USB Safely Remove". And one of the things it can do is
    to run a program when it detects a given device. "USB Safely Remove" is
    handy for much more than this too, so it is worth looking into even if
    you can't get this to work for this purpose.

    http://safelyremove.com/

    --
    Bill
    Gateway M465e ('06 era) - OE-QuoteFix v1.19.2
    Centrino Core Duo 1.83G - 2GB - Windows XP SP3
     
    BillW50, Jun 12, 2011
    #4
  5. Jo-Anne

    Jo-Anne Guest

    "VanguardLH" <> wrote in message
    news:it1f0s$drn$...
    > Jo-Anne wrote:
    >
    >> I recently started playing DVDs on my WinXP laptop. Each time I put a DVD
    >> in
    >> the drive, it opens with PowerDVD. Since I like to use VLC Media Player,
    >> I
    >> close the PowerDVD window, open VLC Media Player, and click on the DVD
    >> drive. I'm sure there's a way to set VLC as the default DVD player. I'd
    >> be
    >> grateful for instructions on how to do this or even for a link to a
    >> website
    >> that explains it.

    >
    > Not a hardware question. This is a software configuration issue or, at
    > best, an issue with filetype associations in the operating system.
    > VideoLan's forums are over at http://forum.videolan.org/.
    >
    > Right-click on the .vob file (or whatever you open to play the movie),
    > select Open With, and browse to the VLC program's executable. Make sure
    > you enable the Remember option in the browse dialog.
    >
    > Or you could set the file associations within VLC Player. Alas, for
    > some reason, its designers decided that not all the simple options will
    > be present in the advanced options. To set file associations in VLC's
    > preferences, use the simple interface for its Preferences dialog. Then
    > look under the Interface category of options. Enable the extension for
    > whatever is the video file you are trying to open in VLC.



    Thank you, Vanguard! I did look at the interface categories in VLC, and all
    the options are checked--but still PowerDVD opens the files. I wonder if
    PowerDVD can be uninstalled...

    Jo-Anne
     
    Jo-Anne, Jun 13, 2011
    #5
  6. Jo-Anne

    Jo-Anne Guest

    "Patok" <> wrote in message
    news:it1ndb$ago$...
    > Jo-Anne wrote:
    >> I recently started playing DVDs on my WinXP laptop. Each time I put a DVD
    >> in the drive, it opens with PowerDVD. Since I like to use VLC Media
    >> Player, I close the PowerDVD window, open VLC Media Player, and click on
    >> the DVD drive. I'm sure there's a way to set VLC as the default DVD
    >> player. I'd be grateful for instructions on how to do this or even for a
    >> link to a website that explains it.

    >
    > From my limited understanding, it seems that it's not possible. For some
    > reason, VLC does not register itself as a DVD playing application. You can
    > set it to play specific file types, but not devices.
    >
    > To see which programs will play DVDs upon insertion, right-click on the
    > DVD drive, and in the AutoPlay tab you can see and set them. I personally
    > see nothing wrong with the default PowerDVD for that purpose, and haven't
    > changed it (but then, I don't usually play DVDs). For example, Media
    > Player Classic registers as a DVD playing application - see if you'll like
    > it instead.
    >
    > --
    > You'd be crazy to e-mail me with the crazy. But leave the div alone.
    > *
    > Whoever bans a book, shall be banished. Whoever burns a book, shall burn.



    Thank you, Patok! I've had trouble with PowerDVD from the first time I tried
    playing DVDs. In one case, a DVD that was set up for the United States
    (where I live) wouldn't play until I "changed" the area to the United
    States. In another case, the sound wouldn't play at all. I had no problem
    with the sound on that DVD in VLC.

    Jo-Anne
     
    Jo-Anne, Jun 13, 2011
    #6
  7. Jo-Anne

    Jo-Anne Guest

    "BillW50" <> wrote in message
    news:it2ks1$5hu$...
    > In news:it15pt$vrd$,
    > Jo-Anne wrote:
    >> I recently started playing DVDs on my WinXP laptop. Each time I put a
    >> DVD in the drive, it opens with PowerDVD. Since I like to use VLC
    >> Media Player, I close the PowerDVD window, open VLC Media Player, and
    >> click on the DVD drive. I'm sure there's a way to set VLC as the
    >> default DVD player. I'd be grateful for instructions on how to do
    >> this or even for a link to a website that explains it.
    >>
    >> Thank you!
    >>
    >> Jo-Anne

    >
    > I am not 100% positive this will work, but it is worth a shot. There is a
    > program called "USB Safely Remove". And one of the things it can do is to
    > run a program when it detects a given device. "USB Safely Remove" is handy
    > for much more than this too, so it is worth looking into even if you can't
    > get this to work for this purpose.
    >
    > http://safelyremove.com/
    >
    > --
    > Bill
    > Gateway M465e ('06 era) - OE-QuoteFix v1.19.2
    > Centrino Core Duo 1.83G - 2GB - Windows XP SP3
    >


    Thank you, Bill! I had already bookmarked USB Safely Remove (I think from
    one of your earlier posts). I'll definitely check it out for this
    issue--although I wonder how it reacts if the media in the DVD player is
    simply a data CD/DVD.

    Jo-Anne
     
    Jo-Anne, Jun 13, 2011
    #7
  8. Jo-Anne

    BillW50 Guest

    In news:it5bo8$jet$,
    Jo-Anne wrote:
    > Thank you, Vanguard! I did look at the interface categories in VLC,
    > and all the options are checked--but still PowerDVD opens the files.
    > I wonder if PowerDVD can be uninstalled...
    >
    > Jo-Anne


    All versions of PowerDVD that I know of, can be uninstalled.

    --
    Bill
    Gateway M465e ('06 era) - OE-QuoteFix v1.19.2
    Centrino Core Duo 1.83G - 2GB - Windows XP SP3
     
    BillW50, Jun 13, 2011
    #8
  9. Jo-Anne

    BillW50 Guest

    In news:it5c1p$lii$,
    Jo-Anne wrote:
    > "BillW50" <> wrote in message
    > news:it2ks1$5hu$...
    >> In news:it15pt$vrd$,
    >> Jo-Anne wrote:
    >>> I recently started playing DVDs on my WinXP laptop. Each time I put
    >>> a DVD in the drive, it opens with PowerDVD. Since I like to use VLC
    >>> Media Player, I close the PowerDVD window, open VLC Media Player,
    >>> and click on the DVD drive. I'm sure there's a way to set VLC as the
    >>> default DVD player. I'd be grateful for instructions on how to do
    >>> this or even for a link to a website that explains it.
    >>>
    >>> Thank you!
    >>>
    >>> Jo-Anne

    >>
    >> I am not 100% positive this will work, but it is worth a shot. There
    >> is a program called "USB Safely Remove". And one of the things it
    >> can do is to run a program when it detects a given device. "USB
    >> Safely Remove" is handy for much more than this too, so it is worth
    >> looking into even if you can't get this to work for this purpose.
    >>
    >> http://safelyremove.com/

    >
    > Thank you, Bill! I had already bookmarked USB Safely Remove (I think
    > from one of your earlier posts). I'll definitely check it out for this
    > issue--although I wonder how it reacts if the media in the DVD player
    > is simply a data CD/DVD.
    >
    > Jo-Anne


    Just curious, have you ever tried to change under Explorer (file
    manager) under Tools->Folder Options and select the third tab called
    File Types? Here the third one down is called DVD Video. Select this one
    and press the Advanced button. It should list something like this:

    Play
    Play with PowerDVD (in bold)
    Play with VLC media player

    Select the VLC one. Then press the Set Default button (now this one
    should be in bold). That should now open DVD movies with VLC instead of
    PowerDVD.

    --
    Bill
    Gateway M465e ('06 era) - OE-QuoteFix v1.19.2
    Centrino Core Duo 1.83G - 2GB - Windows XP SP3
     
    BillW50, Jun 13, 2011
    #9
  10. Jo-Anne

    Jo-Anne Guest

    "BillW50" <> wrote in message
    news:it5hqe$vl7$...
    > In news:it5c1p$lii$,
    > Jo-Anne wrote:
    >> "BillW50" <> wrote in message
    >> news:it2ks1$5hu$...
    >>> In news:it15pt$vrd$,
    >>> Jo-Anne wrote:
    >>>> I recently started playing DVDs on my WinXP laptop. Each time I put
    >>>> a DVD in the drive, it opens with PowerDVD. Since I like to use VLC
    >>>> Media Player, I close the PowerDVD window, open VLC Media Player,
    >>>> and click on the DVD drive. I'm sure there's a way to set VLC as the
    >>>> default DVD player. I'd be grateful for instructions on how to do
    >>>> this or even for a link to a website that explains it.
    >>>>
    >>>> Thank you!
    >>>>
    >>>> Jo-Anne
    >>>
    >>> I am not 100% positive this will work, but it is worth a shot. There
    >>> is a program called "USB Safely Remove". And one of the things it
    >>> can do is to run a program when it detects a given device. "USB
    >>> Safely Remove" is handy for much more than this too, so it is worth
    >>> looking into even if you can't get this to work for this purpose.
    >>>
    >>> http://safelyremove.com/

    >>
    >> Thank you, Bill! I had already bookmarked USB Safely Remove (I think
    >> from one of your earlier posts). I'll definitely check it out for this
    >> issue--although I wonder how it reacts if the media in the DVD player
    >> is simply a data CD/DVD.
    >>
    >> Jo-Anne

    >
    > Just curious, have you ever tried to change under Explorer (file manager)
    > under Tools->Folder Options and select the third tab called File Types?
    > Here the third one down is called DVD Video. Select this one and press the
    > Advanced button. It should list something like this:
    >
    > Play
    > Play with PowerDVD (in bold)
    > Play with VLC media player
    >
    > Select the VLC one. Then press the Set Default button (now this one should
    > be in bold). That should now open DVD movies with VLC instead of PowerDVD.
    >
    > --
    > Bill
    > Gateway M465e ('06 era) - OE-QuoteFix v1.19.2
    > Centrino Core Duo 1.83G - 2GB - Windows XP SP3
    >


    Hi, Bill,

    I set VLC as the default, but PowerDVD still came up. I restarted the
    computer; PowerDVD still came up. I deleted PowerDVD from the "list." It no
    longer comes up--but VLC doesn't either. I have to open VLC, click on Open
    Disc, and click Open. This is all on a DVD I had run earlier. So I tried a
    new DVD, and it makes a strange sound spinning, doesn't stop spinning, and
    VLC isn' working at all with it. I inserted one of the DVDs I had run
    before, and it works OK--although I still have to open VLC and manually
    start it.

    From what I can see, this SHOULD have worked. I can't understand why it
    hasn't--and I don't know what to do about the DVD that won't run at all.

    Thank you for the suggestion, though!

    Jo-Anne
     
    Jo-Anne, Jun 13, 2011
    #10
  11. Jo-Anne

    Jo-Anne Guest

    "Jo-Anne" <> wrote in message
    news:it5ov8$ke3$...
    > "BillW50" <> wrote in message
    > news:it5hqe$vl7$...
    >> In news:it5c1p$lii$,
    >> Jo-Anne wrote:
    >>> "BillW50" <> wrote in message
    >>> news:it2ks1$5hu$...
    >>>> In news:it15pt$vrd$,
    >>>> Jo-Anne wrote:
    >>>>> I recently started playing DVDs on my WinXP laptop. Each time I put
    >>>>> a DVD in the drive, it opens with PowerDVD. Since I like to use VLC
    >>>>> Media Player, I close the PowerDVD window, open VLC Media Player,
    >>>>> and click on the DVD drive. I'm sure there's a way to set VLC as the
    >>>>> default DVD player. I'd be grateful for instructions on how to do
    >>>>> this or even for a link to a website that explains it.
    >>>>>
    >>>>> Thank you!
    >>>>>
    >>>>> Jo-Anne
    >>>>
    >>>> I am not 100% positive this will work, but it is worth a shot. There
    >>>> is a program called "USB Safely Remove". And one of the things it
    >>>> can do is to run a program when it detects a given device. "USB
    >>>> Safely Remove" is handy for much more than this too, so it is worth
    >>>> looking into even if you can't get this to work for this purpose.
    >>>>
    >>>> http://safelyremove.com/
    >>>
    >>> Thank you, Bill! I had already bookmarked USB Safely Remove (I think
    >>> from one of your earlier posts). I'll definitely check it out for this
    >>> issue--although I wonder how it reacts if the media in the DVD player
    >>> is simply a data CD/DVD.
    >>>
    >>> Jo-Anne

    >>
    >> Just curious, have you ever tried to change under Explorer (file manager)
    >> under Tools->Folder Options and select the third tab called File Types?
    >> Here the third one down is called DVD Video. Select this one and press
    >> the Advanced button. It should list something like this:
    >>
    >> Play
    >> Play with PowerDVD (in bold)
    >> Play with VLC media player
    >>
    >> Select the VLC one. Then press the Set Default button (now this one
    >> should be in bold). That should now open DVD movies with VLC instead of
    >> PowerDVD.
    >>
    >> --
    >> Bill
    >> Gateway M465e ('06 era) - OE-QuoteFix v1.19.2
    >> Centrino Core Duo 1.83G - 2GB - Windows XP SP3
    >>

    >
    > Hi, Bill,
    >
    > I set VLC as the default, but PowerDVD still came up. I restarted the
    > computer; PowerDVD still came up. I deleted PowerDVD from the "list." It
    > no longer comes up--but VLC doesn't either. I have to open VLC, click on
    > Open Disc, and click Open. This is all on a DVD I had run earlier. So I
    > tried a new DVD, and it makes a strange sound spinning, doesn't stop
    > spinning, and VLC isn' working at all with it. I inserted one of the DVDs
    > I had run before, and it works OK--although I still have to open VLC and
    > manually start it.
    >
    > From what I can see, this SHOULD have worked. I can't understand why it
    > hasn't--and I don't know what to do about the DVD that won't run at all.
    >
    > Thank you for the suggestion, though!
    >
    > Jo-Anne
    >

    Addendum: I did finally get the new DVD to play. I don't know what went
    wrong the first time. So the only issue is having to start VLC rather than
    having it automatically play the DVDs.

    Jo-Anne
     
    Jo-Anne, Jun 13, 2011
    #11
  12. Jo-Anne

    Patok Guest

    Jo-Anne wrote:
    > "Jo-Anne" <> wrote in message
    >> "BillW50" <> wrote in message
    >>>
    >>> Jo-Anne
    >>> Just curious, have you ever tried to change under Explorer (file manager)
    >>> under Tools->Folder Options and select the third tab called File Types?
    >>> Here the third one down is called DVD Video. Select this one and press
    >>> the Advanced button. It should list something like this:
    >>>
    >>> Play
    >>> Play with PowerDVD (in bold)
    >>> Play with VLC media player
    >>>
    >>> Select the VLC one. Then press the Set Default button (now this one
    >>> should be in bold). That should now open DVD movies with VLC instead of
    >>> PowerDVD.
    >>>

    >>
    >> I set VLC as the default, but PowerDVD still came up. I restarted the
    >> computer; PowerDVD still came up. I deleted PowerDVD from the "list." It
    >> no longer comes up--but VLC doesn't either. I have to open VLC, click on
    >> Open Disc, and click Open. This is all on a DVD I had run earlier. So I
    >> tried a new DVD, and it makes a strange sound spinning, doesn't stop
    >> spinning, and VLC isn' working at all with it. I inserted one of the DVDs
    >> I had run before, and it works OK--although I still have to open VLC and
    >> manually start it.
    >>
    >> From what I can see, this SHOULD have worked. I can't understand why it
    >> hasn't--and I don't know what to do about the DVD that won't run at all.
    >>

    > Addendum: I did finally get the new DVD to play. I don't know what went
    > wrong the first time. So the only issue is having to start VLC rather than
    > having it automatically play the DVDs.


    Duh. As I wrote before, the only application that will play DVDs
    upon inserting them, is the one listed in the AutoPlay tab of your DVD
    drive, under DVD movie. (You never said what applications you see
    there.) The entry you've been setting in Folder Options, following
    Bill's advice, is for right-clicking an already inserted and
    identified DVD disk, it is *not* for automatically playing it.

    --
    You'd be crazy to e-mail me with the crazy. But leave the div alone.
    *
    Whoever bans a book, shall be banished. Whoever burns a book, shall burn.
     
    Patok, Jun 13, 2011
    #12
  13. Jo-Anne

    BillW50 Guest

    In news:it5p5g$m04$,
    Jo-Anne wrote:
    > "Jo-Anne" <> wrote in message
    > news:it5ov8$ke3$...
    >> "BillW50" <> wrote in message
    >> news:it5hqe$vl7$...
    >>> In news:it5c1p$lii$,
    >>> Jo-Anne wrote:
    >>>> "BillW50" <> wrote in message
    >>>> news:it2ks1$5hu$...
    >>>>> In news:it15pt$vrd$,
    >>>>> Jo-Anne wrote:
    >>>>>> I recently started playing DVDs on my WinXP laptop. Each time I
    >>>>>> put a DVD in the drive, it opens with PowerDVD. Since I like to
    >>>>>> use VLC Media Player, I close the PowerDVD window, open VLC
    >>>>>> Media Player, and click on the DVD drive. I'm sure there's a way
    >>>>>> to set VLC as the default DVD player. I'd be grateful for
    >>>>>> instructions on how to do this or even for a link to a website
    >>>>>> that explains it. Thank you!
    >>>>>>
    >>>>>> Jo-Anne
    >>>>>
    >>>>> I am not 100% positive this will work, but it is worth a shot.
    >>>>> There is a program called "USB Safely Remove". And one of the
    >>>>> things it can do is to run a program when it detects a given
    >>>>> device. "USB Safely Remove" is handy for much more than this too,
    >>>>> so it is worth looking into even if you can't get this to work
    >>>>> for this purpose. http://safelyremove.com/
    >>>>
    >>>> Thank you, Bill! I had already bookmarked USB Safely Remove (I
    >>>> think from one of your earlier posts). I'll definitely check it
    >>>> out for this issue--although I wonder how it reacts if the media
    >>>> in the DVD player is simply a data CD/DVD.
    >>>>
    >>>> Jo-Anne
    >>>
    >>> Just curious, have you ever tried to change under Explorer (file
    >>> manager) under Tools->Folder Options and select the third tab
    >>> called File Types? Here the third one down is called DVD Video.
    >>> Select this one and press the Advanced button. It should list
    >>> something like this: Play
    >>> Play with PowerDVD (in bold)
    >>> Play with VLC media player
    >>>
    >>> Select the VLC one. Then press the Set Default button (now this one
    >>> should be in bold). That should now open DVD movies with VLC
    >>> instead of PowerDVD.

    >>
    >> Hi, Bill,
    >>
    >> I set VLC as the default, but PowerDVD still came up. I restarted the
    >> computer; PowerDVD still came up. I deleted PowerDVD from the
    >> "list." It no longer comes up--but VLC doesn't either. I have to
    >> open VLC, click on Open Disc, and click Open. This is all on a DVD I
    >> had run earlier. So I tried a new DVD, and it makes a strange sound
    >> spinning, doesn't stop spinning, and VLC isn' working at all with
    >> it. I inserted one of the DVDs I had run before, and it works
    >> OK--although I still have to open VLC and manually start it.
    >>
    >> From what I can see, this SHOULD have worked. I can't understand why
    >> it hasn't--and I don't know what to do about the DVD that won't run
    >> at all. Thank you for the suggestion, though!
    >>
    >> Jo-Anne
    >>

    > Addendum: I did finally get the new DVD to play. I don't know what
    > went wrong the first time. So the only issue is having to start VLC
    > rather than having it automatically play the DVDs.
    >
    > Jo-Anne


    Try this, Win+R and paste in this line (including quotes):

    "C:\Program Files\VideoLAN\VLC\vlc.exe" --started-from-file dvd://d:

    The last part "d:" change to whatever your drive letter is for your DVD
    drive. In this example it is drive D. And that should start VLC and play
    the DVD. If that works and it should if your path for VLC is the same,
    let me know and we will go on from there.

    --
    Bill
    Gateway M465e ('06 era) - OE-QuoteFix v1.19.2
    Centrino Core Duo 1.83G - 2GB - Windows XP SP3
     
    BillW50, Jun 13, 2011
    #13
  14. Jo-Anne

    BillW50 Guest

    In news:it5qlq$sg$,
    Patok wrote:
    > Duh. As I wrote before, the only application that will play DVDs
    > upon inserting them, is the one listed in the AutoPlay tab of your DVD
    > drive, under DVD movie. (You never said what applications you see
    > there.) The entry you've been setting in Folder Options, following
    > Bill's advice, is for right-clicking an already inserted and
    > identified DVD disk, it is *not* for automatically playing it.


    Thanks Patok for the information. Here is something that should work if
    you have TweakUI installed.

    My Computer
    AutoPlay
    Handlers

    Here you can select VLC to autoplay DVD movies.

    You can do this without TweakUI too. Right click on the DVD drive in
    Explorer and select properties. AutoPlay tab, DVD Movie (drop down
    menu), and Select an action to perform. Then select Play DVD movie using
    VideoLAN VLC media player.

    --
    Bill
    Gateway M465e ('06 era) - OE-QuoteFix v1.19.2
    Centrino Core Duo 1.83G - 2GB - Windows XP SP3
     
    BillW50, Jun 13, 2011
    #14
  15. Jo-Anne

    Jo-Anne Guest

    "BillW50" <> wrote in message
    news:it5rm9$855$...
    > In news:it5qlq$sg$,
    > Patok wrote:
    >> Duh. As I wrote before, the only application that will play DVDs
    >> upon inserting them, is the one listed in the AutoPlay tab of your DVD
    >> drive, under DVD movie. (You never said what applications you see
    >> there.) The entry you've been setting in Folder Options, following
    >> Bill's advice, is for right-clicking an already inserted and
    >> identified DVD disk, it is *not* for automatically playing it.

    >
    > Thanks Patok for the information. Here is something that should work if
    > you have TweakUI installed.
    >
    > My Computer
    > AutoPlay
    > Handlers
    >
    > Here you can select VLC to autoplay DVD movies.
    >
    > You can do this without TweakUI too. Right click on the DVD drive in
    > Explorer and select properties. AutoPlay tab, DVD Movie (drop down menu),
    > and Select an action to perform. Then select Play DVD movie using VideoLAN
    > VLC media player.
    >
    > --
    > Bill
    > Gateway M465e ('06 era) - OE-QuoteFix v1.19.2
    > Centrino Core Duo 1.83G - 2GB - Windows XP SP3
    >

    Bingo! That did it, Bill. I do have TweakUI installed, but I didn't see an
    Autoplay option under My Compuer. So I followed your directions starting
    with right-clicking on the DVD drive. It worked! Thank you very much!

    Jo-Anne
     
    Jo-Anne, Jun 13, 2011
    #15
  16. Jo-Anne

    Jo-Anne Guest

    "Patok" <> wrote in message
    news:it5qlq$sg$...
    > Jo-Anne wrote:
    >> "Jo-Anne" <> wrote in message
    >>> "BillW50" <> wrote in message
    >>>>
    >>>> Jo-Anne
    >>>> Just curious, have you ever tried to change under Explorer (file
    >>>> manager) under Tools->Folder Options and select the third tab called
    >>>> File Types? Here the third one down is called DVD Video. Select this
    >>>> one and press the Advanced button. It should list something like this:
    >>>>
    >>>> Play
    >>>> Play with PowerDVD (in bold)
    >>>> Play with VLC media player
    >>>>
    >>>> Select the VLC one. Then press the Set Default button (now this one
    >>>> should be in bold). That should now open DVD movies with VLC instead of
    >>>> PowerDVD.
    >>>>
    >>>
    >>> I set VLC as the default, but PowerDVD still came up. I restarted the
    >>> computer; PowerDVD still came up. I deleted PowerDVD from the "list." It
    >>> no longer comes up--but VLC doesn't either. I have to open VLC, click on
    >>> Open Disc, and click Open. This is all on a DVD I had run earlier. So I
    >>> tried a new DVD, and it makes a strange sound spinning, doesn't stop
    >>> spinning, and VLC isn' working at all with it. I inserted one of the
    >>> DVDs I had run before, and it works OK--although I still have to open
    >>> VLC and manually start it.
    >>>
    >>> From what I can see, this SHOULD have worked. I can't understand why it
    >>> hasn't--and I don't know what to do about the DVD that won't run at all.
    >>>

    >> Addendum: I did finally get the new DVD to play. I don't know what went
    >> wrong the first time. So the only issue is having to start VLC rather
    >> than having it automatically play the DVDs.

    >
    > Duh. As I wrote before, the only application that will play DVDs upon
    > inserting them, is the one listed in the AutoPlay tab of your DVD drive,
    > under DVD movie. (You never said what applications you see there.) The
    > entry you've been setting in Folder Options, following Bill's advice, is
    > for right-clicking an already inserted and identified DVD disk, it is
    > *not* for automatically playing it.
    >
    > --
    > You'd be crazy to e-mail me with the crazy. But leave the div alone.
    > *
    > Whoever bans a book, shall be banished. Whoever burns a book, shall burn.



    Thank you for the information, Patok! I did manage to get Autoplay to work
    with VLC by clicking on the AutoPlay tab of the DVD drive, as you suggested
    and as Bill instructed. It works!

    Jo-Anne
     
    Jo-Anne, Jun 13, 2011
    #16
  17. Jo-Anne

    Jo-Anne Guest

    "BillW50" <> wrote in message
    news:it5r4h$4a2$...
    > In news:it5p5g$m04$,
    > Jo-Anne wrote:
    >> "Jo-Anne" <> wrote in message
    >> news:it5ov8$ke3$...
    >>> "BillW50" <> wrote in message
    >>> news:it5hqe$vl7$...
    >>>> In news:it5c1p$lii$,
    >>>> Jo-Anne wrote:
    >>>>> "BillW50" <> wrote in message
    >>>>> news:it2ks1$5hu$...
    >>>>>> In news:it15pt$vrd$,
    >>>>>> Jo-Anne wrote:
    >>>>>>> I recently started playing DVDs on my WinXP laptop. Each time I
    >>>>>>> put a DVD in the drive, it opens with PowerDVD. Since I like to
    >>>>>>> use VLC Media Player, I close the PowerDVD window, open VLC
    >>>>>>> Media Player, and click on the DVD drive. I'm sure there's a way
    >>>>>>> to set VLC as the default DVD player. I'd be grateful for
    >>>>>>> instructions on how to do this or even for a link to a website
    >>>>>>> that explains it. Thank you!
    >>>>>>>
    >>>>>>> Jo-Anne
    >>>>>>
    >>>>>> I am not 100% positive this will work, but it is worth a shot.
    >>>>>> There is a program called "USB Safely Remove". And one of the
    >>>>>> things it can do is to run a program when it detects a given
    >>>>>> device. "USB Safely Remove" is handy for much more than this too,
    >>>>>> so it is worth looking into even if you can't get this to work
    >>>>>> for this purpose. http://safelyremove.com/
    >>>>>
    >>>>> Thank you, Bill! I had already bookmarked USB Safely Remove (I
    >>>>> think from one of your earlier posts). I'll definitely check it
    >>>>> out for this issue--although I wonder how it reacts if the media
    >>>>> in the DVD player is simply a data CD/DVD.
    >>>>>
    >>>>> Jo-Anne
    >>>>
    >>>> Just curious, have you ever tried to change under Explorer (file
    >>>> manager) under Tools->Folder Options and select the third tab
    >>>> called File Types? Here the third one down is called DVD Video.
    >>>> Select this one and press the Advanced button. It should list
    >>>> something like this: Play
    >>>> Play with PowerDVD (in bold)
    >>>> Play with VLC media player
    >>>>
    >>>> Select the VLC one. Then press the Set Default button (now this one
    >>>> should be in bold). That should now open DVD movies with VLC
    >>>> instead of PowerDVD.
    >>>
    >>> Hi, Bill,
    >>>
    >>> I set VLC as the default, but PowerDVD still came up. I restarted the
    >>> computer; PowerDVD still came up. I deleted PowerDVD from the
    >>> "list." It no longer comes up--but VLC doesn't either. I have to
    >>> open VLC, click on Open Disc, and click Open. This is all on a DVD I
    >>> had run earlier. So I tried a new DVD, and it makes a strange sound
    >>> spinning, doesn't stop spinning, and VLC isn' working at all with
    >>> it. I inserted one of the DVDs I had run before, and it works
    >>> OK--although I still have to open VLC and manually start it.
    >>>
    >>> From what I can see, this SHOULD have worked. I can't understand why
    >>> it hasn't--and I don't know what to do about the DVD that won't run
    >>> at all. Thank you for the suggestion, though!
    >>>
    >>> Jo-Anne
    >>>

    >> Addendum: I did finally get the new DVD to play. I don't know what
    >> went wrong the first time. So the only issue is having to start VLC
    >> rather than having it automatically play the DVDs.
    >>
    >> Jo-Anne

    >
    > Try this, Win+R and paste in this line (including quotes):
    >
    > "C:\Program Files\VideoLAN\VLC\vlc.exe" --started-from-file dvd://d:
    >
    > The last part "d:" change to whatever your drive letter is for your DVD
    > drive. In this example it is drive D. And that should start VLC and play
    > the DVD. If that works and it should if your path for VLC is the same, let
    > me know and we will go on from there.
    >
    > --
    > Bill
    > Gateway M465e ('06 era) - OE-QuoteFix v1.19.2
    > Centrino Core Duo 1.83G - 2GB - Windows XP SP3
    >

    Thank you, Bill! I'll copy this post to my hard drive for future reference.
    As it turns out, your earlier instruction on how to set up Autoplay for the
    DVD drive (right-clicking on the drive, etc.) worked perfectly.

    Jo-Anne
     
    Jo-Anne, Jun 13, 2011
    #17
  18. Jo-Anne

    Patok Guest

    BillW50 wrote:
    > In news:it5qlq$sg$,
    > Patok wrote:
    >> Duh. As I wrote before, the only application that will play DVDs
    >> upon inserting them, is the one listed in the AutoPlay tab of your DVD
    >> drive, under DVD movie. (You never said what applications you see
    >> there.) The entry you've been setting in Folder Options, following
    >> Bill's advice, is for right-clicking an already inserted and
    >> identified DVD disk, it is *not* for automatically playing it.

    >
    > Thanks Patok for the information. Here is something that should work if
    > you have TweakUI installed.
    >
    > My Computer
    > AutoPlay
    > Handlers
    >
    > Here you can select VLC to autoplay DVD movies.
    >
    > You can do this without TweakUI too. Right click on the DVD drive in
    > Explorer and select properties. AutoPlay tab, DVD Movie (drop down
    > menu), and Select an action to perform. Then select Play DVD movie using
    > VideoLAN VLC media player.


    But can you do that? For some reason, I don't have VLC in the list
    of autoplay handlers, and I don't see any option in the VLC
    preferences to set that association. Maybe it asked once, when I was
    installing it, and I said no?

    In the meantime, I see that Jo-Anne was able to set VLC to play her
    DVDs; apparently on her system, VLC had added itself to the list of
    DVD playing programs, and all she needed to do was select it in the
    AutoPlay tab.

    However, I found that in TweakUI one can Create a new association
    in the Handlers list, and I was able to add VLC to play DVDs. So, in
    case someone doesn't have it there, here's how to do it:

    - In TweakUI, in My Computer -> AutoPlay -> Handlers, click on "Create"
    - check the desired checkboxes - DVD, etc.
    - click "Change program", find and select the desired program - on my
    comp, VLC is in "Program Files\VideoLAN\VLC\"
    - in the "Args:" field, enter "dvd://%L\"
    - write something memorable in the Description and Using fields :)
    - exit TweakUI, and then right-click on the DVD drive in Win Explorer
    - in the AutoPlay tab, select the desred type (DVD movie, etc), and
    then choose the new entry for "Select an action to perform"

    --
    You'd be crazy to e-mail me with the crazy. But leave the div alone.
    *
    Whoever bans a book, shall be banished. Whoever burns a book, shall burn.
     
    Patok, Jun 13, 2011
    #18
  19. Jo-Anne

    BillW50 Guest

    In news:it5uvr$vjt$,
    Patok wrote:
    > BillW50 wrote:
    >> In news:it5qlq$sg$,
    >> Patok wrote:
    >>> Duh. As I wrote before, the only application that will play DVDs
    >>> upon inserting them, is the one listed in the AutoPlay tab of your
    >>> DVD drive, under DVD movie. (You never said what applications you
    >>> see there.) The entry you've been setting in Folder Options,
    >>> following Bill's advice, is for right-clicking an already inserted
    >>> and identified DVD disk, it is *not* for automatically playing it.

    >>
    >> Thanks Patok for the information. Here is something that should work
    >> if you have TweakUI installed.
    >>
    >> My Computer
    >> AutoPlay
    >> Handlers
    >>
    >> Here you can select VLC to autoplay DVD movies.
    >>
    >> You can do this without TweakUI too. Right click on the DVD drive in
    >> Explorer and select properties. AutoPlay tab, DVD Movie (drop down
    >> menu), and Select an action to perform. Then select Play DVD movie
    >> using VideoLAN VLC media player.

    >
    > But can you do that? For some reason, I don't have VLC in the list
    > of autoplay handlers, and I don't see any option in the VLC
    > preferences to set that association. Maybe it asked once, when I was
    > installing it, and I said no?
    >
    > In the meantime, I see that Jo-Anne was able to set VLC to play her
    > DVDs; apparently on her system, VLC had added itself to the list of
    > DVD playing programs, and all she needed to do was select it in the
    > AutoPlay tab.
    >
    > However, I found that in TweakUI one can Create a new association
    > in the Handlers list, and I was able to add VLC to play DVDs. So, in
    > case someone doesn't have it there, here's how to do it:
    >
    > - In TweakUI, in My Computer -> AutoPlay -> Handlers, click on
    > "Create" - check the desired checkboxes - DVD, etc.
    > - click "Change program", find and select the desired program - on my
    > comp, VLC is in "Program Files\VideoLAN\VLC\"
    > - in the "Args:" field, enter "dvd://%L\"
    > - write something memorable in the Description and Using fields :)
    > - exit TweakUI, and then right-click on the DVD drive in Win Explorer
    > - in the AutoPlay tab, select the desred type (DVD movie, etc), and
    > then choose the new entry for "Select an action to perform"


    If you use custom install of VLC, I believe you need to check Discs
    Playback to have the handlers created. Not 100% sure though.

    --
    Bill
    Gateway M465e ('06 era) - OE-QuoteFix v1.19.2
    Centrino Core Duo 1.83G - 2GB - Windows XP SP3
     
    BillW50, Jun 13, 2011
    #19
  20. Jo-Anne

    BillW50 Guest

    In news:it5tap$jii$,
    Jo-Anne wrote:
    > Bingo! That did it, Bill. I do have TweakUI installed, but I didn't
    > see an Autoplay option under My Compuer. So I followed your
    > directions starting with right-clicking on the DVD drive. It worked!
    > Thank you very much!
    > Jo-Anne


    Oh that is great to hear. I'm using TweakUI v2.1. If you have the same,
    it should show up if you click the + to the left of My Computer.

    --
    Bill
    Gateway M465e ('06 era) - OE-QuoteFix v1.19.2
    Centrino Core Duo 1.83G - 2GB - Windows XP SP3
     
    BillW50, Jun 13, 2011
    #20
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mike

    Problem playing DVDs in XP.

    Mike, Jun 30, 2003, in forum: Windows XP Hardware
    Replies:
    5
    Views:
    2,336
    Alex Nichol
    Jul 1, 2003
  2. Jim Macklin

    Re: dvd drive won't read dvds

    Jim Macklin, Jul 22, 2003, in forum: Windows XP Hardware
    Replies:
    0
    Views:
    242
    Jim Macklin
    Jul 22, 2003
  3. Joe

    Drive not playing DVDs

    Joe, Jul 17, 2004, in forum: Windows XP Hardware
    Replies:
    0
    Views:
    179
  4. Guest
    Replies:
    4
    Views:
    261
    Guest
    Sep 6, 2004
  5. forest jones
    Replies:
    4
    Views:
    821
    Alec S.
    Sep 3, 2008
Loading...

Share This Page