How to permanently disable IEEE 802.1x authentication

Discussion in 'Windows XP Embedded' started by Brian, Feb 5, 2008.

  1. Brian

    Brian Guest

    We have multiple laptops in our environment that are experiencing wireless
    network connectivity problems due to the IEEE 802.1x authentication option
    being enabled. This option was disabled on our image, but is somehow
    becoming enabled on the devices once deployed. This symptom is currently
    affecting 20 out of 125 devices. The laptops have an Atheros AR5005G
    wireless card installed with the driver version 4.1.2.144

    Is there a way to permanently disable the IEEE 802.1x authentication via
    Group Policy, or registry configuration, or some other means?

    Thanks.
     
    Brian, Feb 5, 2008
    #1
    1. Advertisements

  2. Brian

    KM Guest

    Brian,

    There is Wireless Network (IEEE 802.11) Policies Group Policy Extension.
    Take a look at the picture here: http://technet.microsoft.com/en-us/library/Bb878079.cg070301(en-us,TechNet.10).gif

    To get it in your Group Policy Editor you will have to copy the following Dlls from Server 2003's (that does have the WiFi extension
    by default) system32 folder to your image's system32 folder:
    wlsnp.dll
    wlstore.dll
    ws03res.dll
    And then register the wlsnp.dll (the actual MMC extension snap-in) with regsvr32 at run time.

    Supposedly, it should work on XP Pro and XPe but I haven't tried the procedure.

    --
    =========
    Regards,
    KM


    > We have multiple laptops in our environment that are experiencing wireless
    > network connectivity problems due to the IEEE 802.1x authentication option
    > being enabled. This option was disabled on our image, but is somehow
    > becoming enabled on the devices once deployed. This symptom is currently
    > affecting 20 out of 125 devices. The laptops have an Atheros AR5005G
    > wireless card installed with the driver version 4.1.2.144
    >
    > Is there a way to permanently disable the IEEE 802.1x authentication via
    > Group Policy, or registry configuration, or some other means?
    >
    > Thanks.
     
    KM, Feb 6, 2008
    #2
    1. Advertisements

  3. Brian

    Brian Guest

    Thank you for your reply. Is there a MS KB article for this procedure? Does
    this configuration require the SSID of the wireless network? The problem
    that we are seeing is affecting home users and it would not be possible for
    us to pre-configure the SSID of each wireless network. We are looking for a
    solution that will disable IEEE 802.1x authentication regardless of which
    wireless network the user is connecting to.

    Thanks,
    Brian

    "KM" wrote:

    > Brian,
    >
    > There is Wireless Network (IEEE 802.11) Policies Group Policy Extension.
    > Take a look at the picture here: http://technet.microsoft.com/en-us/library/Bb878079.cg070301(en-us,TechNet.10).gif
    >
    > To get it in your Group Policy Editor you will have to copy the following Dlls from Server 2003's (that does have the WiFi extension
    > by default) system32 folder to your image's system32 folder:
    > wlsnp.dll
    > wlstore.dll
    > ws03res.dll
    > And then register the wlsnp.dll (the actual MMC extension snap-in) with regsvr32 at run time.
    >
    > Supposedly, it should work on XP Pro and XPe but I haven't tried the procedure.
    >
    > --
    > =========
    > Regards,
    > KM
    >
    >
    > > We have multiple laptops in our environment that are experiencing wireless
    > > network connectivity problems due to the IEEE 802.1x authentication option
    > > being enabled. This option was disabled on our image, but is somehow
    > > becoming enabled on the devices once deployed. This symptom is currently
    > > affecting 20 out of 125 devices. The laptops have an Atheros AR5005G
    > > wireless card installed with the driver version 4.1.2.144
    > >
    > > Is there a way to permanently disable the IEEE 802.1x authentication via
    > > Group Policy, or registry configuration, or some other means?
    > >
    > > Thanks.

    >
    >
    >
     
    Brian, Feb 6, 2008
    #3
  4. Brian

    KM Guest

    Brian,

    I haven't seen a KB on the subject but I never did a good search for it.
    I don't think SSID option is in wireless group policy settings.

    Are you dealing with XP Embedded image?


    Anyway, on the Web I also saw the following trick that basically allows you to disable IEEE Authentication on currently selected
    interface (batch script):
    CODE FOR /f "tokens=3 delims=\" %%i IN ('reg query "HKLM\Software\microsoft\eapol\parameters\General" /v "Interfacelist" ^|
    findstr "REG_SZ"') DO set IEEE=%%i
    ECHO y | reg add "HKLM\SOFTWARE\Microsoft\EAPOL\Parameters\Interfaces\%IEEE%" /v "1" /t REG_BINARY /d
    0300000000000000000000400D00000020000000112233112233112233112233112233112233112233112233112233112233
    11220D0000002800000000000000280000000500000000000000000000000000000000000000000000000000000000000000
    00000000


    --
    =========
    Regards,
    KM


    > Thank you for your reply. Is there a MS KB article for this procedure? Does
    > this configuration require the SSID of the wireless network? The problem
    > that we are seeing is affecting home users and it would not be possible for
    > us to pre-configure the SSID of each wireless network. We are looking for a
    > solution that will disable IEEE 802.1x authentication regardless of which
    > wireless network the user is connecting to.
    >
    > Thanks,
    > Brian
    >
    > "KM" wrote:
    >
    >> Brian,
    >>
    >> There is Wireless Network (IEEE 802.11) Policies Group Policy Extension.
    >> Take a look at the picture here: http://technet.microsoft.com/en-us/library/Bb878079.cg070301(en-us,TechNet.10).gif
    >>
    >> To get it in your Group Policy Editor you will have to copy the following Dlls from Server 2003's (that does have the WiFi
    >> extension
    >> by default) system32 folder to your image's system32 folder:
    >> wlsnp.dll
    >> wlstore.dll
    >> ws03res.dll
    >> And then register the wlsnp.dll (the actual MMC extension snap-in) with regsvr32 at run time.
    >>
    >> Supposedly, it should work on XP Pro and XPe but I haven't tried the procedure.
    >>
    >> --
    >> =========
    >> Regards,
    >> KM
    >>
    >>
    >> > We have multiple laptops in our environment that are experiencing wireless
    >> > network connectivity problems due to the IEEE 802.1x authentication option
    >> > being enabled. This option was disabled on our image, but is somehow
    >> > becoming enabled on the devices once deployed. This symptom is currently
    >> > affecting 20 out of 125 devices. The laptops have an Atheros AR5005G
    >> > wireless card installed with the driver version 4.1.2.144
    >> >
    >> > Is there a way to permanently disable the IEEE 802.1x authentication via
    >> > Group Policy, or registry configuration, or some other means?
    >> >
    >> > Thanks.

    >>
    >>
    >>
     
    KM, Feb 7, 2008
    #4
  5. Brian

    KM Guest

    I might have been wrong about the SSID.
    Please see for yourself: http://technet.microsoft.com/en-us/library/bb878079.aspx.

    Following couple links can be helpful to you too:
    http://www.petri.co.il/creating_wireless_gpo_settings.htm
    http://technet2.microsoft.com/windo...02d1-421d-bc85-af90cc0ddb261033.mspx?mfr=true

    --
    =========
    Regards,
    KM


    "KM" <konstmor@nospam_yahoo.com> wrote in message news:...
    > Brian,
    >
    > I haven't seen a KB on the subject but I never did a good search for it.
    > I don't think SSID option is in wireless group policy settings.
    >
    > Are you dealing with XP Embedded image?
    >
    >
    > Anyway, on the Web I also saw the following trick that basically allows you to disable IEEE Authentication on currently selected
    > interface (batch script):
    > CODE FOR /f "tokens=3 delims=\" %%i IN ('reg query "HKLM\Software\microsoft\eapol\parameters\General" /v "Interfacelist" ^|
    > findstr "REG_SZ"') DO set IEEE=%%i
    > ECHO y | reg add "HKLM\SOFTWARE\Microsoft\EAPOL\Parameters\Interfaces\%IEEE%" /v "1" /t REG_BINARY /d
    > 0300000000000000000000400D00000020000000112233112233112233112233112233112233112233112233112233112233
    > 11220D0000002800000000000000280000000500000000000000000000000000000000000000000000000000000000000000
    > 00000000
    >
    >
    > --
    > =========
    > Regards,
    > KM
    >
    >
    >> Thank you for your reply. Is there a MS KB article for this procedure? Does
    >> this configuration require the SSID of the wireless network? The problem
    >> that we are seeing is affecting home users and it would not be possible for
    >> us to pre-configure the SSID of each wireless network. We are looking for a
    >> solution that will disable IEEE 802.1x authentication regardless of which
    >> wireless network the user is connecting to.
    >>
    >> Thanks,
    >> Brian
    >>
    >> "KM" wrote:
    >>
    >>> Brian,
    >>>
    >>> There is Wireless Network (IEEE 802.11) Policies Group Policy Extension.
    >>> Take a look at the picture here: http://technet.microsoft.com/en-us/library/Bb878079.cg070301(en-us,TechNet.10).gif
    >>>
    >>> To get it in your Group Policy Editor you will have to copy the following Dlls from Server 2003's (that does have the WiFi
    >>> extension
    >>> by default) system32 folder to your image's system32 folder:
    >>> wlsnp.dll
    >>> wlstore.dll
    >>> ws03res.dll
    >>> And then register the wlsnp.dll (the actual MMC extension snap-in) with regsvr32 at run time.
    >>>
    >>> Supposedly, it should work on XP Pro and XPe but I haven't tried the procedure.
    >>>
    >>> --
    >>> =========
    >>> Regards,
    >>> KM
    >>>
    >>>
    >>> > We have multiple laptops in our environment that are experiencing wireless
    >>> > network connectivity problems due to the IEEE 802.1x authentication option
    >>> > being enabled. This option was disabled on our image, but is somehow
    >>> > becoming enabled on the devices once deployed. This symptom is currently
    >>> > affecting 20 out of 125 devices. The laptops have an Atheros AR5005G
    >>> > wireless card installed with the driver version 4.1.2.144
    >>> >
    >>> > Is there a way to permanently disable the IEEE 802.1x authentication via
    >>> > Group Policy, or registry configuration, or some other means?
    >>> >
    >>> > Thanks.
    >>>
    >>>
    >>>

    >
    >
     
    KM, Feb 7, 2008
    #5
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    0
    Views:
    772
  2. Paul Barber

    svchost.exe memory errors with 802.1x authentication.

    Paul Barber, Dec 26, 2003, in forum: Windows XP Embedded
    Replies:
    1
    Views:
    363
    Brad Combs
    Dec 29, 2003
  3. Paul Barber

    svchost.exe memory errors with 802.1x authentication.

    Paul Barber, Dec 26, 2003, in forum: Windows XP Embedded
    Replies:
    0
    Views:
    245
    Paul Barber
    Dec 26, 2003
  4. Bruce Backus

    802.11 - 802.1x using eap-tls

    Bruce Backus, Feb 17, 2005, in forum: Windows XP Embedded
    Replies:
    6
    Views:
    227
    Bruce Backus
    Feb 21, 2005
  5. Guest

    802.1x Computer-only authentication

    Guest, Mar 15, 2006, in forum: Windows XP Embedded
    Replies:
    0
    Views:
    588
    Guest
    Mar 15, 2006
Loading...

Share This Page