Cannot send mail - Helo command rejected error

Discussion in 'Microsoft Outlook' started by Guest, Dec 13, 2004.

  1. Guest

    Guest Guest

    When I try to send email in Outlook 2000, I get this message:

    "The message could not be sent because one of the recipients was
    rejected by the server. Server Response: '504<yourxhtr8hvc4p>:Helo
    command rejected: need fully-qualified hostname'.
    (Account: 'pop.kent.edu', SMTP Server: 'smtp.kent.edu', Error Number
    0x800ccc79)"

    I have the right smtp server for outgoing mail, and the system admin of that
    server says it's not a server problem. Help please!
     
    Guest, Dec 13, 2004
    #1
    1. Advertisements

  2. "vesperholly" <> wrote in message
    news:...
    > When I try to send email in Outlook 2000, I get this message:
    >
    > "The message could not be sent because one of the recipients was
    > rejected by the server. Server Response: '504<yourxhtr8hvc4p>:Helo
    > command rejected: need fully-qualified hostname'.
    > (Account: 'pop.kent.edu', SMTP Server: 'smtp.kent.edu', Error Number
    > 0x800ccc79)"
    >
    > I have the right smtp server for outgoing mail, and the system admin of
    > that
    > server says it's not a server problem. Help please!


    Sounds like you may not have a complete e-mail address for one of your
    recipients. i.e or whatever. Double-check the e-mail
    address(es) you sent to.


    --
    Aloha,

    -Ben-
    Ben M. Schorr, OneNote-MVP
    Stockholm Consulting Group/KSG
    http://www.scgab.com
    Microsoft OneNote FAQ:
    http://home.hawaii.rr.com/schorr/computers/onenotefaq.htm

    **I apologize but I am unable to respond to direct requests for assistance.
    Please post questions and replies here in the newsgroup. Mahalo!
     
    Ben M. Schorr - MVP OneNote, Dec 13, 2004
    #2
    1. Advertisements

  3. Guest

    Guest Guest

    Hi, thanks but the email is 100% correct. I've checked it again and again. I
    am trying to send a test mail to my account, and a test email to another
    account of mine. Could this error be coming from some kind of hidden
    firewall? I disabled the Windows XP one, but in a file sharing program I
    have, I am behind a firewall still. I have Norton AntiVirus but I am not
    aware if it has a firewall. Thanks!

    "Ben M. Schorr - MVP OneNote" wrote:

    > "vesperholly" <> wrote in message
    > news:...
    > > When I try to send email in Outlook 2000, I get this message:
    > >
    > > "The message could not be sent because one of the recipients was
    > > rejected by the server. Server Response: '504<yourxhtr8hvc4p>:Helo
    > > command rejected: need fully-qualified hostname'.
    > > (Account: 'pop.kent.edu', SMTP Server: 'smtp.kent.edu', Error Number
    > > 0x800ccc79)"
    > >
    > > I have the right smtp server for outgoing mail, and the system admin of
    > > that
    > > server says it's not a server problem. Help please!

    >
    > Sounds like you may not have a complete e-mail address for one of your
    > recipients. i.e or whatever. Double-check the e-mail
    > address(es) you sent to.
    >
    >
    > --
    > Aloha,
    >
    > -Ben-
    > Ben M. Schorr, OneNote-MVP
    > Stockholm Consulting Group/KSG
    > http://www.scgab.com
    > Microsoft OneNote FAQ:
    > http://home.hawaii.rr.com/schorr/computers/onenotefaq.htm
    >
    > **I apologize but I am unable to respond to direct requests for assistance.
    > Please post questions and replies here in the newsgroup. Mahalo!
    >
    >
    >
     
    Guest, Dec 13, 2004
    #3
  4. You're going to need to talk to your mail provider about the best way to
    resolve this. What's happening is that when Outlook connects to your mail
    provider's server it sends your computer name, say "mycomputer", but the
    server requires that the name be a "fully qualified hostname" - something
    like "mycomputer.kent.edu".

    You could try just changing your computer name to something like the latter
    form, but it may well be that the server will try and look up the address
    for that name, not find it (or find it but with a different address) and
    continue to reject your connection. If that's the case, you'll need to
    talk to your provider to figure out what you need to do.

    --
    Jeff Stephenson
    Outlook Development
    This posting is provided "AS IS" with no warranties, and confers no rights

    On Sun, 12 Dec 2004 23:29:02 -0800, vesperholly wrote:

    > Hi, thanks but the email is 100% correct. I've checked it again and
    > again. I am trying to send a test mail to my account, and a test email
    > to another account of mine. Could this error be coming from some kind of
    > hidden firewall? I disabled the Windows XP one, but in a file sharing
    > program I have, I am behind a firewall still. I have Norton AntiVirus
    > but I am not aware if it has a firewall. Thanks!
    >
    > "Ben M. Schorr - MVP OneNote" wrote:
    >
    >> "vesperholly" <> wrote in message
    >> news:...
    >>> When I try to send email in Outlook 2000, I get this message:
    >>>
    >>> "The message could not be sent because one of the recipients was
    >>> rejected by the server. Server Response: '504<yourxhtr8hvc4p>:Helo
    >>> command rejected: need fully-qualified hostname'.
    >>> (Account: 'pop.kent.edu', SMTP Server: 'smtp.kent.edu', Error Number
    >>> 0x800ccc79)"
    >>>
    >>> I have the right smtp server for outgoing mail, and the system admin of
    >>> that
    >>> server says it's not a server problem. Help please!

    >>
    >> Sounds like you may not have a complete e-mail address for one of your
    >> recipients. i.e or whatever. Double-check the e-mail
    >> address(es) you sent to.
    >>
    >>
    >> --
    >> Aloha,
    >>
    >> -Ben-
    >> Ben M. Schorr, OneNote-MVP
    >> Stockholm Consulting Group/KSG
    >> http://www.scgab.com
    >> Microsoft OneNote FAQ:
    >> http://home.hawaii.rr.com/schorr/computers/onenotefaq.htm
    >>
    >> **I apologize but I am unable to respond to direct requests for
    >> assistance. Please post questions and replies here in the newsgroup.
    >> Mahalo!
    >>
    >>
    >>
     
    Jeff Stephenson [MSFT], Dec 13, 2004
    #4
  5. Jeff Stephenson [MSFT] <> wrote:

    > You could try just changing your computer name to something like the
    > latter form, but it may well be that the server will try and look up
    > the address for that name, not find it (or find it but with a
    > different address) and continue to reject your connection. If that's
    > the case, you'll need to talk to your provider to figure out what you
    > need to do.


    The better way is to configure the TCP/IP connection to supply the domain.
    Right-click My Network Places and choose Properties. Right-click the
    network interface providing the link to yoru ISP and choose Properties.
    Select Internet Protocol (TCP/IP) and click Properties. Click Advanced,
    then the DNS tab. At the bottom, include the ISP's domain (kent.edu, for
    example, as you stated) in the "DNS suffix for this connection" box.
    --
    Brian Tillman
     
    Brian Tillman, Dec 13, 2004
    #5
  6. Guest

    Guest Guest

    Thanks for your help, but I really don't think it's an ISP or server problem.
    Two days ago I could download mail just fine. The only thing that's changed
    since then is I had to do a System Restore which wiped my settings. I had to
    go back and manually take down the Norton firewall and WinXP firewall,
    reinstall programs, etc. Some kind of default has been turned on, that used
    to be off, that now won't let my SMTP connect but I can't figure out what it
    is.

    I think the key lies in HELO command and fully-qualified host name. I tried
    changing it to my name, and then to my ISP's domain name (not kent.edu but
    xyz.net), and STILL no go! Any more ideas?

    "Brian Tillman" wrote:

    > Jeff Stephenson [MSFT] <> wrote:
    >
    > > You could try just changing your computer name to something like the
    > > latter form, but it may well be that the server will try and look up
    > > the address for that name, not find it (or find it but with a
    > > different address) and continue to reject your connection. If that's
    > > the case, you'll need to talk to your provider to figure out what you
    > > need to do.

    >
    > The better way is to configure the TCP/IP connection to supply the domain.
    > Right-click My Network Places and choose Properties. Right-click the
    > network interface providing the link to yoru ISP and choose Properties.
    > Select Internet Protocol (TCP/IP) and click Properties. Click Advanced,
    > then the DNS tab. At the bottom, include the ISP's domain (kent.edu, for
    > example, as you stated) in the "DNS suffix for this connection" box.
    > --
    > Brian Tillman
    >
    >
     
    Guest, Dec 14, 2004
    #6
  7. vesperholly <> wrote:

    > Two days ago I could download mail just fine. The only thing
    > that's changed since then is I had to do a System Restore which wiped
    > my settings. I had to go back and manually take down the Norton
    > firewall and WinXP firewall, reinstall programs, etc.


    You're running two firewalls simultaneously? Unnecessary. Choose one and
    run it. Frankly, with how many problems have been reported with Norton
    products on Windows XP SP2, I'd choose the Windows firewall or one of the
    (excellent) freeware firewalls before choosing Norton. I'd also make sure
    the Norton antivirus was uninstalled completely and then reinstalled without
    the mail scanning feature. This, too, has caused more headaches for more
    people.
    --
    Brian Tillman
     
    Brian Tillman, Dec 14, 2004
    #7
  8. Guest

    Guest Guest

    From what I've been able to find out, both Outlook and Outlook Express use
    the NETBIOS name for the helo command. I have several users who would like to
    use OE or Outlook to send mail through our server, but policy dictates that
    the helo command contains the fqdn.

    I've been digging around on Google for a week and haven't found anything
    close to the solution. Is there a registry setting we can do that tells
    Outlook and OE to use the Internet settings instead of NETBIOS?

    By the way, non Microsoft email clients work fine for our other users so
    it's not a configuration issue on the server side. The mail logs show that
    the helo command only contains the netbios name. Here's an example:

    May 12 13:59:37 www postfix/smtpd[2648]: NOQUEUE: reject: RCPT from
    wsip-x.x.x.cox.net[x.x.x.x]: 504 <SP6100GORMAN>: Helo command rejected: need
    fully-qualified hostname; from=<> to=<>
    proto=ESMTP helo=<SP6100GORMAN>

    The actual host name of that PC is SP6100-GORMAN so it even pulls the dash
    out.

    Greg

    "Brian Tillman" wrote:

    > vesperholly <> wrote:
    >
    > > Two days ago I could download mail just fine. The only thing
    > > that's changed since then is I had to do a System Restore which wiped
    > > my settings. I had to go back and manually take down the Norton
    > > firewall and WinXP firewall, reinstall programs, etc.

    >
    > You're running two firewalls simultaneously? Unnecessary. Choose one and
    > run it. Frankly, with how many problems have been reported with Norton
    > products on Windows XP SP2, I'd choose the Windows firewall or one of the
    > (excellent) freeware firewalls before choosing Norton. I'd also make sure
    > the Norton antivirus was uninstalled completely and then reinstalled without
    > the mail scanning feature. This, too, has caused more headaches for more
    > people.
    > --
    > Brian Tillman
    >
    >
     
    Guest, May 13, 2005
    #8
  9. Guest

    williebuilt72

    Joined:
    Jan 7, 2009
    Messages:
    1
    Likes Received:
    0
    Just a note to say I followed Brian Tillman's

    suggestion to modify the TCP/IP connection.
    Not sure why it works, but it does! My IP
    says to leave this area blank.

    I also noted that on the home page for this
    forum there is a reference to the problem
    and to use RegCure to solve it. I am using
    RegCure, but did not notice this until I
    logged on to write this note. I am curious
    now, but will not try it now that I have things
    working!

    This is puzzling in that why did it pop up
    after 8 months of use? And of course,
    everyone points the finger at the other guy!
    I talked with my ISP rep who had worked for
    other ISPs who offered the solution to problems
    like this. However, my ISP provides limited
    support to OE, and not helping their customers
    with this problem has ticked numerous people
    off. The rep stated the solution was very simple
    and could be provided in seconds, but he couldn't
    because of policy! I am thinking about makiing
    a change!

    williebuilt72
     
    williebuilt72, Jan 7, 2009
    #9
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. TheDon
    Replies:
    1
    Views:
    405
    CWatters
    Nov 9, 2003
  2. dhicks
    Replies:
    1
    Views:
    790
    Brian Tillman
    Jan 16, 2004
  3. Dfm

    Mail rejected

    Dfm, Sep 22, 2004, in forum: Microsoft Outlook
    Replies:
    6
    Views:
    205
  4. Dan

    Avoiding a "Bogus HELO" error

    Dan, Oct 6, 2004, in forum: Microsoft Outlook
    Replies:
    7
    Views:
    1,011
    Vanguardx
    Oct 7, 2004
  5. Gabe Grall

    Rejected by POST filter? can't send attachments?

    Gabe Grall, Jan 31, 2008, in forum: Microsoft Outlook
    Replies:
    4
    Views:
    249
    Brian Tillman
    Feb 1, 2008
Loading...

Share This Page