One other thing to consider - "Status" is used as a property name for
several type of objects. I generally try to avoid using any name which might
conflict with a built-in name, property or keyword. As a general rule, most
common names can easily be adapted by adding a prefix which tells "what kind
of" thing it is. So if this is an order status, then "OrderStatus" becomes
the name. I *always* do this with 'name', 'date', 'status', 'id' (and many
other) type of fields. It's a bit more trouble on the front-end but saves
costly time in debugging the odd errors that can occur *plus* it makes your
code more readable. I know from experience that the code I wrote 3 years ago
doesn't make nearly as much sense today unless I consistantly used
descriptive names.